Updating Archer C7 v2 to 21.02.2 from Chaos Calmer

I'm on Chaos Calmer on my Archer C7 v2 for years now. Tried a LEDE build at one stage, but I had issues with my 2.4GHz wifi dropping out, so I went back to Chaos Calmer.
As this build is out of support and has security issues, I want to upgrade to 21.02.2 and have downloaded the sysupgrade.bin build (5.7MB). I understand that I can't keep my existing settings, but I have created a backup and I can use that as a basis for manually updating my new install.

The documentation is confusing me somewhat as it implies that I can't just sysupgrade using LuCi web interface or am I reading it wrongly? Should I be downloading the factory.bin (16.3MB) build and using the LuCI web interface to upgrade with that?

Thanks for any pointers!

Sysupgrade is not supported for upgrading from 15.05 to 21.02.2

You'll need to upgrade to 19.07 first, then 21.02.2

Ok - thanks! It seems that I was correct in inferring that I could not go direct to 21.02 from 15.05.

So, I take it that I would use Luci web sysupgrade from 15.05 to 19.07 without keeping any settings and once rebooted safely I would sysupgrade to 21.02 and then manually configure my settings? I presume I can't just restore my saved settings once I'm on 21.02?
What was throwing me was the statement that a sysupgrade was a complete replacement (once I was on an OpenWRT build), so I thought the 21.02 bin file would just overwrite the current binary. I'm used to flashing binary images on satellite receivers, but these are complete replacements and don't need intermediate steps. There is obviously an interim state in the OpenWRT images which requires a two step approach? Does this have to do with the change in target?

This device actually had a target migration (ar71xx > ath79) when 19.07 was released. Therefore, you probably will need to do 3 steps.

  1. 15.05 > 19.07 ar71xx [if this doesn't work, try 18.06]
  2. 19.07 ar71xx [or 18.06] > 19.07 ath79
  3. 19.07 ath79 > 21.02 ath79

DO NOT attempt to keep settings during any of these upgrades. Likewise, don't restore a backup from your old config. It is probably best to do a reset to defaults before you begin the update process... then for each update, make sure that "Keep settings" is deselected.

Before you start, I'd recommend that you take a backup that you can use as a reference, but you'll need to recreate all your settings from scratch.

You will get a warning on the 2nd update (for the ath79 transition). You can go ahead and continue, provided that the checksum matches with the download site and that you have selected the correct firmware image


See the release notes for 19.07.0 and 21.02.0 -

Thanks, guys.

As @psherman suggests, it might be best to sysupgrade to 19.07 ar71xx first, followed by sysupgrade to 19.07 ath79, followed by sysupgrade to 21.02.2. I don't think it's advised to try and go direct from 19.07 ar71xx to 21.02.2, perhaps? I know he is not using an Archer C7 v2, whereas you are, so maybe your experience is slightly different.

It may work, but IMO, best to take the extra step just in case.

1 Like

See this section in the 21.02.0 release notes -

1 Like

Another option would be Installation or restore with TFTP

Thanks guys. I went from 15.05 to 19.07 (ar71xx) to 19.07 (ath79) to 21.02.2
The main scary bit was when I changed back from the default 192.168.1.x to 192.168.0.x addressing scheme and I couldn't seem to access the web config page. I found that the edit hadn't been accepted and I ended up having to force the change. The only other hitch I had was with the WiFi config as I didn't spot that I had to link the WiFi to the LAN :thinking:

All seems to be good at this stage, thanks for the advice.

Just over 5 days after I had updated, I have had an issue where my 2.4GHz just disassociated my connections last night. Nothing in the kernel or system logs other than the two 2.4GHz clients disassociated. No increase in system load or memory usage evident. There had been an increase in usage of 2.4GHz in the previous couple of days due to grandkids i-Pads on the system but they had left several hours previous. I restarted the 2.4 wireless and the stations were able to reconnect, but the issue happened again 30 minutes later. I rebooted and the problem hasn't returned in the following 18 hours.

This issue seems exactly like the problem I had when I initially upgraded to LEDE several years ago. I couldn't resolve it at the time, so I dropped back to 15.05.1 and that has been rock-solid. It occasionally would be running for months at a time.

I've searched the forum and there seems to be a lot of theories as to what is causing this - ath10k drivers (strange as the problem happens on 2.4GHz for me), memory issues etc. etc.

For the moment, I've set up a cron job to reboot at 04.30 each morning, but it seems like a stupid partial workaround. Is there any merit in me starting yet another thread about this problem?

I'm beginning to regret my decision to move to a newer, supported version on OpenWRT. :face_holding_back_tears:

Try the following...

Uncheck "Disable Inactivity Polling".

Increase the value in "Station inactivity limit".

I set mine to 10 hours.

I have a couple of static devices that were getting kicked when I didn't want them kicked, so that solved it.

Ok - I see that your setting is for wlan0, which on my setup is the 5GHz radio. I presume I should adjust it to wlan1, which is for 2.4GHz on my router?

I've changed a couple of settings so far, so I don't want to try more just yet, as it seems to be difficult to establish the real cause of the issue.

Do you think there is merit in changing the atk10k drivers as suggested in many of the threads?

I use the settings for both 2.4 and 5.

I use the ct-smallbuffers driver currently.

To go from CT to CT-Smallbuffers -

opkg remove kmod-ath10k-ct
opkg update && opkg install kmod-ath10k-ct-smallbuffers
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.