Updated to 23.05 and nothing worked. Fresh settings helped but some radios will not work (MR8300)

Hi i updated my MR8300 from 22.03.5 to 23.05.0 and kept settings. Pretty much everything was broken at that point. None of the LAN ports were working, wi-fi "connected" but my phone kept disconnecting every second over and over again.

I managed to get most of my router up and running with a fresh setting reset but 2 out of 3 of my wi-fi radios will not work. In the wireless page they are all created, but radio0 and radio2 say "disabled" even though they are enabled. The button where you would normally click Enable says Disable so that page seems to think they are enabled as well.

I think the issue is on the Network>Interfaces>Devices page. There is only "phy1-ap0" which is mapped to radio1 and does work. phy0-ap0 which should be mapped to radio0 and phy2-ap0 which should be mapped to radio2 do not exist. I cannot seem to create them either.

Am I encountering some kind of bug? When I try and "Add device configuration" to make a phy0-ap0 or phy2-ap0 I cannot. The names get wiped out when I try and Save the config and clicking "Existing device" drop down is empty.

Thank you for your help and up until this latest release I had 0 problems with OpenWrt. It's been a God send.

Did you read the release notes, and follow the advice for your device?

ipq40xx EA6350v3, EA8300 and MR8300 require tweak to the U-Boot environment on update from 22.03 to 23.05. Refer to the Device wiki or the instruction on sysupgrade on how to do this change. Config needs to be reset on sysupgrade.

2 Likes

That is precisely what you MUST NOT do !
You need:

  • to change a boot variable, but I assume you have done it otherwise it couldn't boot.
  • not to keep settings, meaning you must reconfigure from scratch. This because the device now runs with DSA and the network configuration is different.

Reflash OpenWrt, this time NOT keeping settings. Reconfigure from scratch.

1 Like

Sorry forgot to mention yes I did increase the allowance to 5mb to update. I wouldn't have been able to update without doing that.

Were you trying to point out "Config needs to be reset on sysupgrade."? I thought that means change it back to 3mb from 5mb. If they meant a clean state then Settings would have been a more appropriate wording for that.

Either way I did a fresh install and 2 radios still do not work same as in my original post.

2 Likes

I ended up configuring from scratch and the only issue is the one in my original post, 2 of the radios will not enable and are missing from interface>Devices and i cannot add them

I was trying to point both.
Not familiar with device itself, but the advice in wiki is pretty clear...

Do not try to restore any previous 22.03 config file, it isn't compatible. The device now runs with DSA and need to be configured from scratch (meanwhile advanced users may know how to manually restore some settings). Backup your settings.

2 Likes

In the CLI, rm /etc/config/wireless and reboot to be sure you have a clean default wireless configuration, then start from there. Make sure to set your country code, the same country on all radios.

Do not reference wireless devices in the network device and interface pages. Wireless will have automatically generated names which will attach to the network specified in the wireless configuration.

Note that on this hardware, one of the 5 GHz radios only works in the low part of the band (channel 64 or lower) and the other one only on the high part of the band (channel 100 or higher). The order of enumerating the radios may have changed in the new version.

3 Likes

Follow @mk24 's answer, I can't tell better.
There should be no issue in detecting wifis with a fresh install.

1 Like

Thank you for the reply. I removed that config and started again with no solution.

I confirmed the country is set properly on all radios using cli "iw reg get". They are all set to the same with the one that works and the two that do not.

From your suggestions, the only issue that could remain would be the channel number. Unless they are improperly being displayed and were changed behind the scenes, one of them can only be set below 64 and the other above 100. This used to be the behavior on the 22.03.05 as well but I cannot rememebr which one was which

You did bring to my attention that it's both 5 ghz radios that do not work and the 2.4 works fine which is strange.

Here is the wifi config for my device (fake ssid and password of course).

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option band '5g'
	option htmode 'VHT80'
	option txpower '17'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'ssid0'
	option encryption 'psk2'
	option key 'password'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '1'
	option band '2g'
	option htmode 'HT40'
	option txpower '17'
	option country 'FR'
	option cell_density '0'
	option noscan '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'ssid1'
	option encryption 'psk2'
	option key 'password'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option txpower '20'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'ssid2'
	option encryption 'psk2'
	option key 'password'

My config looks similar to yours. Even though the networks says disabled on that page it seems they are still broadcasting. When I try to connect with my device, after about 10 seconds of my devices trying to obtain connection info I can see this posted in the OpenWrt System Log. I can connect to the 2.4 ghz radio fine and internet works.

daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)

I found various results (from older versions of OpenWRT) and they never got it fixed and ended up downgrading.

does anything look off in these logs? I still cannot get my 5ghz radios to work. I tried various settings. I see various entries like permission denied etc. In these logs I was trying various settings so that's why it goes up and down. Thank you.

Mon Nov 13 08:44:11 2023 daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Mon Nov 13 08:45:14 2023 kern.info kernel: [300328.041950] device phy2-ap0 left promiscuous mode
Mon Nov 13 08:45:14 2023 kern.info kernel: [300328.042211] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:45:14 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: Set new config for phy phy2: /var/run/hostapd-phy2.conf
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: Restart interface for phy phy2
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: Remove interface 'phy2'
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: phy2-ap0: interface state DFS->DISABLED
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: phy2-ap0: AP-DISABLED
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: phy2-ap0: CTRL-EVENT-TERMINATING
Mon Nov 13 08:45:14 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Nov 13 08:45:14 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface phy2-ap0 wasn't started
Mon Nov 13 08:45:14 2023 daemon.notice hostapd: nl80211: deinit ifname=phy2-ap0 disabled_11b_rates=0
Mon Nov 13 08:45:14 2023 kern.warn kernel: [300329.001670] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0
Mon Nov 13 08:45:15 2023 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=CA ieee80211d=1 ieee80211h=1 hw_mode=a beacon_int=100 chanlist=60 tx_queue_data2_burst=2.0 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40] ieee80211ac=1 vht_oper_chwidth=1 vht_oper_centr_freq_seg0_idx=58 vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-2][BF-ANTENNA-3][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7] channel=60  interface=phy2-ap0 bssid=ea:9f:80:ac:16:c4 ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=1 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=1 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 sae_require_mfp=1 sae_pwe=2 wpa_passp
Mon Nov 13 08:45:16 2023 kern.warn kernel: [300330.689499] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Mon Nov 13 08:45:16 2023 kern.warn kernel: [300330.689580] ath10k_ahb a800000.wifi: msdu-desc: 2500  skid: 32
Mon Nov 13 08:45:16 2023 daemon.info dnsmasq[1]: read /etc/hosts - 6 names
Mon Nov 13 08:45:16 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Mon Nov 13 08:45:16 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Nov 13 08:45:16 2023 daemon.warn dnsmasq-dhcp[1]: not giving name dell.lan to the DHCP lease of 192.168.0.181 because the name exists in /tmp/hosts/dhcp.cfg01411c with address 192.168.0.145
Mon Nov 13 08:45:16 2023 daemon.warn dnsmasq-dhcp[1]: not giving name dell to the DHCP lease of 192.168.0.181 because the name exists in /tmp/hosts/dhcp.cfg01411c with address 192.168.0.145
Mon Nov 13 08:45:16 2023 kern.info kernel: [300330.738523] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Mon Nov 13 08:45:16 2023 kern.info kernel: [300330.739514] ath10k_ahb a800000.wifi: wmi print 'free: 53252 iram: 13432 sram: 35752'
Mon Nov 13 08:45:17 2023 kern.info kernel: [300331.061806] ath10k_ahb a800000.wifi: rts threshold -1
Mon Nov 13 08:45:17 2023 kern.warn kernel: [300331.063581] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Nov 13 08:45:17 2023 kern.info kernel: [300331.082207] br-lan: port 6(phy2-ap0) entered blocking state
Mon Nov 13 08:45:17 2023 kern.info kernel: [300331.082270] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:45:17 2023 kern.info kernel: [300331.087347] device phy2-ap0 entered promiscuous mode
Mon Nov 13 08:45:17 2023 daemon.notice hostapd: phy2-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Nov 13 08:45:17 2023 daemon.notice hostapd: phy2-ap0: interface state COUNTRY_UPDATE->HT_SCAN
Mon Nov 13 08:45:17 2023 daemon.notice netifd: Wireless device 'radio2' is now up
Mon Nov 13 08:45:17 2023 daemon.notice hostapd: phy2-ap0: interface state HT_SCAN->DFS
Mon Nov 13 08:45:17 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-START freq=5300 chan=60 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Mon Nov 13 08:45:44 2023 daemon.notice hostapd: Set new config for phy phy2:
Mon Nov 13 08:45:44 2023 daemon.notice hostapd: Remove interface 'phy2'
Mon Nov 13 08:45:44 2023 daemon.notice hostapd: phy2-ap0: interface state DFS->DISABLED
Mon Nov 13 08:45:44 2023 daemon.notice hostapd: phy2-ap0: AP-DISABLED
Mon Nov 13 08:45:44 2023 daemon.notice hostapd: phy2-ap0: CTRL-EVENT-TERMINATING
Mon Nov 13 08:45:44 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Nov 13 08:45:44 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface phy2-ap0 wasn't started
Mon Nov 13 08:45:44 2023 daemon.notice hostapd: nl80211: deinit ifname=phy2-ap0 disabled_11b_rates=0
Mon Nov 13 08:45:44 2023 kern.info kernel: [300358.603599] device phy2-ap0 left promiscuous mode
Mon Nov 13 08:45:44 2023 kern.info kernel: [300358.603865] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:45:44 2023 kern.info kernel: [300358.701022] ath10k_ahb a800000.wifi: mac flush null vif, drop 0 queues 0xffff
Mon Nov 13 08:45:44 2023 kern.warn kernel: [300358.701517] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0
Mon Nov 13 08:45:45 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:45:45 2023 daemon.notice netifd: Wireless device 'radio2' is now down
Mon Nov 13 08:45:45 2023 daemon.notice netifd: radio2 (10893): WARNING: Variable 'data' does not exist or is not an array/object
Mon Nov 13 08:45:45 2023 daemon.notice hostapd: Set new config for phy phy2:
Mon Nov 13 08:45:45 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:45:45 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:45:45 2023 daemon.notice hostapd: Set new config for phy phy2: /var/run/hostapd-phy2.conf
Mon Nov 13 08:45:45 2023 daemon.notice hostapd: Restart interface for phy phy2
Mon Nov 13 08:45:46 2023 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=CA ieee80211d=1 ieee80211h=1 hw_mode=a beacon_int=100 chanlist=60 tx_queue_data2_burst=2.0 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40] ieee80211ac=1 vht_oper_chwidth=1 vht_oper_centr_freq_seg0_idx=58 vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-2][BF-ANTENNA-3][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7] channel=60  interface=phy2-ap0 bssid=ea:9f:80:ac:16:c4 ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=1 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=1 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 sae_require_mfp=1 sae_pwe=2 wpa_passp
Mon Nov 13 08:45:47 2023 kern.warn kernel: [300361.489136] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Mon Nov 13 08:45:47 2023 kern.warn kernel: [300361.489221] ath10k_ahb a800000.wifi: msdu-desc: 2500  skid: 32
Mon Nov 13 08:45:47 2023 kern.info kernel: [300361.538469] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Mon Nov 13 08:45:47 2023 kern.info kernel: [300361.543180] ath10k_ahb a800000.wifi: wmi print 'free: 53252 iram: 13432 sram: 35752'
Mon Nov 13 08:45:47 2023 kern.info kernel: [300361.873900] ath10k_ahb a800000.wifi: rts threshold -1
Mon Nov 13 08:45:47 2023 kern.warn kernel: [300361.875224] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Nov 13 08:45:47 2023 kern.info kernel: [300361.880643] br-lan: port 6(phy2-ap0) entered blocking state
Mon Nov 13 08:45:47 2023 kern.info kernel: [300361.889269] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:45:47 2023 kern.info kernel: [300361.895703] device phy2-ap0 entered promiscuous mode
Mon Nov 13 08:45:47 2023 daemon.notice hostapd: phy2-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Nov 13 08:45:47 2023 daemon.notice hostapd: phy2-ap0: interface state COUNTRY_UPDATE->HT_SCAN
Mon Nov 13 08:45:48 2023 daemon.notice netifd: Wireless device 'radio2' is now up
Mon Nov 13 08:45:48 2023 daemon.notice hostapd: phy2-ap0: interface state HT_SCAN->DFS
Mon Nov 13 08:45:48 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-START freq=5300 chan=60 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Mon Nov 13 08:46:00 2023 daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Mon Nov 13 08:46:47 2023 kern.info kernel: [300421.374139] device phy2-ap0 left promiscuous mode
Mon Nov 13 08:46:47 2023 kern.info kernel: [300421.374366] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:46:48 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: Set new config for phy phy2: /var/run/hostapd-phy2.conf
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: Restart interface for phy phy2
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: Remove interface 'phy2'
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: phy2-ap0: interface state DFS->DISABLED
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: phy2-ap0: AP-DISABLED
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: phy2-ap0: CTRL-EVENT-TERMINATING
Mon Nov 13 08:46:48 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Nov 13 08:46:48 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface phy2-ap0 wasn't started
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: nl80211: deinit ifname=phy2-ap0 disabled_11b_rates=0
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: nl80211: Failed to remove interface phy2-ap0 from bridge br-lan: Invalid argument
Mon Nov 13 08:46:48 2023 kern.info kernel: [300422.351423] ath10k_ahb a800000.wifi: mac flush null vif, drop 0 queues 0xffff
Mon Nov 13 08:46:48 2023 kern.warn kernel: [300422.352187] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0
Mon Nov 13 08:46:48 2023 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=CA ieee80211d=1 ieee80211h=1 hw_mode=a beacon_int=100 chanlist=52 tx_queue_data2_burst=2.0 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40] ieee80211ac=1 vht_oper_chwidth=1 vht_oper_centr_freq_seg0_idx=58 vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-2][BF-ANTENNA-3][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7] channel=52  interface=phy2-ap0 bssid=ea:9f:80:ac:16:c4 ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=1 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=1 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 sae_require_mfp=1 sae_pwe=2 wpa_passp
Mon Nov 13 08:46:50 2023 daemon.info dnsmasq[1]: read /etc/hosts - 6 names
Mon Nov 13 08:46:50 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 10 names
Mon Nov 13 08:46:50 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Nov 13 08:46:50 2023 daemon.warn dnsmasq-dhcp[1]: not giving name dell.lan to the DHCP lease of 192.168.0.181 because the name exists in /tmp/hosts/dhcp.cfg01411c with address 192.168.0.145
Mon Nov 13 08:46:50 2023 daemon.warn dnsmasq-dhcp[1]: not giving name dell to the DHCP lease of 192.168.0.181 because the name exists in /tmp/hosts/dhcp.cfg01411c with address 192.168.0.145
Mon Nov 13 08:46:50 2023 kern.warn kernel: [300424.040927] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Mon Nov 13 08:46:50 2023 kern.warn kernel: [300424.041003] ath10k_ahb a800000.wifi: msdu-desc: 2500  skid: 32
Mon Nov 13 08:46:50 2023 kern.info kernel: [300424.089798] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Mon Nov 13 08:46:50 2023 kern.info kernel: [300424.090799] ath10k_ahb a800000.wifi: wmi print 'free: 53252 iram: 13432 sram: 35752'
Mon Nov 13 08:46:50 2023 kern.info kernel: [300424.426312] ath10k_ahb a800000.wifi: rts threshold -1
Mon Nov 13 08:46:50 2023 kern.warn kernel: [300424.428091] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Nov 13 08:46:50 2023 kern.info kernel: [300424.434661] br-lan: port 6(phy2-ap0) entered blocking state
Mon Nov 13 08:46:50 2023 kern.info kernel: [300424.441736] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:46:50 2023 kern.info kernel: [300424.448057] device phy2-ap0 entered promiscuous mode
Mon Nov 13 08:46:50 2023 daemon.notice hostapd: phy2-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Nov 13 08:46:50 2023 daemon.notice hostapd: phy2-ap0: interface state COUNTRY_UPDATE->HT_SCAN
Mon Nov 13 08:46:50 2023 daemon.notice netifd: Wireless device 'radio2' is now up
Mon Nov 13 08:46:50 2023 daemon.notice hostapd: phy2-ap0: interface state HT_SCAN->DFS
Mon Nov 13 08:46:50 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: Set new config for phy phy2:
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: Remove interface 'phy2'
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: phy2-ap0: interface state DFS->DISABLED
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: phy2-ap0: AP-DISABLED
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: phy2-ap0: CTRL-EVENT-TERMINATING
Mon Nov 13 08:47:03 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Nov 13 08:47:03 2023 daemon.err hostapd: hostapd_free_hapd_data: Interface phy2-ap0 wasn't started
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: nl80211: deinit ifname=phy2-ap0 disabled_11b_rates=0
Mon Nov 13 08:47:03 2023 kern.info kernel: [300437.092325] device phy2-ap0 left promiscuous mode
Mon Nov 13 08:47:03 2023 kern.info kernel: [300437.092548] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:47:03 2023 kern.info kernel: [300437.252147] ath10k_ahb a800000.wifi: mac flush null vif, drop 0 queues 0xffff
Mon Nov 13 08:47:03 2023 kern.warn kernel: [300437.253258] ath10k_ahb a800000.wifi: peer-unmap-event: unknown peer id 0
Mon Nov 13 08:47:03 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:47:03 2023 daemon.notice netifd: Wireless device 'radio2' is now down
Mon Nov 13 08:47:03 2023 daemon.notice netifd: radio2 (11395): WARNING: Variable 'data' does not exist or is not an array/object
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: Set new config for phy phy2:
Mon Nov 13 08:47:03 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:47:04 2023 daemon.notice wpa_supplicant[1137]: Set new config for phy phy2
Mon Nov 13 08:47:04 2023 daemon.notice hostapd: Set new config for phy phy2: /var/run/hostapd-phy2.conf
Mon Nov 13 08:47:04 2023 daemon.notice hostapd: Restart interface for phy phy2
Mon Nov 13 08:47:04 2023 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=CA ieee80211d=1 ieee80211h=1 hw_mode=a beacon_int=100 chanlist=52 tx_queue_data2_burst=2.0 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][MAX-AMSDU-7935][DSSS_CCK-40] ieee80211ac=1 vht_oper_chwidth=1 vht_oper_centr_freq_seg0_idx=58 vht_capab=[RXLDPC][SHORT-GI-80][TX-STBC-2BY1][SU-BEAMFORMER][SU-BEAMFORMEE][MU-BEAMFORMER][MU-BEAMFORMEE][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN][RX-STBC-1][SOUNDING-DIMENSION-2][BF-ANTENNA-3][MAX-MPDU-11454][MAX-A-MPDU-LEN-EXP7] channel=52  interface=phy2-ap0 bssid=ea:9f:80:ac:16:c4 ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=1 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=1 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 sae_require_mfp=1 sae_pwe=2 wpa_passp
Mon Nov 13 08:47:05 2023 kern.warn kernel: [300439.860512] ath10k_ahb a800000.wifi: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Mon Nov 13 08:47:05 2023 kern.warn kernel: [300439.860594] ath10k_ahb a800000.wifi: msdu-desc: 2500  skid: 32
Mon Nov 13 08:47:05 2023 kern.info kernel: [300439.911594] ath10k_ahb a800000.wifi: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Mon Nov 13 08:47:05 2023 kern.info kernel: [300439.911840] ath10k_ahb a800000.wifi: wmi print 'free: 53252 iram: 13432 sram: 35752'
Mon Nov 13 08:47:06 2023 kern.info kernel: [300440.235201] ath10k_ahb a800000.wifi: rts threshold -1
Mon Nov 13 08:47:06 2023 kern.warn kernel: [300440.235637] ath10k_ahb a800000.wifi: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Nov 13 08:47:06 2023 kern.info kernel: [300440.244933] br-lan: port 6(phy2-ap0) entered blocking state
Mon Nov 13 08:47:06 2023 kern.info kernel: [300440.250469] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 08:47:06 2023 kern.info kernel: [300440.257191] device phy2-ap0 entered promiscuous mode
Mon Nov 13 08:47:06 2023 daemon.notice hostapd: phy2-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Nov 13 08:47:06 2023 daemon.notice hostapd: phy2-ap0: interface state COUNTRY_UPDATE->HT_SCAN
Mon Nov 13 08:47:06 2023 daemon.notice netifd: Wireless device 'radio2' is now up
Mon Nov 13 08:47:06 2023 daemon.notice hostapd: phy2-ap0: interface state HT_SCAN->DFS
Mon Nov 13 08:47:06 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Mon Nov 13 08:46:50 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-START freq=5260 chan=52 sec_chan=1, width=1, seg0=58, seg1=0, cac_time=60s
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: Set new config for phy phy2:
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: Remove interface 'phy2'
Mon Nov 13 08:47:03 2023 daemon.notice hostapd: phy2-ap0: interface state DFS->DISABLED

You may encounter DFS issues. Set the channel to auto, so the device will auto choose a proper channel after detecting radar interferences.

thank you for the suggestion, I tried it but it did not make a difference. My device still runs in to "daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)".

Mon Nov 13 11:51:22 2023 kern.info kernel: [311496.807308] br-lan: port 6(phy2-ap0) entered blocking state
Mon Nov 13 11:51:22 2023 kern.info kernel: [311496.814759] br-lan: port 6(phy2-ap0) entered disabled state
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Nov 13 11:51:22 2023 kern.info kernel: [311496.821265] device phy2-ap0 entered promiscuous mode
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: interface state COUNTRY_UPDATE->ACS
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: ACS-STARTED
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: DFS-PRE-CAC-EXPIRED freq=5260 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5260 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy0-ap0: DFS-PRE-CAC-EXPIRED freq=5260 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5260 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: DFS-PRE-CAC-EXPIRED freq=5280 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5280 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy0-ap0: DFS-PRE-CAC-EXPIRED freq=5280 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5280 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: DFS-PRE-CAC-EXPIRED freq=5300 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5300 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy0-ap0: DFS-PRE-CAC-EXPIRED freq=5300 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5300 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy2-ap0: DFS-PRE-CAC-EXPIRED freq=5320 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5320 cf2=0
Mon Nov 13 11:51:22 2023 daemon.notice hostapd: phy0-ap0: DFS-PRE-CAC-EXPIRED freq=5320 ht_enabled=0 chan_offset=0 chan_width=0 cf1=5320 cf2=0
Mon Nov 13 11:51:23 2023 daemon.notice netifd: Wireless device 'radio2' is now up
Mon Nov 13 11:51:28 2023 daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Mon Nov 13 11:51:29 2023 daemon.notice hostapd: phy2-ap0: ACS-COMPLETED freq=5280 channel=56
Mon Nov 13 11:51:29 2023 daemon.notice hostapd: phy2-ap0: interface state ACS->HT_SCAN
Mon Nov 13 11:51:29 2023 daemon.notice hostapd: phy2-ap0: interface state HT_SCAN->DFS
Mon Nov 13 11:51:29 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-START freq=5280 chan=56 sec_chan=-1, width=1, seg0=58, seg1=0, cac_time=60s
Mon Nov 13 11:52:31 2023 daemon.notice hostapd: phy2-ap0: DFS-CAC-COMPLETED success=1 freq=5280 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5290 cf2=0
Mon Nov 13 11:52:31 2023 kern.info kernel: [311565.281468] ath10k_ahb a800000.wifi: mac flush null vif, drop 0 queues 0xffff
Mon Nov 13 11:52:31 2023 kern.info kernel: [311565.383530] IPv6: ADDRCONF(NETDEV_CHANGE): phy2-ap0: link becomes ready
Mon Nov 13 11:52:31 2023 kern.info kernel: [311565.383819] br-lan: port 6(phy2-ap0) entered blocking state
Mon Nov 13 11:52:31 2023 kern.info kernel: [311565.389342] br-lan: port 6(phy2-ap0) entered forwarding state
Mon Nov 13 11:52:31 2023 daemon.notice netifd: Network device 'phy2-ap0' link is up
Mon Nov 13 11:52:31 2023 daemon.notice hostapd: phy2-ap0: interface state DFS->ENABLED
Mon Nov 13 11:52:31 2023 daemon.notice hostapd: phy2-ap0: AP-ENABLED
Mon Nov 13 11:52:31 2023 daemon.notice hostapd: phy0-ap0: DFS-CAC-COMPLETED success=1 freq=5280 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5290 cf2=0
Mon Nov 13 11:53:27 2023 daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)

Looks like the radio2 ap0 is up, Have you tested it ? Could youy share your /etc/config/wireless and /etc/config/network files without sensible info. The ipv6 dchp error message might not be related.

I realized you quoted a post from me above -

  • it seems unrelated to this posts
  • I did not have to downgrade - it was working properly
  • further, the post following mine explained what the OP's issue may have been
  • the linked thread is unrelated to wireless, I'm not sure why you believe the posts are related

This is an IPv6 problem, which is normal if your network is v4 only.

I see both radios trying to set to the same frequency 5280, which is not going to work for one of them. Set the radios each to a definite channel-- one in the low part of the band and one in the high part. Ideally try channels which are not DFS in your country.

1 Like

Sorry i did not mean to paste your reply in that thread. The url just happened to be on your reply when i copy pasted it.

The op in that thread did indeed downgrade "Going back to 21.02.5 has fixed my problems completely.". I know that thread isn't about wireless, but it had the exact same error as i am getting

daemon.err odhcp6c[2288]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
1 Like

thank you for the reply. That is strange you saw they are trying to set the same frequency. Before it was suggested I try auto above, one of them was channel 108 and the other 52. The web interface doesn't even let me set channels that are close together and are far apart. One in the low part of the band (36-64) and one in the high (100-165) as you had suggested.

updated to 23.05.2. still encountering same issue