Update WRT3200ACM firmware failed

I have this problem when trying to update my router.

It's a Linksys WRT3200ACM.

I got the new 21.02.3 firmware for my device from the device page from were i got my first firmware for the device (19.07.7)

The problem is just when i try to update it tells me it's the wrong firmware and if i force the update anyway it won't boot up again.

Is it just that my under 2 years old router just is to old or is there some error that i have to work around?

I have uploaded some screenshots there maybe can tell more then i maybe understand off it.



Did you read the warning and instructions displayed in the first screenshot?

Granted, it's a lot of text on a small screen but the instructions are clear: wipe settings, then force upgrade if you'd like.

And pretty please use a cable to upgrade, don't do that over wireless.

I was not sure if I did something wrong or something.

But yeah. Normally i do i over cable but i did not have that option at the moment do to the only machines i own that there are on cable are consoles.

But i had i fall back option.
But i have been reading a bit more up on my now "error" and it tells me that i can delete 2 files and make a workaround that way.

My only problem is that my settings (just tested with 19.7.10) did not follow over and i therefore lost most of my configuration anyway as it looks now.

Sorry to hear that. In that settings case you could just force flash while wiping settings.

You can indeed just wipe /etc/config/network and be fine with it; --force will still be required though. At that point you might as well just SSH in and sysupgrade manually with -F -n.

I still had the opportunity to fall back do to the way the flashing works on the device.

So i kan still "backup" most of my setup like static addresses and network settings.

But things like my VPN, 4G failover, samba share and so on do i have to make again from scratch as it looks...

You'll use the config you save as a refrence.

Some background reading: https://openwrt.org/docs/guide-user/network/dsa/start?s[]=dsa&s[]=networking#dsa_networking

If your network setup is pretty OOTB, the switch to DSA is relatively painless. For the most part, your other config settings migrate seamlessly.

Per @lleachii just reconcile the new configs from your backup configs.

I made a test upgrade to 19.07.10 and there i lost all my settings except for network settings like static IP addresses, wifi settings and such...

All my other things did not migrate over.

I did however not make the "download backup file".
The question is if that will migrate my current settings to the new install..

I will rather not make my full setup again.

It took me months last time do to not knowing what i was doing..

Reboot to your working alternate partition (19.07.7) and make a backup - System/Backup Flash/Firmware/Generate Archive. This will create a backup of all your current configs.

Flash 21.02.3 (Force, Do Not Keep Settings). On boot, you'll have default network on 192.168.1.0/24. Reconcile /etc/config/network against your backup /etc/config/network.

Then you update opkg and add your additional packages. Most of these can be migrated as is directly from your backup.

I will try and see if I can figure it out...

Just a quick question.
What is there in the network file?
Because if it's not that important i can just scratch that from the backup.

see post to short circuit things a bit.

1 Like

I opened the file and got my answer.

I will try to work on the router later today when the internet connection not is critical to work so I can pull it down for maintenance.

I have now tried the upgrade as described and most of my settings works now.

My only problem now is the installation of all my file packages that i can't figure out how to move over.

Guess i have to install them all one by one now.

Unfortunately yes, but next upgrade you should be able to save settings. Check this link for a couple of options/scripts that you can run on your 19.07.7 partition to identify what packages got added after /rom was built.

I just made a copy/paste list of the installed list on my 19.07.7 install.

But I'll try look at the other one.
Maybe it's better.

I have now installed the new firmware and my other stuff and my entire setup is up and running again.

Thanks for the help.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.