Update to Openwrt 18.06 and no internet

Hi, I have a strange problem.
I am right using a home hub 5a as my main router, connected directly with a VSDL connection to TalkTalk. I had some trouble originally getting an internet connection after replacing the supplied (but rubbish router) with LEDE v17. After some googling I found out I needed to set a VLAN, and then it all started working.

So 10 months later, I decided to update to OpenWrt v18 and I bought a new HH5a pre-installed with Openwrt and proceeded to swap out my old router. However, I cannot get the internet working.
I backed up the config from my old hh5 and loaded it into the new one (having the IP address it allocated itself).
The modem connects but the router cannot get internet access (e.g. ping to 8.8.8.8 fails with network unreachable) . This was the same problem I had when first setting up the LEDE HH5, before I added the VLAN.
So I reset the router back to default and tried following my old notes. I end up with the following network config file. But it doesn't work. Am I missing something obvious here?

 -----------------------------------------------------
 OpenWrt 18.06.1, r7258-5eb055306f
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:cb3b:9278::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'a0:1b:29:59:70:66'

config interface 'wan'
        option ifname 'ptm0.101'
        option proto 'dhcp'
        option type 'bridge'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr 'a0:1b:29:59:70:67'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

Anthony

Yes,
https://openwrt.org/docs/guide-user/network/wan/isp-configurations

TalkTalk uses DHCP protocol.

config dsl 'dsl'
option annex 'b'
option tone 'a'

config interface 'wan'
option ifname 'dsl0.101'
# option ifname 'ptm0.101' # for LEDE 17.01
option proto 'dhcp'

So just change ptm0.101 for the wan ifname to dsl0.101.

I found this as I was writing the post, but I thought I'd post anyway in case it helped someone!

Anthony

Yes, it helped (Telekom Slovakia). Thanks a lot.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.