Update pc engines alix 6f

Sorry, bit noobish, has probably been asked allready, but I want to be sure to understand it.
I have a PC Engines ALIX 6f board, which works fine with openwrt. However, I am not sure how i can update that installation in the future? For "normal" Routers there is an update image afaiu, which can be transfered to the router via LuCi. Afterwards restore settings, and everything should work again. However, the wikis state, that for x86 there is no update mechanism, therefore no update image. Does that mean, i have to write a new image to the cf card everytime i want to update? That actually would be a showstopper, since the the cf card is hard to reach and I don't want to open the router everytime i want to update.
For the record, I toyed arround a bit with openwrt 15 and tried to update with the alix image, but that failed, got only 128 MB Data transfered (Probably because the board has just 256 MB)
So, is there any way to update my router via the webgui, or atleast somehow over the net?

It's possible to use the *combined* images for sysupgrade, x86-generic-combined-squashfs.img.gz for example. This works via LUCI and cli, just like with ordinary sysupgrade images.

I tried to upgrade 10.3.1 (x86-generic) to 18.6.1 (x86-geode, since the Table of Hardware says this ALIX 2D13 uses AMD Geode) using in LUCI:


Each of these images gives in LUCI:

"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

What am I overlooking, can someone help?

try without compressed images, gunzip them

I think I tried that, to no avail.

I resorted to dd-ing the image to the CF card. That of course is more hassle because you have to disconnect the router, open it and remove the logic board to access the card.

Would be great if this could work out easier next time.

you could try the sysupgrade -F from console, maybe your current image was too old, just for test, try it again in LUCI and see if is still not working

Thanks, for me it is too late for that now since I have already upgraded to the latest version by overwriting the whole CF card using dd.

1 Like