Update kmod-usb-net-rtl8152 Driver to avoid USB 3.0 to Gigabit LAN issues?

That was my thought at first, but after updating the driver from realtek website solve the problem completely (not to mention similar older problems in other forums).

Also without updating the drivers but using usb 2.0 port the device works flawlessly (well except it won't give full gigabit speed since bottleneck in usb 2.0 interface).

@Ark, after all your problems and seeing that people is not having problems with UE300 adaptors and 2013 drivers and, I do not have problems with same adaptor and 2020 drivers. May I suggest you get a new one? In the end, even with same chipset, adaptors are not build the same and they differ in quality.

I guess for this time I'll use my other USB 3.0 to gigabit adapter which is AX88179 based, or putting the RTL8153 adaptor in USB 2.0 slot. I do plan to use the realtek on raspberry pi but using dietpi, nftable and updated linux driver as another router / gateway, and testing if the adapter works normally like in windows. But I don't have spare unit because it's now used as my main router right now so maybe in the future.

1 Like

@xiaobo, as you can see it got rejected, probably because how I committed it. Let me see if I can follow up on how to properly do the pull request for a new version of a kernel driver.

1 Like

Ok, finally I bought UE-300 and plugged it in usb 3.0 port, works normal unlike previous adapter. although a bit curious lsusb shows rtl8152 even though google said it's rtl8153 chipset. And I vaguely remember my previous adapter shows as rtl8153...

This is not a driver problem. The USB core is also unable to communicate with the device. That's most likely a hardware and/or firmware issue with the device. I'd just throw it in the garbage.

This doesn't mean that I don't believe you are right about the bug being related to autosuspend or other parts of device power management. It might very well be related. But it's still a bug. And there might be more. Which is why I believe implementing any workaround is a waste of time.

But disabling autosuspend is simple in Linux. You don't need anythong special for that. You can

  1. boot with usbcore.autosuspend=-1 on the kernel command line, or
  2. echo -1 >/sys/module/usbcore/parameters/autosuspend, or
  3. echo -1 >/sys/bus/usb/devices/x-y/power/autosuspend (where x-y must be replaced)

This is documented e.g in https://www.kernel.org/doc/Documentation/ABI/stable/sysfs-bus-usb

I reckon that's how the driver reports it. Nothing to worry about, tho'. Your device is a RTL8153, Linux uses same driver for both the 8152 and 8153.

Same problem here.

Ok, been tinkering with another device (intel nuc / mini pc) and tried installing OPNsense with internal ethernet (RTL8111) on WAN and the previously problematic usb to gigabit ethernet (RTL8153) as LAN. tried speedtest and downloads seems no problem which leads to more questions.

I know intel nuc and OPNsense is not a good comparison since comparing x86 vs arm and Linux vs BSD but I thought maybe there's more than just faulty usb ethernet. I plan to test it as openwrt in the nuc later.

Edit : after swapping the WAN side to USB Adapter and LAN to onboard NIC problem began to happens, and after further examination, previously the LAN side on my laptop is set to 100 mbps not 1 Gbps, maybe that explain why the USB ethernet works fine (similar when plugged in to USB 2.0 port). I guess it's confirmed the generic USB Gigabit adapter is very unrealiable that archieving 1 Gbps is almost impossible.

1 Like

Would you post the patch somewhere?

edit: no need, just found your closed PR.


1 Like

Hi Amteza, i plugged in the TP-Link UE300 and i can see it on the USB LS but i dont see the eth1. only eth0. hope you can help

root@OpenWrt:~# lsusb
Bus 002 Device 002: ID 2357:0601 TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153]
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If you installed the corresponding kmod-usb-net-rtl8152 package it simple works, you have to do nothing to see the new interface.

i get that error:

root@OpenWrt:~# opkg install kmod-usb-net-rtl8152
Installing kmod-usb-net-rtl8152 (5.4.66-1) to root...
Downloading https://downloads.openwrt.org/snapshots/targets/bcm27xx/bcm2711/packages/kmod-usb-net-rtl8152_5.4.66-1_aarch64_cortex-a72.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-net-rtl8152:
 *      kernel (= 5.4.66-1-5bce2209885de4a03488d29e7c2dd93e)
 * opkg_install_cmd: Cannot install package kmod-usb-net-rtl8152.

Update to latest snapshot.

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

1 Like

I updated to the latest snapshot. It’s working. Thank you.

1 Like

Now I got this problem and I don't know what to do.

I have a USB3->ethernet-adapter branded Plexgear. It has RTL8153 inside.

This one: https://www.kjell.com/se/produkter/natverk/tradburet-natverk/natverkskort/gigabit-natverkskort-usb-3.0-p69085

It appears when I do "lsusb" but not when "ifconfig". I included RTL8152-driver when I compiled so it's installed. I can see that also when I check in Software in LuCI.

Anyone know what to do?

Best regards!

Ok. Update!

As I said. eth1 didn't show up in ifconfig at first.

But after adding an exact copy of the LAN (eth0) in Network -> Interfaces, except choosing eth1 instead of eth0 and instead of I changed the last 1 to 2. After doing this it also showed up after doing a ifconfig. I didn't know I had to "start" it somewhere before it showed up. Thought it was gonna be auto-detected after installing the driver. My bad maybe.

At first I couldn't connect to it with ssh or LuCI, but after rebooting it's now possible. How nice. Thought I were going to have to buy new hardware.

So let's hope it works fine from now on. Now on to my next mission!

Have a nice day guys! :slight_smile:

same,i am using rtl8512b chipset on my Raspiberry pi 3b running on openwrt, it looks fine,but when i use speedtest, the device would stuck, i have no way to slove but reboot. I also buy a rtl8513 chip, test tomorrow

I have same problem as author of this topic
my device is RTL8152B chip based (100mbit) and has usb 2.0

please update drivers in openwrt repository
as I understood it will help most of us