Update fails from Chaos Calmer


I have an GL.iNet GL-AR300M router with OpenWrt Chaos Calmer 15.05 r47065 installed. Now I tried to upgrade OpenWRT using LuCI but it failed:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Also command line upgrade fails:

How do I update this router?

Thx a lot and merry Christmas :slight_smile:


There are 4 possible sets of images to use (Lite, NAND, NOR, and 16). Are you sure you are using the right image for your router?

Also, look at the warning at the top of the device page:

1 Like

Also, I would try updating to version 17 first.


Crossgrading from ar71xx to ath79 (which you'll inevitably hit with 21.02) will also require --force (make extra sure to only force the correct fimrware image and not accidentally flash your router with something else, as --force will forego most sanity checks).

Thx for your support! I solved the problem by installing the original GL.iNet firmware with Uboot. After that, I was able to install Open WRT without further problems...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.