Unusual packet behavior OpenWRT with Cudy x6 router

I'm using 802.1q to support multiple vlans on my Cudy x6 wifi routers. I'm experiencing an unusual packet behavior when trying to reach network devices from a wifi client connected to my wifi SSIDs. For example, when my client is connected to one of my SSIDs, lets say the SSID called badgerNet (range 172.16.100.0/24), my client can only access certain IP addresses in other reachable networks. Example, if my client at 172.16.100.51 tries to ping, http, or any method, to a machine at 192.168.0.10, there is no problem at all, but when my client tries to access a machine at 192.168.0.3, then it's a no-go. It's odd because the addresses that my wifi clients can reach and those it cannot reach seem to be purely random. Note that the firewall is disabled on all my OpenWRT Cudy x6 wifi routers and the reachability within and around my networks is otherwise perfect. For example, I can connect a PC by ethernet to the same vlan as my SSID and that PC can reach all networks and addresses in my network. Also not that all firewal rules within my networks have bee disabled just to troubleshoot this weird behavior. It all seems to point to a problem with the OpenWRT code and Cudy x6 combination.

Here is the network config of one of my Cudy X6 wifi routers:

root@CudyWiFi_AP3:/etc/config# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfa:a9f0:a93f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.0.253'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.1'
        list dns '8.8.4.4'
        list dns '4.2.2.3'
        list dns '8.8.8.8'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '100'
        list ports 'lan1:t'

config interface 'badgernet'
        option proto 'static'
        option device 'br-lan.100'
        option ipaddr '172.16.100.4'
        option netmask '255.255.255.0'
        option gateway '172.16.100.1'

config bridge-vlan
        option device 'br-lan'
        option vlan '110'
        list ports 'lan1:t'

config interface 'badgerguest'
        option proto 'static'
        option device 'br-lan.110'
        option ipaddr '172.16.110.4'
        option netmask '255.255.255.0'
        option gateway '172.16.110.1'

config bridge-vlan
        option device 'br-lan'
        option vlan '115'
        list ports 'lan1:t'

config interface 'badgeriot'
        option proto 'static'
        option device 'br-lan.115'
        option ipaddr '172.16.115.4'
        option netmask '255.255.255.0'
        option gateway '172.16.115.1'


I will be happy to provide more of my configurations if needed.

Hope you can fix or figure out the problem... it could be my OpenWRT configuration, but everything works perfectly except for this one issue.

All, disregard this issue/non-issue. The problem was me, I had a L3 device on one network that couldn't be reached by the wifi client on another network. It turns out that that L3 device is a Cisco switch that had a "gateway of last resort" configured, but the L3 device was not in routing mode. For those of you who know Cisco switches, if the switch is in L2 mode, which this one was, the "ip route 0.0.0.0 0.0.0.0 x.x.x.x" command is ignored and the "ip default-gateway x.x.x.x" is recognized instead. My preferred fix was to put the switch in L3 mode and keep using the "ip route 0.0.0.0 0.0.0.0 x.x.x.x" command as I plan to do more L3 stuff. The bottom line is that I screwed it up and apologize for the rookie mistake and posting it here. That being said, this OpenWRT runs fantastic on the Cudy x6 WiFi router, I am exceptionably pleased. Kind regards

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.