Unstable WiFi - "STA-OPMODE-SMPS-MODE-CHANGED"

Hello guys,

I am once again facing some WiFi problems with my Archer C7 v2 running openwrt v19.07.4.

My log is full of these entries while using the 2.4 GHz band with my notebook (Intel AC 7260).

log
---> My notebook using the 2.4 GHz band
Wed Dec  2 10:09:36 2020 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK static
Wed Dec  2 10:09:46 2020 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK dynamic
Wed Dec  2 10:10:02 2020 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK static
Wed Dec  2 10:10:12 2020 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK dynamic
Wed Dec  2 10:10:47 2020 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK static
Wed Dec  2 10:10:57 2020 daemon.notice hostapd: wlan1: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK dynamic

---> My notebook forced to use the 5 GHz band
Wed Dec  2 13:28:59 2020 daemon.notice hostapd: wlan0: STA-OPMODE-SMPS-MODE-CHANGED MAC_ADDRESS_NOTEBOOK off

This wouldn't bother me at all if it wouldn't interfere with all my other wireless devices.
All my apple devices get really bad wifi connections. Strength / Signal is fine, but the troughput is almost at zero. Websites take forever to load or timeout.

This only happens while my acer notebook is connected to the 2.4 GHz band of my Archer C7 v2.

Is there an option to disable SMPS in OpenWrt or Windows?

  • I don't believe so in OpenWrt, it appears to be in code...and would affect all clients
  • In Windows, yes - see:

Look for "MIMO power save mode".

1 Like

For some reason there is no "MIMO" option under Advanced Settings in the adapter configuration.
Latest Intel drivers are installed.

I guess then this isn't an issue with OpenWrt but with Intel.

Disable all of the power saving features anyway, just as a test. I remember at least two, maybe three different power saving settings for one of my older Intel WiFi cards.

1 Like

Same issue here.
TL-WR1043ND v2 - 19.07.7

Any solution?

What clients are affected ? I had to change the wifi adapter setting of the affected laptop.

In my case, all of them are affected when I've this problem.

Windows clients, Android phones..

Yes, but you have to switch the smps Mode off only at the device that causes the message. For me there are exactly 2 of them, both Laptops.

Where should I find the option?

image

At Intel it is called MIMO power save mode:

For italian tp-link I am sorry...

For everyone saying disabling MIMO on that device fixes it....
The hint to disable MIMO might be working for SOME of you.
But not for everyone!!!
I have an Intel AC 7260 card in my device and even with the latest Intel drivers there is no such option!

Since it doesn't happen with the stock firmware on wireless routers there HAS to be a bug in OpenWrt causing this behaviour.

1 Like

Since there isn't the option on both my computer, is there a way to disable it in OpenWRT?

Does not look like...

Set htmode to Legacy should disable it.

1 Like

It did the job.

This patch should disable SMPS handling for 802.11n.

1 Like