Unreliable 2.4GHz WiFi on TP-Link Archer C7 v5

Hi,

I just started using openWRT on a TP-Link Archer C7 v5 as a wired access point with the 5GHz WiFi currently turned off.

The configuration is pretty much standard with "N Mode 40MHz bandwidth" - security is WPA2-PSK with auto cypher, 802.11w Management Frame Protection is off and I tried KRACK protection on and off. Short Preamble is activated, Disassociate On Low Acknowledgement as well.

I experienced some issues with the WiFi meaning it will start to drop clients and then be not accessible any more until I restart the 'Generic 802.11bgn' radio1.

the system log shows messages like this around a failed connection attempt:

Sun Apr 19 01:15:05 2020 daemon.notice hostapd: wlan1: AP-STA-POLL-OK 00:04:20:28:7f:e1
Sun Apr 19 01:15:32 2020 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 2c:f4:32:44:71:3a
Sun Apr 19 01:15:32 2020 daemon.info hostapd: wlan1: STA 2c:f4:32:44:71:3a IEEE 802.11: disassociated due to inactivity
Sun Apr 19 01:15:33 2020 daemon.info hostapd: wlan1: STA 2c:f4:32:44:71:3a IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Apr 19 01:18:32 2020 daemon.notice hostapd: wlan1: AP-STA-POLL-OK 00:05:cd:c4:c2:1e
Sun Apr 19 01:18:48 2020 daemon.notice hostapd: wlan1: AP-STA-POLL-OK cc:50:e3:78:17:77
Sun Apr 19 01:19:54 2020 daemon.notice hostapd: wlan1: AP-STA-POLL-OK 00:04:20:2a:66:a4
Sun Apr 19 01:19:55 2020 daemon.notice hostapd: wlan1: STA 4c:11:ae:10:bb:4a IEEE 802.11: did not acknowledge authentication response
Sun Apr 19 01:19:56 2020 daemon.notice hostapd: wlan1: STA 8e:3b:ad:b2:4c:ef IEEE 802.11: did not acknowledge authentication response

this happens about 1 - 2 times a day.

Any suggestions how I can improve the reliability? Thanks in advance.

Switch to 20MHz to test.

Thanks. Set 20MHz this morning and no problems so far. I guess going with the safe settings first makes sense :wink:

no - that was not it! The same issue just happened after about 12h smooth running (as far as I noticed).

I might have forgotten to mention that there is a wifi repeater (not wired AP) involved... now I have it disabled - no issues so far.

1 Like