Unofficial TRENDnet AC2600 (TEW-827DRU v1.0R) release v18.06.5

I have posted new releases here:

Be sure to read my notes appended to the post.

Are the builds compatible with gigabyte internet speeds? Two days ago I upgraded my Uverse internet from fiber 300/300 to 1000/1000. I only get half of my gigabit speeds using this router with version 18.06.6.I purchased a new gigabit ethernet card for my PC. I upgraded all of my cables to Cat 6. And I still only get half of my speeds using this router. If I bypass the router and connect my PC to the RG (modem) I come really close to gigabit speeds. As soon as I put this router back in the mix my speeds tank. So again can someone please tell me if these builds can support gigabyte internet? Otherwise everything is working great. I did test speeds using the built in speed test in the AT&T RG. They test at 945/965 on average. So the problem seems to be in my equipment. Thank you.

That should answer your question, the TEW-827DRU v1.0 is based on the slightly older/ slower ipq8064 SOC, compared to the router discussed there.

Now I'm confused. Should I go back to stock firmware on my router? Should I buy a new router even though this one is supposed to handle gigabyte internet just fine? Or should I just bite the bullet and take my own router out of the equation and just use the AT&T BGW210? I might just drop my internet back down to 300/300 as I really don't want to sped another penny on this so called upgrade. Thank again for any responses.

So I bypassed the router and I now get 990/980 on my fiber internet using the AT&T RG. I have tried all afternoon to reflash the stock Trendnet firmware back onto my router. Every single time it appears to complete. But when I boot up I am back in OpenWRT. Any ideas on how to flash this thing back to Trendnet firmware?

Read this post: TRENDnet AC2600 (TEW-827DRU v1.0R)

You must first install the 1.00b11 firmware, THEN patch it with the latest update from Trendnet. You don't need to install all of the intermediate updates, just the first and the latest.

You will have to do that through the Emergency loader thing as described above, just like how you installed OpenWRT in the first place.

As for performance, I can do 500/500 without too much trouble but I don't test anything beyond that. I've heard about performance limitations on the ipq806x series but I've not stressed it enough to find out so I can't say if it's true or not.

Thank you. I tried the 1.00b11 firmware early this afternoon but never got to do the latest firmware as the router kept booting into Luci. I'll try it again in case I did something wrong. But I was able to get to the last step and the screen even said "Update Successful" or something to that effect. I'll try it again. I noticed one thing though was that after I got the success message my browser always tried to reload a page that said "Backup Bootloader." Is that normal? If not maybe that's where this is going wrong.

I don't remember ever seeing anything like that before. If you can get a picture/screenshot, that would be nice.

Give it a try again and if you can't get it working let me know.

Be sure to give the Recovery Loader plenty of time to restore, like maybe 5 minutes, 10 minutes absolute max. The 1.00 Trendnet firmware file includes a bunch of extra partitions that are not normally touched, so it takes longer to finish than the OpenWRT firmware. Also, interrupting that process at the wrong time is one of the few ways you can brick this device.

I'm sorry. It says "Backup Loader". I just followed your instructions again and the router still booted into the Luci login screen. I have no idea what I am doing wrong. I get the first firmware loaded to where the screen says success. Then in the upper left corner of my browser (New Edge) It says "Backup Loader" and I get a spinning wheel like it's trying to load something. I gave both firmware versions time to stop loading this extra refresh and I still booted up into the Luci login screen after rebooting the router. I am at a loss here.

I'm going to try it again tomorrow. It's starting to get late here. If I still can't get it I might just down grade my internet back to 300/300 and go back to things working as they were. Otherwise I might just buy a new router that I know can do gigabit speeds. This one should but I can't get back to the Trendnet firmware. I do appreciate the help though. If I don't have success tomorrow I'll post a screen shot. Maybe the refresh is really part of the whole process and I am not giving it enough time? I just assume that after I get a success message on the screen and things start to refresh that the firmware is loaded.

Well that's weird.

It sounds like the image file isn't being loaded correctly. Unfortunately there is no way to get feedback about the process from the Recovery Loader. It's pretty dumb.

You are loading the .bin file, not the .zip file, right?

Also, check the sha256sum and re-download if it's wrong. Read here to learn how. 7-zip can do it:

I just tried it again making sure both firmware versions had plenty of time to load. I am still booting into the Luci login screen. I tried to post a screenshot but was told it was too large. I'll have to try again later. Yes I am loading the .bin files. I extracted them to a temp folder on my PC first. Thanks for the help. What am I supposed to do after I load the first firmware? Am I supposed to reboot the router or use the reset again? If I just reboot the router it loads into Luci before I can get the second file loaded. If I use the reset procedure it does the same thing while the 2nd file is being loaded. I have also thought of just trying to install the second firmware without rebooting router or using reset but I can not get the recovery page to come up again so I can enter the 2nd firmware. The only thing I can do is reboot or reset the router. I am pulling my hair out on this one.

Edit The files seem to check out without any errors.

Yep, that's the Recovery Loader. At least we know you are getting into it okay.

When you load the first/1.00 OEM firmware image file the router is going to auto-reboot itself, so you won't be able to time the reset button and get back into the Recovery Loader again to immediately install the second/update image. And that's fine; you can install the update later once you get into the OEM management interface and install it from there.

The question is: Why isn't the Recovery Loader correctly installing the v1.00 OEM firmware?

When I did all of my dev work I went back and forth between the OEM and the OpenWRT/LEDE firmware multiple times without problems, most of the time.

I did observe the Recovery Loader fail to install images on two occasions out of perhaps dozens, but I never figured out why and I wasn't able to reproduce the problem. Maybe you've somehow stumbled upon something which makes it fail.

Try to minimize your environment and any factor which might contribute to the problem: Unplug all network connections except for a direct attachment to your PC system when using the Recovery Loader. Don't try to load in a second image; try to let the 1.00 OEM image boot up first.

It could also be possible that there is something different about your system which is breaking the OEM installer script, but I've never seen anything like that before. I have two units here at home and five others I've worked on directly and they were all the same.

Prognosis: Fuck if I know!

Lol!! I know right? Ok I'll try it again and see what happens. Last night I did try rebooting the router after v1.00 was installed. And it booted into Luci. But I am very persistent.Thanks again for the help!

I tried several times this morning. I can not get rid of OpenWRT. The router boots into Luci every time. I am going out now to pick up a new TP-Link AC4000 Mu-Mimo router that will do gigabit internet. Thanks for all of the help.

One thing I did notice while trying to flash v1.0 of the Trendnet firmware only port 1 (where my ethernet cable was plugged in) would light up. The power light never came on when V1.0 was being flashed. So I doubt the firmware was ever really being installed at all. In better news I did pick up a TP-Link AC4000 Mu-Mimo router yesterday. Wow this thing rocks! I might revisit the Trendnet when I feel like playing with it. Is there some type of protection setting in OpenWRT that might be keeping me from flashing v1.0? If there is I couldn't find it. Thanks again.

The recovery loaders, as depicted in your screenshots, is provided by the OEM bootloader of your router, this bootloader is never touched by OpenWrt.

Right. But any idea why I can not flash v1.0 of the Trendnet firmware? The only light that flashes when installing the old firmware is port 2 which is what I have my ethernet cable plugged into. I thought the power light was supposed to flash. This leads me to believe that nothing is being installed. Upon reboot of the router I get the Luci login screen every time. I have checked the v1.0 firmware .bin file and it checks out with no errors. My new router is working great. But I'd still like to reflash my Trendnet back to stock.

That's normal. uboot doesn't activate the power LED on this model.

Get a TTL serial adapter and plug it into the console. That's the only way you are going to get any debugging info from the device. You could also install firmware from uboot TFTP that way too.

There's no pin headers on this board, but the holes are there and you don't have to solder as long as your wires make contact.

There is probably just something dumb keeping the firmware from being written, like you have bad memory somewhere, or there is something different about your process that we are not considering.

I've gone back and forth between the OEM and OpenWRT firmware on my test unit many times.

I also had challenges getting back to stock firmware from OpenWRT 18.06.5. Eventually I found that you can't go back directly to latest Stock firmware, but you can flash older the older stock 1.00b11 firmware and then go to 1.03b02 there after.