Unmanaged switch takes down the whole network if connected at startup

I'm absolutely up the wall with trying to get this unmanaged switch to work.

I have OpenWRT running on a pi 4 with a handful of ethernet adapters (confirmed not a power supply issue, got a powered hub). The unmanaged switch in question is running on eth3. But if anything is plugged into it when the pi starts up, nothing gets internet access including the pi, and that device on the switch doesn't even get local access. Still gets DHCP somehow but cannot ping the pi. However, if the device is plugged in elsewhere and then moves to the switch later, it continues to operate successfully. Obviously this is no way to operate a network long term.

  • I have confirmed the port works normally with my PC plugged directly into it.
  • I have tried three different cables with the switch, same results.
  • I have tried several different combinations of ports on the switch in case just one of them is the issue and I have found no successful combination.
  • I have tried eth0, eth1, and eth2 to the same results.

Another possibly useful thing: eth1 has another router in it, and the PC works through the ports on that.

network config stuff (again, switch is on eth3):

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'
	list ports 'eth3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'WAN'
	option proto 'dhcp'
	option device 'eth2'

config device
	option name 'eth1'
	option acceptlocal '1'
	option promisc '1'

config device
	option name 'eth3'
	option acceptlocal '1'
	option promisc '1'

config device
	option name 'eth0'
	option acceptlocal '1'

Any help would be appreciated. This thing is supposed to be plug and play, that's all I keep hearing when I search for anything I could do differently, it's really quite frustrating.

Sounds stupid but I have seen it: power cycle the unmanaged switch before you try again and dig deeper...

that's something i had tried, but i got it in my head to try a new combination of power cycles i hadn't tried yet... the switch, then the entire network at once, then the pi, then the whole network again.

It works.

Why.

WHY.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.