UniFi 6+ stops responding after trying to setup VLANs

Hello!

I've bought a new AP: UniFi 6+ with OpenWrt 23.05.5.

My previous setup:

TL;DR: UniFi 6+ in, Archer C6 out.

Now I'm trying to achieve the same result as before: Setup the guest network on the main router, and then use VLANs to run them out to the dumb APs.

After following this step, my AP stops responding. I can't even access it through SSH.

Is there something different between U6 Lite and U6+? What am I doing wrong?

Please first confirm that the guest network is working as expected with the C6, so all we're doing is replicating that general setup on the new U6+.

Assuming that's the case, let's see your current config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

Also, let’s see the same config from the C6 so we have a reference of the final goal.

Yes, the guest VLAN is working as expected with the C6.

root@ArcherC6:~# ubus call system board
{
        "kernel": "5.15.167",
        "hostname": "ArcherC6",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link Archer C6 v3",
        "board_name": "tplink,archer-c6-v3",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}
root@ArcherC6:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd1:982c:d384::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '10.0.0.4'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.0.0.1'
        list dns '10.0.0.1'

config interface 'guest'
        option proto 'none'
        option device 'br-lan.10'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan4:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan3'
        list ports 'lan4:t'

Thanks for the confirmation. Let's try to setup the same VLANs on the U6+, starting with a review of the config.

Now the U6+, after following this guide:

root@U6Plus:~# ubus call system board
config/network{
        "kernel": "5.15.167",
        "hostname": "U6Plus",
        "system": "ARMv8 Processor rev 4",
        "model": "Ubiquiti UniFi 6 Plus",
        "board_name": "ubnt,unifi-6-plus",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "mediatek/filogic",
                "description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
        }
}
root@U6Plus:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd41:a7d5:7fc2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.0.0.6'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.0.0.1'
        list dns '10.0.0.1'

Thanks, @psherman!

Ok... there are two possible approaches. Let's try first with the bridge-VLAN method.

Create two new bridge-VLANs:

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'eth0:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'eth0:t'

Then edit your lan to use br-lan.1:

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '10.0.0.6'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.0.0.1'
        list dns '10.0.0.1'

And finally create an unmanaged interface for VLAN 10:

config interface 'guest'
        option proto 'none'
        option device 'br-lan.10'

After you've made all those changes, restart your router. You should be able to setup an SSID against the guest network, and your lan should continue to work as it was.

1 Like

Yeah, it worked. That was my mistake.

On U6 Lite, it is:

list ports 'lan'

On U6+, it is:

list ports 'eth0'

How am I supposed to know that? :stuck_out_tongue:

Anyway. On my old U6 Lite:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'
        option ipv6 '0'

Can I safely remove "option ipv6 '0'"?

Thanks again, @psherman!

Yes, it should have no effect.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

Ok. Thank you very much, @psherman!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.