Unifi 6 LR Issues

Did you see the thread at UniFi 6 LR v2 ethernet not working ?

Looks like there are several different hardware revisions out there. And the current ethernet mac/pcs driver isn't so forgiving wrt phy configuration. I beleive the symptoms you describe could match non-working ethernet on an otherwise functional device.

@daniel is working on a fix for the mtk_eth_soc driver which looks really promising. But it's not ready for OpenWrt yet AFAIK. Depends on lots of rather new phylink stuff. In the meantime you could try the DTS changes suggested in that thread. But console will make the debugging easier than blindly trying to guess what's wrong...

Ah yeah thanks for the pointer, that thread didn't come up in my searching somehow. That does sound like the issue I'm having with the new one.

If it helps I can provide you a full dump of the flash of a not modified U6-LR v3, you will have to open the unit up and desolder the flash and write it using a programmer. If nothing else works and the device is still bricked this will solve your problem.

That may help, depending on what's going on when I get a chance to solder some pins on to access the serial port. Just got the case open earlier. Would dumping an existing working device using dd be equivalent to the raw dump you're talking about? Since I do have a second working device I could do that from too.

I've just fixed it, and I do believe it was because I flashed 6.0.21 onto a v3 device, that older firmware I'm guessing doesn't support the newer hardware variation. More details in the other thread UniFi 6 LR v2 ethernet not working - #53 by pythoner6

Hello,
I did the same and have the same problem with Unifi 6 LR. It has a steady white color and TFTP recovery mode does not work. How did you fix your device?

As I mentioned in the other thread I linked, I took it apart to get at the serial pins for the device. At that point the device was in a state where it had a openwrt image that was working aside from the Ethernet port. To recover I enabled wifi using the serial console, connected from my laptop, copied over a bootloader image from another non-bricked u6 lr and flashed that.

Thank ou very much. How did you do that? Is there any tutorilal about this method?

Is taking apart the device the only way to recover it? And no easier way!!

Guys, I did a monumental mistake. After flashing ubnt_unifi-6-lr-v2-squashfs-sysupgrade.bin, my ethernet port didn't work anymore and after checking some threads, I was thinking I needed to flash ubnt_unifi-6-lr-v2-ubootmod-squashfs-sysupgrade.itb and after force-flashing it through LuCI, my AP doesn't boot anymore and no prompt comes out of Serial. Anyone able to help me out?

My bad. The serial works fine now after confirming the GND pin snapped. After resoldering, I get:

ubnt boot ...
Flash Index: 0, MenuID: ef, DevID1: 40, DevID2: 20
Setup flash information successful, support list index: 43
 0. Name = Preloader, offset = 0, start_addr=30000000, size=262144,start_sector=0, end_sector=3
 1. Name = ATF, offset = 40000, start_addr=30040000, size=131072,start_sector=4, end_sector=5
 2. Name = u-boot, offset = 60000, start_addr=30060000, size=393216,start_sector=6, end_sector=11
 3. Name = u-boot-env, offset = c0000, start_addr=300c0000, size=65536,start_sector=12, end_sector=12
 4. Name = Factory, offset = d0000, start_addr=300d0000, size=262144,start_sector=13, end_sector=16
 5. Name = EEPROM, offset = 110000, start_addr=30110000, size=65536,start_sector=17, end_sector=17
 6. Name = bs, offset = 120000, start_addr=30120000, size=65536,start_sector=18, end_sector=18
 7. Name = cfg, offset = 130000, start_addr=30130000, size=1048576,start_sector=19, end_sector=34
 8. Name = kernel0, offset = 230000, start_addr=30230000, size=32374784,start_sector=35, end_sector=528
 9. Name = kernel1, offset = 2110000, start_addr=32110000, size=32374784,start_sector=529, end_sector=1022
Board: Ubiquiti Networks MT7622 board (a620-13.0000)
UBNT application initialized
bootm flag=0, states=70f
Wrong Image Format for bootm command
ERROR: can't get kernel image!

Ok, nevermind. I managed to recover with urescue and tftp put the stock file and now we're back on track. However the v2 openwrt firmware still doesn't work. It's definetly the right variant because I got 2 separate LEDs and The PHY is a "Marvell AQrate AQR112C". Thoughts?

So now it boots OpenWrt, except that Ethernet does not work?

Yes, and I also figured out that a 100M PoE Switch or injector will not work properly but a 1000M will. Changing the link to 10M will outright disable the ethernet port. The OEM firmware hasn't had this issue so this needs to be patched accordingly.

Please ask Ubiquiti for the GPL sources (kernel + uboot) so that their non-upstreamed patch for 100M / 10M operation can be included. If they don't comply then please escalate (e.g. Software Freedom Conservancy, Linux Foundation etc.).

1 Like