UniFi 6 LR bricked after installing OpenWrt

I purchased an UniFi 6 LR directly from Ubiquiti and first got it working with the official software but decided to switch to OpenWrt. I tried version 21.02.0 and 21.02.1 as well as the linked snapshot build (multiple versions) following the given instructions. The result is always that the led is steady white for a few seconds followed by a white flash and then it turns off. Till now I have always been able to restore the original firmware using tftp (on the first try it selected as ip address instead of

The Flash Layout matches the docs exactly and I am using MobaXTerm for ssh and scp.

Could anyone please give me some hints how to get this working?

Files I have used:
Note: I once accidentally used the initramfs-kernel image instead of the sysupgrade image.

Additional Information:

U6-LR-BZ.5.60.23# uname -a
Linux U6-LR 4.4.198 #0 SMP Thu Aug 30 12:10:54 2018 aarch64 GNU/Linux

U6-LR-BZ.5.60.23# cat /proc/version
Linux version 4.4.198 (builder@owrt1505-builder) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3979-2252731af4) ) #0 SMP Thu Aug 30 12:10:54 2018

Any news on this? Did you manage to get it working?

Are you really sure they're bricked ? Current snapshot images DO work but the LED isn't. So please wait a while after flashing OpenWRT (open a ping to for instance). When the AP finished first boot it probably takes a few minutes to become responsive due a (mount_root) process that takes some (CPU) time. This is only the first time after a OpenWRT firmware upgrade, future boots should finish way faster.

Could you please share your TFTP recovery method / experience in THIS post ? Me and others having issues with the official ubiquiti tftp recovery procedure not working at all. Tnx!

I just got mine going by putting it in the 'tftp' mode following https://help.ui.com/hc/en-us/articles/204910124-UniFi-TFTP-Recovery-for-Bricked-Access-Points. Only problem was that the device was not pingable at I also tried different other IPs up to without success.

Than I decided to do a network scan using nmap - success!

$ sudo nmap -sn 192.168.1.*
Starting Nmap 7.91 ( https://nmap.org ) at 2022-02-16 07:14 CET
Nmap scan report for
Host is up (0.00011s latency).
MAC Address: D0:21:XX:XX:XX:XX (Ubiquiti Networks)
Nmap scan report for fedora (
Host is up.
Nmap done: 256 IP addresses (2 hosts up) scanned in 15.09 seconds

Nmap discovered a host at (???). This ip was pingable and for the first time tftp succeeded putting the latest firmware (5.60.23) on my device:

$ tftp -v
Connected to (, port 69
tftp> binary
mode set to octet
tftp> rexmt 1
tftp> timeout 60
tftp> put BZ.MT7622_5.60.23+13051.211209.2348.bin
putting BZ.MT7622_5.60.23+13051.211209.2348.bin to [octet]
Sent 14649771 bytes in 1.7 seconds [70975982 bit/s]

Note the stock firmware of my device was 5.60.8.

1 Like

First: I am sure that my device was bricket, because I could not even enter TFTP-Mode again.

I got a new LR6 and tried the flash procedure again. This time it worked. Though the LED still is not working. The boot procedure starts with a solid white LED then the LED flashed white multiple times and then turns off. After a while the device is accessible on

Tried with OpenWrt 21.02.2

1 Like