UniElec U7628-01 becomes inaccessible after 19.07.3 upgrade error

I'm new in OpenWrt and I have a problem with UniElec U7628-01 (tech data unielec_u7628-01).

I have tried to install the last release of OpenWrt firmware (19.07.3) using the LuCI interface and this upgrade guide. I have uploaded through the LuCI interface the u7628-01-128M-16M-squashfs-sysupgrade.bin firmware upgrade file taken from this resource.

But something went wrong because now I can no longer use the router. I supposed that during the upload I lost the wi-fi connection with the router (yes, I know, I should have used the ethernet cable), but I'm not sure if this is the cause. Now I can no longer use the LuCI interface, I can't establish an ssh connection, the wi-fi access point doesn't work anymore and the ethernet doesn't establish an IP configuration. When I turn the platform on, the Wi-Fi led stays on for only a few seconds and then turns off, while before when the access point worked, that led flashed. I have tried to reset and access the recovery mode as explained in Since Supported Commit and I have tried a TFTP connection with ethernet, but nothing.

The only thing I haven't tried is a serial connection because I don't have the USB adapter.

What should I do? Is it possible that an error during the upgrade has done so much damage? What happened?

There is not much information about the UniElec U7628-01 and I can't understand which is the way to resolve this problem. I thought that the current firmware is corrupted and that I should flash a new firmware but if I can't access the router with a TFTP connection though an ethernet cable, how can I flash a new firmware? Can I flash a new firmware with a serial?

Thanks in advance

I suppose you need [3.3V] console first, then follow instructions in https://openwrt.org/toh/unielec/unielec_u7628-01

1 Like

It's clear there are a lot of variants of this device both hardware and software. A likely reason for bricking is that the memory sizes of your unit don't match the build.

If your unit has the Breed bootloader there is web recovery. If it is a u-boot bootloader you need serial.

In any case serial would help immensely to debug the situation.

1 Like

Thank you guys, I understand that fortunately it is nothing serious. I will try with serial and I will let you know if i solved it and how.

@AndrewZ @mk24

Thank you, finally I tried to connect with serial and I managed to access the U-Boot console.

Now I have a new problem (related with this topic) because I tried to load a firmware image (taken here) through the serial port (related guide), but after rebooting the firmware, the serial console no longer transmitted anything.

I think that I have overwrite or erase the U-Boot bootloader. In this platform I don't have the JTAG port. What should I do now? Does the U7628 support the serial UART boot? Is there now a recovery procedure?

If you have erased the bootloader, the recovery is to use a SPI programmer directly on the flash chip. There is no UART ROM boot.