Unexpected wireless settings behavior

This looks promising. I made the changes suggested. Just so everyone has the latest updates, here are the current contents of /etc/config/network :

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdc8:2218:bb0b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'br-wifi'
        option type 'bridge'
        list ports 'wlan0'
        list ports 'wlan1'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

config interface 'wifi'
        option device 'br-wifi'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.0.0.0'

After running all these:

root@OpenWrt:~# ifdown wifi
root@OpenWrt:~# ifup wifi
root@OpenWrt:~# wifi
root@OpenWrt:~# /etc/init.d/firewall restart
root@OpenWrt:~# /etc/init.d/dnsmasq restart

I was able to connect to the 2.4GHz network with laptop1 on the ubuntu partition. I'll connect to it with laptop2 and leave it overnight to see if it's still happy in the morning. I may even connect a few other devices to push things just a tiny bit more. I still see this:

root@OpenWrt:~#   /etc/init.d/dnsmasq restart
udhcpc: started, v1.35.0
udhcpc: broadcasting discover
udhcpc: no lease, failing
root@OpenWrt:~#

but nobody has identified it as a concern so far. Thanks for jumping in on this!

1 Like

It is not something to be concerned. It means that there is no other DHCP server running in the lan.

Remove the ports lines. In /etc/config/network, a bridge that is going to be only wifi will start out empty. The wireless configuration will add the APs to the bridge.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.