Unexpected wireless settings behavior

Hello,

I followed the instructions to set up a Routed AP, but needed to add a step to set the uplink to be a dhcp client. As I finish getting the configuration the way I want it, I ran into a few weird issues. I'm on a Netgear WAC104.

After completing the setup, I can join the wireless network, am getting an IP address in the correct range, and can access the internet via the uplink. However, if I try to change the network name, it almost always fails. I've found that as long as it starts with "OpenWrt", it's ok. For example, OpenWrt, OpenWrt4, OpenWrt-tower57 all work. However, anything that doesn't start with it fails: tower24, tower57-OpenWrt, etc. According to the docs, it seems like this shouldn't be a requirement since the example explicitly shows an SSID without the prefix. However, I can consistently reproduce the case where I can connect to the network is the prefix is present and cannot connect if it is not. I can also reproduce this but in the web interface and command line. How do I fix this? Is there some setting that I need to change that validates SSIDs?

I'm also unable to set my network as hidden. When I set this either in the web interface (just a checkbox) or the command line, I'm no longer able to join the network. If I remove the hidden setting, I can join the network again. I haven't found anything yet that gives me a good sense of what this would be or what is happening. Logs don't seem to have anything useful that I can tell and I can't seem to find anything different in the configs other than the line to hide the ssid. How do I get the hidden setting to work?

Thanks for the help!

It's not a requirements, but without the actual (faulty-) configs, anything else would be guesswork - and crystal balls are in short demand.

While this is technically possible, it's (almost) never a good idea.

2 Likes

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

Happy to supply the configs. Since this followed one of the openwrt guides and started with an openwrt default config, I thought maybe these were known things since they're very specific and that somehow I missed them in the docs and the forum. I'll add those to the request for them below that specified the ones to provide.

I'm open to better improvements that obviate the need for a hidden network, though I have had no troubles with hidden networks so far. I've found that I know so much less than I thought I did about configuring home networking devices so before I go really crazy learning and enjoying the power that openwrt affords, I just wanted to get something basic working - even if it isn't optimal. I actually bought a second identical device intentionally to spend time doing that. I anticipate that it will take a lot of time (and guidance - as much as I was trying not to bother here) to get a setup that makes the experts happy - especially since this basic setup that I expected to take a couple hours ended up taking all weekend. However, I wanted to parcel that out to a different thread once the basics here are handled. Hope that makes sense.

Here is the output. Hope this helps narrow down the issue. Thanks!

BusyBox v1.35.0 (2023-01-03 00:24:21 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 22.03.3, r20028-43d71ad93e
 -----------------------------------------------------
root@OpenWrt:~# ubus call system board; \
> uci export network; uci export wireless; \
> uci export dhcp; uci export firewall; \
> ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
{
	"kernel": "5.10.161",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "Netgear WAC104",
	"board_name": "netgear,wac104",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.3",
		"revision": "r20028-43d71ad93e",
		"target": "ramips/mt7621",
		"description": "OpenWrt 22.03.3 r20028-43d71ad93e"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fffb:aaaa:cccc::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config interface 'wifi'
	option proto 'static'
	option ipaddr '10.0.0.1'
	option netmask '255.0.0.0'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'wifi'
	option mode 'ap'
	option encryption 'psk2'
	option key 'redacted-password'
	option ssid 'OpenWrt-tower57'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'wifi'
	option mode 'ap'
	option encryption 'psk2'
	option key 'redacted-password'
	option ssid 'OpenWrt-tower57'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config dhcp 'wifi'
	option interface 'wifi'
	option start '100'
	option limit '150'
	option leasetime '12h'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option masq '1'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config zone
	option name 'wifi'
	list network 'wifi'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config forwarding
	option src 'lan'
	option dest 'wifi'

config forwarding
	option src 'wifi'
	option dest 'lan'

config forwarding
	option src 'wifi'
	option dest 'wan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip '8888::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.30/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
10: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 10.0.0.1/8 brd 10.255.255.255 scope global wlan1
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev br-lan  src 192.168.1.30 
10.0.0.0/8 dev wlan1 scope link  src 10.0.0.1 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.30 
broadcast 10.0.0.0 dev wlan1 table local scope link  src 10.0.0.1 
local 10.0.0.1 dev wlan1 table local scope host  src 10.0.0.1 
broadcast 10.255.255.255 dev wlan1 table local scope link  src 10.0.0.1 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.1.0 dev br-lan table local scope link  src 192.168.1.30 
local 192.168.1.30 dev br-lan table local scope host  src 192.168.1.30 
broadcast 192.168.1.255 dev br-lan table local scope link  src 192.168.1.30 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
lrwxrwxrwx    1 root     root            16 Jan  2 16:24 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 Apr  3 07:35 /tmp/resolv.conf
-rw-r--r--    1 root     root            39 Apr  2 22:49 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            39 Apr  2 22:49 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface lan
nameserver 192.168.1.1
root@OpenWrt:~# 

In general it looks fine. A few remarks:

  1. Change the netmask in wifi into something more down-to-earth, like 255.255.255.0, as your DHCP is not covering all 16,7 million addresses, nor will you be able to handle more than 50 wireless devices.
  2. ula prefix should start from fdxx and it is private, so there is no need to redact it.
  3. How are you applying the changes in wifi, e.g SSID and hidden? Luci, uci, edit configs?
  4. What does logread and dmesg say when you try to apply the changes?

This networking device is intended to house all the home automation stuff. My intent was to spread these sparsely across 10.x so I can group devices by location or type as opposed to having 10.0.0.1 be a light, 2 be a camera, 3, 4, 5, be lights, 6 be a motion sensor, 7 be the driveway lights, 8 be the master closet light, etc. You're right I'll never have millions of devices filling the whole address space, but is it totally stupid to try to organize the devices this way? They'll mostly have static IPs eventually. I was expecting there wasn't considerable overhead. Is that not the case?

Is it worth unredacting the ula value for this question or is that for future reference?

I've tried applying the setting via luci (web interface) and editing the config files manually via vi and observed the same result. I thought maybe one would show me what I was doing wrong in the other, but no dice.

I'll grab dmesg logs later today. I'm less familiar with logread. I can read up on it to see what we're getting there or if you want me to provide something specific, please let me know.

Not stupid, but doesn’t need to be so sparse. How many of each device?

How about just using the last octet. For example
10.0.0.10-19 = cameras
10.0.0.20-49 = lights
Etc

I started with that on the old network, but kept having to rearrange them as things changed and I didn't buffer quite right. It also required me to buffer for things on my wish list (say, more cameras) even if they weren't going to happen in the foreseeable future. I wanted to eliminate this problem completely with the space that I have here. Maybe a middle ground? What about 10.1.x.x? That gives me 250 categories and each one has more than enough space. My original plan was to use 10.0.x for "visiting" devices like my laptop (NOT a guest network), but putting those in, say, 10.1.0.x is something I could live with. Is 10.1.x.x more reasonable given what I'm trying to do (or avoid doing)?

Whatever floats your boat. But you could do blocks of 50 addresses - that would give you 5 categories.

Future reference.

Use logread -f to follow the logs.

So yay... new problem. I had the device off most of the day while I was away and after powering it on I can no longer connect to the wifi at all even with the config that used to work. Here's the log from trying to start the network again before I post the logs for the changes since I'm not sure that the logs for the config changes from previously working to previously not working will still be relevant when I'm not starting from a working state. I am using the steps from the Routed AP guide again. I added an ifdown after having issues running an ifup as the first command even though I thought ifup was supposed to have an ifdown in it.

root@OpenWrt:~# ifdown wifi
# no new dmesg message
# logread messages
Mon Apr  3 21:17:23 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:17:25 2023 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: DNS service limited to local subnets
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Mon Apr  3 21:17:30 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses

Even though ifup says that it times out, it seems to finish in the logs (right?).

root@OpenWrt:~# ifup wifi
Command failed: Request timed out
root@OpenWrt:~#

# dmesg messages
[ 2417.787182] do_page_fault(): sending SIGSEGV to netifd for invalid read access from 00000094
[ 2417.804107] epc = 00403b1d in netifd[400000+1d000]
[ 2417.814035] ra  = 004039d7 in netifd[400000+1d000]
[ 2424.846121] br-lan: port 4(lan4) entered disabled state
[ 2424.860160] device lan4 left promiscuous mode
[ 2424.869287] br-lan: port 4(lan4) entered disabled state
[ 2424.928945] device lan3 left promiscuous mode
[ 2424.938001] br-lan: port 3(lan3) entered disabled state
[ 2424.988742] device lan2 left promiscuous mode
[ 2424.997709] br-lan: port 2(lan2) entered disabled state
[ 2425.058545] device lan1 left promiscuous mode
[ 2425.067285] device eth0 left promiscuous mode
[ 2425.076254] br-lan: port 1(lan1) entered disabled state
[ 2425.283522] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[ 2425.318939] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[ 2425.335422] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[ 2425.358446] mt7530 mdio-bus:1f lan1: configuring for phy/gmii link mode
[ 2425.379848] 8021q: adding VLAN 0 to HW filter on device lan1
[ 2425.394900] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 2425.416949] br-lan: port 1(lan1) entered blocking state
[ 2425.427531] br-lan: port 1(lan1) entered disabled state
[ 2425.439747] device lan1 entered promiscuous mode
[ 2425.449099] device eth0 entered promiscuous mode
[ 2425.486458] mt7530 mdio-bus:1f lan2: configuring for phy/gmii link mode
[ 2425.500575] 8021q: adding VLAN 0 to HW filter on device lan2
[ 2425.515585] br-lan: port 2(lan2) entered blocking state
[ 2425.526669] br-lan: port 2(lan2) entered disabled state
[ 2425.539049] device lan2 entered promiscuous mode
[ 2425.573812] mt7530 mdio-bus:1f lan3: configuring for phy/gmii link mode
[ 2425.590616] 8021q: adding VLAN 0 to HW filter on device lan3
[ 2425.605524] br-lan: port 3(lan3) entered blocking state
[ 2425.616063] br-lan: port 3(lan3) entered disabled state
[ 2425.637523] device lan3 entered promiscuous mode
[ 2425.652533] mt7530 mdio-bus:1f lan4: Link is Down
[ 2425.674584] mt7530 mdio-bus:1f lan4: configuring for phy/gmii link mode
[ 2425.693014] 8021q: adding VLAN 0 to HW filter on device lan4
[ 2425.709000] br-lan: port 4(lan4) entered blocking state
[ 2425.719498] br-lan: port 4(lan4) entered disabled state
[ 2425.735087] device lan4 entered promiscuous mode
[ 2425.749686] br-lan: port 4(lan4) entered blocking state
[ 2425.760203] br-lan: port 4(lan4) entered forwarding state
[ 2425.774548] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 2425.793624] br-lan: port 4(lan4) entered disabled state
[ 2428.759418] mt7530 mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
[ 2428.781384] br-lan: port 4(lan4) entered blocking state
[ 2428.791897] br-lan: port 4(lan4) entered forwarding state
[ 2449.655626] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2451.498058] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

# logread messages

Mon Apr  3 21:21:16 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:21:16 2023 kern.info kernel: [ 2417.787182] do_page_fault(): sending SIGSEGV to netifd for invalid read access from 00000094
Mon Apr  3 21:21:16 2023 kern.info kernel: [ 2417.804107] epc = 00403b1d in netifd[400000+1d000]
Mon Apr  3 21:21:16 2023 kern.info kernel: [ 2417.814035] ra  = 004039d7 in netifd[400000+1d000]
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: bonding
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: 8021ad
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: 8021q
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: macvlan
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: veth
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: bridge
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: Network device
Mon Apr  3 21:21:21 2023 user.notice : Added device handler type: tunnel
Mon Apr  3 21:21:23 2023 kern.info kernel: [ 2424.846121] br-lan: port 4(lan4) entered disabled state
Mon Apr  3 21:21:23 2023 kern.info kernel: [ 2424.860160] device lan4 left promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2424.869287] br-lan: port 4(lan4) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2424.928945] device lan3 left promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2424.938001] br-lan: port 3(lan3) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2424.988742] device lan2 left promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2424.997709] br-lan: port 2(lan2) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.058545] device lan1 left promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.067285] device eth0 left promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.076254] br-lan: port 1(lan1) entered disabled state
Mon Apr  3 21:21:24 2023 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Mon Apr  3 21:21:24 2023 daemon.warn netifd: You have delegated IPv6-prefixes but haven't assigned them to any interface. Did you forget to set option ip6assign on your lan-interfaces?
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.283522] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.318939] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.335422] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.358446] mt7530 mdio-bus:1f lan1: configuring for phy/gmii link mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.379848] 8021q: adding VLAN 0 to HW filter on device lan1
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.394900] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.416949] br-lan: port 1(lan1) entered blocking state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.427531] br-lan: port 1(lan1) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.439747] device lan1 entered promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.449099] device eth0 entered promiscuous mode
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Interface 'lan' is enabled
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.486458] mt7530 mdio-bus:1f lan2: configuring for phy/gmii link mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.500575] 8021q: adding VLAN 0 to HW filter on device lan2
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.515585] br-lan: port 2(lan2) entered blocking state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.526669] br-lan: port 2(lan2) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.539049] device lan2 entered promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.573812] mt7530 mdio-bus:1f lan3: configuring for phy/gmii link mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.590616] 8021q: adding VLAN 0 to HW filter on device lan3
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.605524] br-lan: port 3(lan3) entered blocking state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.616063] br-lan: port 3(lan3) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.637523] device lan3 entered promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.652533] mt7530 mdio-bus:1f lan4: Link is Down
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.674584] mt7530 mdio-bus:1f lan4: configuring for phy/gmii link mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.693014] 8021q: adding VLAN 0 to HW filter on device lan4
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.709000] br-lan: port 4(lan4) entered blocking state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.719498] br-lan: port 4(lan4) entered disabled state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.735087] device lan4 entered promiscuous mode
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.749686] br-lan: port 4(lan4) entered blocking state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.760203] br-lan: port 4(lan4) entered forwarding state
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.774548] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Mon Apr  3 21:21:24 2023 kern.info kernel: [ 2425.793624] br-lan: port 4(lan4) entered disabled state
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Interface 'loopback' is enabled
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Interface 'loopback' is setting up now
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Interface 'loopback' is now up
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Network device 'eth0' link is up
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Network device 'lo' link is up
Mon Apr  3 21:21:24 2023 daemon.notice netifd: Interface 'loopback' has link connectivity
Mon Apr  3 21:21:25 2023 daemon.err odhcpd[1547]: Failed to send to ff02::1%lan@br-lan (Address not available)
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Wireless device 'radio0' is now up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Network device 'wlan0' link is up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is enabled
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' has link connectivity
Mon Apr  3 21:21:27 2023 kern.info kernel: [ 2428.759418] mt7530 mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
Mon Apr  3 21:21:27 2023 kern.info kernel: [ 2428.781384] br-lan: port 4(lan4) entered blocking state
Mon Apr  3 21:21:27 2023 kern.info kernel: [ 2428.791897] br-lan: port 4(lan4) entered forwarding state
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Network device 'lan4' link is up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: bridge 'br-lan' link is up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'lan' has link connectivity
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'lan' is setting up now
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Wireless device 'radio1' is now up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Network device 'wlan1' link is up
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is disabled
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is enabled
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:21:27 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:21:28 2023 daemon.notice netifd: lan (13645): udhcpc: started, v1.35.0
Mon Apr  3 21:21:28 2023 daemon.notice netifd: lan (13645): udhcpc: broadcasting discover
Mon Apr  3 21:21:28 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan0)
Mon Apr  3 21:21:28 2023 daemon.notice netifd: lan (13645): udhcpc: broadcasting select for 192.168.1.28, server 192.168.1.1
Mon Apr  3 21:21:28 2023 daemon.notice netifd: lan (13645): udhcpc: lease of 192.168.1.28 obtained from 192.168.1.1, lease time 86400
Mon Apr  3 21:21:28 2023 daemon.notice netifd: Interface 'lan' is now up
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:21:28 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:21:29 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan0)
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: DNS service limited to local subnets
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 10.0.0.100 -- 10.0.0.249, lease time 12h
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:21:31 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Apr  3 21:21:31 2023 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: Remove interface 'wlan0'
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Apr  3 21:21:47 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Apr  3 21:21:47 2023 daemon.notice netifd: Network device 'wlan0' link is down
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: Remove interface 'wlan1'
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: wlan1: interface state ENABLED->DISABLED
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: wlan1: AP-DISABLED
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Mon Apr  3 21:21:47 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Apr  3 21:21:47 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Mon Apr  3 21:21:47 2023 daemon.notice netifd: Wireless device 'radio0' is now down
Mon Apr  3 21:21:47 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Mon Apr  3 21:21:48 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Mon Apr  3 21:21:48 2023 daemon.notice netifd: Network device 'wlan0' link is up
Mon Apr  3 21:21:48 2023 kern.info kernel: [ 2449.655626] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mon Apr  3 21:21:48 2023 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->ENABLED
Mon Apr  3 21:21:48 2023 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Apr  3 21:21:49 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Mon Apr  3 21:21:49 2023 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->HT_SCAN
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Wireless device 'radio0' is now up
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:21:50 2023 daemon.notice hostapd: Switch own primary and secondary channel to get secondary channel with no Beacons from other BSSes
Mon Apr  3 21:21:50 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan0)
Mon Apr  3 21:21:50 2023 kern.info kernel: [ 2451.498058] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Mon Apr  3 21:21:50 2023 daemon.notice hostapd: wlan1: interface state HT_SCAN->ENABLED
Mon Apr  3 21:21:50 2023 daemon.notice hostapd: wlan1: AP-ENABLED
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Wireless device 'radio1' is now up
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Network device 'wlan1' link is up
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is disabled
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is enabled
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:21:50 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:21:51 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan0)
Mon Apr  3 21:21:53 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:21:53 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:21:53 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:21:53 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
root@OpenWrt:~# wifi

# dmesg messages
[ 2903.942333] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2904.761210] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

# logread messages
Mon Apr  3 21:29:20 2023 daemon.notice hostapd: Remove interface 'wlan1'
Mon Apr  3 21:29:20 2023 daemon.notice hostapd: wlan1: interface state ENABLED->DISABLED
Mon Apr  3 21:29:20 2023 daemon.notice hostapd: wlan1: AP-DISABLED
Mon Apr  3 21:29:20 2023 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Mon Apr  3 21:29:20 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Apr  3 21:29:20 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Mon Apr  3 21:29:21 2023 daemon.notice hostapd: Remove interface 'wlan0'
Mon Apr  3 21:29:21 2023 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Mon Apr  3 21:29:21 2023 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Apr  3 21:29:21 2023 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Apr  3 21:29:21 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Apr  3 21:29:21 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Apr  3 21:29:21 2023 daemon.notice netifd: Network device 'wlan0' link is down
Mon Apr  3 21:29:21 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Mon Apr  3 21:29:21 2023 daemon.notice netifd: Wireless device 'radio0' is now down
Mon Apr  3 21:29:22 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Mon Apr  3 21:29:22 2023 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->HT_SCAN
Mon Apr  3 21:29:22 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Mon Apr  3 21:29:23 2023 daemon.notice netifd: Network device 'wlan0' link is up
Mon Apr  3 21:29:23 2023 kern.info kernel: [ 2903.942333] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mon Apr  3 21:29:23 2023 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->ENABLED
Mon Apr  3 21:29:23 2023 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Apr  3 21:29:23 2023 daemon.notice hostapd: Switch own primary and secondary channel to get secondary channel with no Beacons from other BSSes
Mon Apr  3 21:29:23 2023 kern.info kernel: [ 2904.761210] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Mon Apr  3 21:29:23 2023 daemon.notice hostapd: wlan1: interface state HT_SCAN->ENABLED
Mon Apr  3 21:29:23 2023 daemon.notice hostapd: wlan1: AP-ENABLED
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Wireless device 'radio1' is now up
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Network device 'wlan1' link is up
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Wireless device 'radio0' is now up
Mon Apr  3 21:29:24 2023 daemon.notice netifd: Network device 'wlan0' link is up
Mon Apr  3 21:29:24 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan1)
Mon Apr  3 21:29:29 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:29:29 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:29:29 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:29:29 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
root@OpenWrt:~# /etc/init.d/firewall restart

# no dmesg messages
# no logread messages
root@OpenWrt:~#   /etc/init.d/dnsmasq restart
udhcpc: started, v1.35.0
udhcpc: broadcasting discover
udhcpc: no lease, failing
root@OpenWrt:~#

# no dmesg messages

# logread messages
Mon Apr  3 21:34:00 2023 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: started, version 2.86 cachesize 150
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: DNS service limited to local subnets
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-cryptohash no-DNSSEC no-ID loop-detect inotify dumpfile
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 10.0.0.100 -- 10.0.0.249, lease time 12h
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using nameserver 192.168.1.1#53
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for test
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for local
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:34:04 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses

Now that all that is out of the way, here are the logs that were actually requested:

Ticking the Hide ESSID checkbox in luci for the 2.4GHz network:

# dmesg messages
[ 3574.698815] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

# logread messages
Mon Apr  3 21:40:32 2023 daemon.notice hostapd: Remove interface 'wlan0'
Mon Apr  3 21:40:32 2023 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Mon Apr  3 21:40:32 2023 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Apr  3 21:40:32 2023 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Apr  3 21:40:32 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Apr  3 21:40:32 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Apr  3 21:40:33 2023 daemon.notice netifd: Wireless device 'radio0' is now down
Mon Apr  3 21:40:33 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Mon Apr  3 21:40:33 2023 kern.info kernel: [ 3574.698815] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mon Apr  3 21:40:33 2023 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->ENABLED
Mon Apr  3 21:40:33 2023 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Apr  3 21:40:35 2023 daemon.notice netifd: Wireless device 'radio0' is now up
Mon Apr  3 21:40:35 2023 daemon.notice netifd: Network device 'wlan0' link is up
Mon Apr  3 21:40:35 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:40:35 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:40:35 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:40:35 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan0)
Mon Apr  3 21:40:38 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:40:38 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:40:38 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:40:38 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Apr  3 21:40:40 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:40:40 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:40:40 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:40:40 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses

I can see that this line has been added to the config wifi-iface 'default_radio0' block in /etc/config/wireless:

option hidden '1'

(message too long, part 1/2)

(part 2/2)

Following this, I tried to connect to the network, but am using the same laptop so I lost a few of the messages. However, I think I got the useful parts from logread that might be helpful:

Mon Apr  3 21:44:37 2023 daemon.info hostapd: wlan1: STA <LAPTOP_MAC> IEEE 802.11: authenticated
Mon Apr  3 21:44:37 2023 daemon.info hostapd: wlan1: STA <LAPTOP_MAC> IEEE 802.11: associated (aid 1)
Mon Apr  3 21:44:37 2023 daemon.notice hostapd: wlan1: AP-STA-CONNECTED <LAPTOP_MAC>
Mon Apr  3 21:44:37 2023 daemon.info hostapd: wlan1: STA <LAPTOP_MAC> WPA: pairwise key handshake completed (RSN)
Mon Apr  3 21:44:37 2023 daemon.notice hostapd: wlan1: EAPOL-4WAY-HS-COMPLETED <LAPTOP_MAC>
Mon Apr  3 21:44:37 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 21:44:39 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 21:44:44 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 21:44:52 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 21:45:08 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 21:45:23 2023 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED <LAPTOP_MAC>
Mon Apr  3 21:45:26 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan

However, this isn't entirely related as it appears the laptop is trying to connect to the 5GHz network which doesn't hav the hidden flag enabled. So here's what happens when I try that:

First enabling Hide ESSID for the 5GHz network in luci:

# dmesg messages
[ 4358.608360] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

# logread messages
Mon Apr  3 21:53:35 2023 daemon.notice hostapd: Remove interface 'wlan1'
Mon Apr  3 21:53:35 2023 daemon.notice hostapd: wlan1: interface state ENABLED->DISABLED
Mon Apr  3 21:53:35 2023 daemon.notice hostapd: wlan1: AP-DISABLED
Mon Apr  3 21:53:35 2023 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Mon Apr  3 21:53:35 2023 daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied
Mon Apr  3 21:53:35 2023 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Mon Apr  3 21:53:35 2023 daemon.notice netifd: Wireless device 'radio1' is now down
Mon Apr  3 21:53:36 2023 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Mon Apr  3 21:53:36 2023 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->HT_SCAN
Mon Apr  3 21:53:37 2023 daemon.notice hostapd: Switch own primary and secondary channel to get secondary channel with no Beacons from other BSSes
Mon Apr  3 21:53:37 2023 kern.info kernel: [ 4358.608360] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Mon Apr  3 21:53:37 2023 daemon.notice hostapd: wlan1: interface state HT_SCAN->ENABLED
Mon Apr  3 21:53:37 2023 daemon.notice hostapd: wlan1: AP-ENABLED
Mon Apr  3 21:53:37 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:53:37 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:53:37 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:53:37 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Wireless device 'radio1' is now up
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Network device 'wlan1' link is up
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Interface 'wifi' is disabled
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Interface 'wifi' is now down
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Interface 'wifi' is enabled
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Interface 'wifi' is setting up now
Mon Apr  3 21:53:37 2023 daemon.notice netifd: Interface 'wifi' is now up
Mon Apr  3 21:53:38 2023 user.notice firewall: Reloading firewall due to ifup of wifi (wlan0)
Mon Apr  3 21:53:40 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Mon Apr  3 21:53:40 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr  3 21:53:40 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 addresses
Mon Apr  3 21:53:40 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Mon Apr  3 21:56:51 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan

Similar to before, I can see that this line was added to the config wifi-iface 'default_radio1' config block on /etc/config/wireless:

option hidden '1'

At this point, I'm not sure why, but I'm seeing an old wifi name appear in my list of wireless networks. It says that it can see an OpenWrt8 even though I can see in /etc/config/wireless that both SSIDs are still OpenWrt-tower57.

When trying to connect to the OpenWrt8 network - which shouldn't exist - it looks like it might be trying. The logs blink while the laptop is trying to join the network and I'm offline, but I do get this line in the logs:

# no dmesg messages

# logread messages (maybe the rest were missing?)
Mon Apr  3 22:14:01 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan

I fired up another laptop that I had available to connect to the network that shouldn't exist and hasn't connected to this WAC104 at all. When it tried to connect to OpenWrt8, I did get this log again in the logread tail:

Mon Apr  3 22:17:58 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan

So there is something really strange happening here.

I checked /etc/config/wireless again to see if somehow the config changed without me, but I still see this:

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wifi'
        option mode 'ap'
        option encryption 'psk2'
        option key 'FAKE_PASSWORD'
        option ssid 'OpenWrt-tower57'
        option hidden '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'wifi'
        option mode 'ap'
        option encryption 'psk2'
        option key 'FAKE_PASSWORD'
        option ssid 'OpenWrt-tower57'
        option hidden '1'

I have no idea how OpenWrt8 is being found or how the device is responding to it. I also try to connect to the current network OpenWrt-tower57, and it does still try to do that too:

Mon Apr  3 22:25:30 2023 daemon.info hostapd: wlan1: STA <LAPTOP_MAC> IEEE 802.11: authenticated
Mon Apr  3 22:25:30 2023 daemon.info hostapd: wlan1: STA <LAPTOP_MAC> IEEE 802.11: associated (aid 1)
Mon Apr  3 22:25:30 2023 daemon.notice hostapd: wlan1: AP-STA-CONNECTED <LAPTOP_MAC>
Mon Apr  3 22:25:30 2023 daemon.info hostapd: wlan1: STA <LAPTOP_MAC> WPA: pairwise key handshake completed (RSN)
Mon Apr  3 22:25:30 2023 daemon.notice hostapd: wlan1: EAPOL-4WAY-HS-COMPLETED <LAPTOP_MAC>
Mon Apr  3 22:25:30 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 22:25:31 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan
Mon Apr  3 22:25:32 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 22:25:35 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan
Mon Apr  3 22:25:35 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan
Mon Apr  3 22:25:37 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 22:25:45 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 22:26:02 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan1 which has no address
Mon Apr  3 22:26:15 2023 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED <LAPTOP_MAC>
Mon Apr  3 22:26:20 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan

While I had access to the other laptop, I figured I'd verify that the OpenWrt-tower57 network wouldn't work there either and watch the logs without losing my connection to the network device. But it does something even more inconsistent: it connects! That ancient machine only has 2.4GHz so I'm not sure if that helps or hurts. Both laptops are running ubuntu. Here is the tail from logread for that connection:

Mon Apr  3 22:31:08 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: authenticated
Mon Apr  3 22:31:08 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: associated (aid 1)
Mon Apr  3 22:31:08 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED <LAPTOP2_MAC>
Mon Apr  3 22:31:08 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> WPA: pairwise key handshake completed (RSN)
Mon Apr  3 22:31:08 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED <LAPTOP2_MAC>
Mon Apr  3 22:31:12 2023 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(wlan0) <LAPTOP2_MAC>
Mon Apr  3 22:31:12 2023 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(wlan0) 10.0.0.107 <LAPTOP2_MAC>
Mon Apr  3 22:31:12 2023 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(wlan0) <LAPTOP2_MAC>
Mon Apr  3 22:31:12 2023 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(wlan0) 10.0.0.107 <LAPTOP2_MAC>
Mon Apr  3 22:31:12 2023 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(wlan0) 10.0.0.107 <LAPTOP2_MAC>
Mon Apr  3 22:31:12 2023 daemon.info dnsmasq-dhcp[1]: DHCPACK(wlan0) 10.0.0.107 <LAPTOP2_MAC> <LAPTOP2_HOSTNAME>

I'm a bit lost. Hopefully this makes sense. I didn't do the logging for the SSID change yet because I'm not sure we need to add more mess to this.

And now another new behavior has surfaced. I can still see OpenWrt8 which still shouldn't exist. With the other laptop connected to the 2.4GHz network, I changed the name of the 5GHz network to chillywilly and I can connect to it with the laptop that was having trouble connecting to any of the wifi networks earlier. They're both hidden and the 5GHz network no longer needs the OpenWrt prefix. I'm not sure how most of this has just started working and I'm even more concerned that I didn't do anything differently that should have "fixed" anything as far as I can tell. I'm at such a loss. I'm almost wondering if Ubuntu is the problem now. I wouldn't think there's a way to confuse it just by changing trivial settings of a wifi network like the name or hidden status, but maybe that makes more sense. Does this make any sense?

It doesn't make too much sense, so maybe you could verify that it works or not by using a mobile phone or a laptop with a different OS?

It's being difficult again. FYI, I have two different SSIDs for 2.4GHz and 5GHz so that I can be specific and know the network to which something is connecting. The 2.4GHz network to which I could connect last night appears to have become unresponsive despite not being bothered.

The laptop2 that was connecting to the 2.4GHz network (that's all it has) in ubuntu last night lost its connection and is not longer able to connect to the 2.4GHz network. It can't get an IP address. Here's what logread says:

Tue Apr  4 20:07:33 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:07:45 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED <LAPTOP2_MAC>
Tue Apr  4 20:08:03 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: authenticated
Tue Apr  4 20:08:03 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: associated (aid 1)
Tue Apr  4 20:08:03 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED <LAPTOP2_MAC>
Tue Apr  4 20:08:03 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> WPA: pairwise key handshake completed (RSN)
Tue Apr  4 20:08:03 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED <LAPTOP2_MAC>
Tue Apr  4 20:08:03 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:05 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:07 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:12 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:20 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:37 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:49 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED <LAPTOP2_MAC>
Tue Apr  4 20:08:50 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: authenticated
Tue Apr  4 20:08:50 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: associated (aid 1)
Tue Apr  4 20:08:50 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED <LAPTOP2_MAC>
Tue Apr  4 20:08:50 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> WPA: pairwise key handshake completed (RSN)
Tue Apr  4 20:08:50 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED <LAPTOP2_MAC>
Tue Apr  4 20:08:50 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:52 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:54 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:08:59 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:07 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:24 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:36 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED <LAPTOP2_MAC>
Tue Apr  4 20:09:37 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: authenticated
Tue Apr  4 20:09:37 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> IEEE 802.11: associated (aid 1)
Tue Apr  4 20:09:37 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED <LAPTOP2_MAC>
Tue Apr  4 20:09:37 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC> WPA: pairwise key handshake completed (RSN)
Tue Apr  4 20:09:37 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED <LAPTOP2_MAC>
Tue Apr  4 20:09:37 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:39 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:41 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:46 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:09:55 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:10:12 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:10:23 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED <LAPTOP2_MAC>

It seems like it keeps trying to join the network and these messages repeat over time.

When I try this on the windows partition of laptop2, it has trouble connecting but then says it's connected with no internet. Laptop2 can't reach URLs via a browser. Under the properties of the wifi connection, windows doesn't report having an IPv4 address. Luci says it has an associated station with the MAC address, but no dhcp lease. I've redacted the MAC to identify it as the windows logs, but it's the same value.

Tue Apr  4 20:34:18 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC_WINDOWS> IEEE 802.11: authenticated
Tue Apr  4 20:34:18 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC_WINDOWS> IEEE 802.11: associated (aid 1)
Tue Apr  4 20:34:18 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED <LAPTOP2_MAC_WINDOWS>
Tue Apr  4 20:34:18 2023 daemon.info hostapd: wlan0: STA <LAPTOP2_MAC_WINDOWS> WPA: pairwise key handshake completed (RSN)
Tue Apr  4 20:34:18 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED <LAPTOP2_MAC_WINDOWS>
Tue Apr  4 20:34:18 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:34:22 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:34:26 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:34:34 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:34:51 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:35:24 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:35:29 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:35:37 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:35:53 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address

EDIT: Though I don't have the logs (and don't expect them to provide any new info), laptop1 is also unable to connect to the 2.4GHz network in both with ubuntu partition (which has connected in the past) nor the windows partition (which hadn't connected to the network device at all previous to this)/

When I try to connect my Android (in case that's significant) phone to the 2.4GHz network, it won't connect either. It hadn't connected to any of the networks at the time when i tried this. Here are the logs for that connection attempt:

Tue Apr  4 20:19:09 2023 daemon.info hostapd: wlan0: STA <PHONE_MAC> IEEE 802.11: authenticated
Tue Apr  4 20:19:09 2023 daemon.info hostapd: wlan0: STA <PHONE_MAC> IEEE 802.11: associated (aid 1)
Tue Apr  4 20:19:10 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED <PHONE_MAC>
Tue Apr  4 20:19:10 2023 daemon.info hostapd: wlan0: STA <PHONE_MAC> WPA: pairwise key handshake completed (RSN)
Tue Apr  4 20:19:10 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED <PHONE_MAC>
Tue Apr  4 20:19:11 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:19:12 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:19:14 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:19:18 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:19:26 2023 daemon.warn dnsmasq-dhcp[1]: DHCP packet received on wlan0 which has no address
Tue Apr  4 20:19:29 2023 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED <PHONE_MAC>
Tue Apr  4 20:19:29 2023 daemon.info hostapd: wlan0: STA <PHONE_MAC> IEEE 802.11: disassociated
Tue Apr  4 20:19:30 2023 daemon.info hostapd: wlan0: STA <PHONE_MAC> IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Tue Apr  4 20:19:33 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan
Tue Apr  4 20:19:34 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan
Tue Apr  4 20:19:34 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via br-lan

The last messages look like they're not related even though they happen at the same time. They look suspicious as well. Nobody should be making dhcp requests via br-lan - at least not the way it's configured now (I'd like to eventually have two of the four lan ports exist on the same network as the wifi, but that's for later).

I'm not sure why the 2.4GHz network seemed fine before, but refuses connection requests (including ones it had before) now without any changes to the config. I tried to rtfm a bit to see if this "new" error was something that had a clear path forward. I see some older threads that necessarily run on an older version of the software than I'm using also evidenced by the fact that a page that used to have a possible answer doesn't even exist anymore so I'm wary of applying fixes or workarounds that may not be necessary or even advised anymore. It seems like the leading possibility to solve this new issue (if it is the issue) might be something like this wlan bridge, but I don't totally understand what's happening here and don't want to make willy-nilly changes without guidance or direction so I don't break things even more or put things in a state that we all haven't agreed upon. I also suspect if it was something that we needed that someone would noticed it already and identified it as a problem.

EDIT: The laptop1 (with a 5GHz radio) is able to connect to the 5GHz network in both the ubuntu and windows partitions. The android phone is also able to connect to the 5GHz network.

FYI - Page has been moved to https://openwrt.org/docs/guide-user/network/wifi/guestwifi/extras

I am out of any ideas. I have never come across these issues with the hidden and the SSID name. However the fact that some devices connect only to 5GHz without issues makes me think of faulty wifi or problematic driver.
Do you have any other device to test apart from this one?

This is a problem. It probably is because your wifi network is not a bridge. When set up (incorrectly) that way, only one of the APs will have an IP address and work. (Which one it may be is a race during startup). For more than one AP to be in the same network you need to declare a bridge:

config device
    option name 'br-wifi'
    option type 'bridge'

config interface 'wifi'
    option device 'br-wifi'
    ... other config

Then in the wireless config use option network 'wifi' as before. The APs will actually be attached to a bridge named br-wifi, which you can inspect with brctl show.

Also avoid hidden SSIDs as many clients don't work well with them.

1 Like

Thanks for your help getting things this far! I'm not even sure we're looking at the same problem anymore. I tested it with two laptops (each with a windows and ubuntu partition) and a phone so I'm not sure that we're short on environment diversity. :slight_smile: I'll see if the suggestion below about the wifi bridge helps. It looked like it might be something that might help here based on the other thread I saw, but wanted to wait until we were on that page in this thread so I wasn't just screwing around with things and messing up any/all of the progress that we made.