Unexpected difficulty flashing MT6000

Looking for advice on getting a brand new MT6000 working with OpenWrt.

Following install directions on macOS, I logged into my MT6000 over Wifi on its default SSID, logged into the OEM admin panel on 192.168.8.1, and used the firmware updater to flash with then current sysupgrade snapshot r26513-65f34e9928. The router rebooted, but I can't access any GUI from 192.168.8.1 or 192.168.1.1.

I created two new Ethernet configs, one with the router IP 192.168.8.1 and macbook to 192.168.8.2; and an alternate with router's IP to 192.168.1.1 and the macbook to 192.168.1.2. (both IPv4 manual only, subnet mask 255.255.255.0). I cannot see the admin page on either, but I'm able to ssh to the host when on 192.168.1.1 version:

$ ssh root@192.168.1.1
BusyBox v1.36.1 (2024-06-03 15:57:54 UTC) built-in shell (ash)
...[logo]...
OpenWrt SNAPSHOT, r26513-65f34e9928

Since the only next step seemed like it might apply to me ("As a reminder only stable releases include LuCI, for a snapshot SSH root@192.168.1.1 and: opkg update && opkg install luci."), I tried it, but the command failed because the router has no internet connection yet.

I have tried both soft and hard resets of the MT6000 as per https://docs.gl-inet.com/router/en/4/faq/debrick/, apparently without any effect (no GUI at either possible IP, and the OEM default WiFi SSID was not reactivated).

Should I connect the MT6000 to my working internet router so that it will have service, and try opkg update && opkg install luci with a live connection?

thanks!

snapshots images don't include Web UI.

If you have managed to log in over SSH, you may want to download the 23.05.3 image for your router, use the scp to upload the image to your router and run the sysupgrade command from CLI to update to a firmware which includes Web UI.

1 Like

At this point you haven't configured the network, so the router doesn't have an IP address for the gateway or DNS server.
What works for me is to set the necessary IP addresses for the LAN directly from the SSH command line.

uci set network.lan.ipaddr="192.168.1.11"
uci set network.lan.gateway="192.168.1.1"
uci set network.lan.dns="192.168.1.1"
uci commit
/etc/init.d/network restart

Obviously you need to change the above IP addresses to suit your LAN network.
Reconnect with the new IP address, if you changed it in the first line above. Then with the router on your LAN, you can download LuCl:

opkg update
opkg install luci
/etc/init.d/uhttpd restart

Log in with LuCl and finish adjusting the network settings.

1 Like

Thanks for the tips -- I missed that the web UI was entirely part of LuCI, but that makes complete sense given its dependencies.

Just needed internet connection. As soon as I connected the MT6000's WAN port to my live router LAN, I was able to ping 8.8.8.8 from the SSH session. I tried the opkg commands again, and 192.168.1.1 was up and running. :slightly_smiling_face:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.