Unbricking Xiaomi AX6

I have a problem with unbricking my ax6. Since I installed the QSDK before and most likely it changed my partition.

When I wanted to revert back to Xiaomi oem firmware using miwifi tool, things got ugly it goes on a bootloop.

And the worst part is that
nvram set uart_en=1 was not persistent at least on my side because I cant interrupt the booting process. My keypresses was just ignore by my router within the 5secs window time.

I tried tftp the oem firmware but the problem is still there while when i tftped the openwrt image there was an error like invalid header or something.

I want to try the initramfs but as i have said, i cant interrupt the booting process.

My question is:

  1. Is there any way to recover my ax6 without uart write?


Can you describe what happens when you try to use the miwifi repair tool?
I made a quick guide with hopefully everything you'll need.

Hello vic1707, I appreciate your time. Anyways, we have the same case here

I also have access to serial thru UART but I cant seem to interrupt the booting process and cant enter to UBOOT even I press any keys.
Is there any other way to recover my brick router?

I ran into the same problem, boot loop, UART connected but no RX access just like you : you can read the output but not write.
In that case the only solution I'm aware of is to use the TFTP method. Either you use the MiRepairTool or you manage to use dnsmasq (or an alternative depending on your OS) and flash the original firmware.
I wasn't able to do the dnsmasq method the only one that worked for me was the RepairTool...

Already tried

TFTP method and MIWIFI tool. I can confirm that it was successful as per serial console. But still it goes on bootloop after power restart.

Maybe this is the reason why:

I guess it needs a NAND flasher to recover which is beyond my capability.

beyond mines too, sorry

Hey! Were you able to recover your AX6? Please let me know as I'm also in a silmilar situation where I brushed QSDK and my router got bricked afterwards.. Help needed

I was and made a little guide OpenWRT redmi AX6 hope it can help you

Bro my case is just like @chad. Your guide is relevant but didn't help me in my case. Thus was asking from him. Anyways, thanks a lot for helping out ppl with similar problem with your post.