Unbricking Router - Strange characters

Hey all,

I'm in the process of unbricking my router. As it stands, I've hooked it up through serial cable to my computer. I'm running putty with all the appropriate settings. The only thing is, the output looks completely wrong.


my▒--!#▒▒▒▒▒▒▒▒▒▒▒▒R▒▒럣▒▒▒▒▒▒E▒#7!%▒▒9▒-#-▒7!#5▒▒H▒▒▒▒▒▒▒E▒#7!%▒▒▒▒#7!%▒=▒▒▒%-57▒75▒!▒5'-%--#1▒▒R▒▒띣▒▒▒▒▒▒E▒%▒▒A%=9▒▒▒▒▒▒▒▒▒▒%=9▒▒s-▒S5▒▒▒▒▒▒▒▒▒▒▒ ▒▒▒띣▒▒▒▒▒▒E▒%▒▒A%=9▒▒▒▒▒▒▒▒▒▒%=9▒▒{-'7▒W-%5▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒R▒▒띣▒▒▒▒▒▒E▒%▒▒A%=9▒▒▒▒▒▒▒▒▒▒▒R▒▒뛣▒▒▒▒▒▒E▒)%!7'!=75▒7!#5▒'!=7-#1▒)5'▒%!7'5▒3▒59▒%!7'5▒7▒▒▒▒R▒▒۟▒▒▒▒▒▒▒E▒;'=#▒▒!▒▒5/▒▒▒▒▒5#57▒;'!9)-#1▒=5▒▒R▒▒۟▒▒▒▒▒▒▒E▒;'=#▒▒!▒▒5/▒▒▒▒▒5#57▒7-=;'57▒=5▒▒R▒▒۟▒▒▒▒▒▒▒E▒75-95▒5/▒▒▒▒5#57▒!▒%!75▒▒▒▒▒▒▒▒▒E▒75-95▒5/▒▒5#57▒!▒%!75▒▒R▒▒۝▒▒▒▒▒▒▒▒▒R▒▒۝▒▒▒▒▒▒▒E▒m_▒▒▒}ww[yacs▒cuWwuSAyo}cqu▒▒▒;'=#▒▒'-#)▒;59!%5▒=7▒5#57▒3!-#1▒=5▒▒R▒▒۝▒▒▒▒▒▒▒E▒m_▒▒▒}ww[yacs▒cuWwuSAU_▒▒▒;'=#▒▒'-#)▒-▒#!▒=7

I've messed around with the Baud rate, ranging from 9600 all the way to 115200. But I can't seem for the life of me to figure out what's going on.

Does anyone have any ideas/recommendations/suggestion?


Which router?

Are your solder connections and wires good?

It's CR8012, some Chinese router I got sometime ago.

I like to think the solder was done relatively good. Although I haven't given much thought to the wires in honesty. Could that be a contributing factor to it?


Tried it with different wires - same thing!

Do you have the correct adapter for the serial port? Meaning, 3.3V when required (most of the time)
I second Jeff's question: are you certain the wiring is appropriate, that is RX is really where you think it is and so on and so forth.

1 Like

I'm using an Arduino Nano as the adapter. Could it be that this shouldn't be used? & Yes i'm certain in terms of the wiring, that they are in the correct order/place.

check your pinout again, even better post photos here how you connect it

1 Like

If I read the tech specs correctly, the Arduino Nano would be running at 5 volts, while your router requires 3.3 volts - you might have already permanently damaged it, by feeding 5 volts to it via the rx pins.

1 Like

Now I'm intrigued :slight_smile:

Using an arduino in place of a dumb level converter is a bit like doing the grocery run in a Ferrari: clearly
possible, but most definitely not the first choice.

Get a 3.3V serial cable or a converter and try again. Fingers crossed.


Ah, yes you're probably right. I've ordered one to be delivered today. I'll have another go then, and maybe with some luck. But we'll see

Thanks folks!


Hey guys - just wanted to update. After trying it with a proper Serial converter it worked a charm & I've finally unbricked my router. Thank you all for your help - I'm pretty chuffed!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.