Unbricking D-Link DIR-859 rev A3

After power on, router only displays a solid power LED, and activity LED for whichever switchport is connected.

No WiFi AP's are broadcast, and the router does not respond on, or

Tried powering the router off, holding the reset button, waiting 10 seconds, and powering up still holding the reset button. I've waited up to a minute to release the reset button. No response on web browser for IP address

I've opened the unit up, and soldered a header to the 3.3V TTL Serial header (JP1). Attached my USB<>TTL cable, connected with 115200 8N1.
Upon boot, I'm presented with this serial output:

U-Boot 1.1.4 (Dec 17 2014 - 10:53:14)

SVN revision: 1128
Target board: WRG-AC37

ap152 - Dragonfly 1.0DRAM:
ath_ddr_initial_config(283): (ddr2 init)
ath_sys_frequency: cpu 775 ddr 650 ahb 258
Tap values = (0x8, 0x8, 0x8, 0x8)
 4 MB
Top of RAM usable for U-Boot at: 80400000
Reserving 244k for U-Boot at: 803c0000
Reserving 192k for malloc() at: 80390000
Reserving 44 Bytes for Board Info at: 8038ffd4
Reserving 36 Bytes for Global Data at: 8038ffb0
Reserving 128k for boot params() at: 8036ffb0
Stack Pointer at: 8036ff98

No other output is displayed. No input is reflected in the terminal window, either.

Anyone have any other ideas?

I'm just grasping at straws here, decided to dump the contents of the Winbond W25Q128FVSIG chip inside.
I used binwalk to compare the contents with the firmware update file from D-Link, and they're completely different.

I was hoping I could re-flash the Winbond chip with my SPI programmer.

W25Q128FVSIG Contents:

145856        0x239C0         Certificate in DER format (x509 v3), header length: 4, sequence length: 64
158336        0x26A80         U-Boot version string, "U-Boot 1.1.4 (Dec 17 2014 - 10:53:14)"
158624        0x26BA0         CRC32 polynomial table, big endian
185440        0x2D460         HTML document header
185639        0x2D527         HTML document footer
185712        0x2D570         HTML document header
186402        0x2D822         HTML document footer
186412        0x2D82C         HTML document header
187095        0x2DAD7         HTML document footer
187452        0x2DC3C         HTML document header
187580        0x2DCBC         HTML document footer
187592        0x2DCC8         HTML document header
187632        0x2DCF0         HTML document footer
189920        0x2E5E0         HTML document header
190256        0x2E730         HTML document footer
327960        0x50118         JFFS2 filesystem, big endian
393232        0x60010         gzip compressed data, maximum compression, from Unix, last modified: 2015-05-06 10:47:28
400420        0x61C24         JFFS2 filesystem, big endian
458752        0x70000         SEAMA firmware header, big endian, meta size: 36, image size: 9416736
458816        0x70040         LZMA compressed data, properties: 0x5D, dictionary size: 33554432 bytes, uncompressed size: 3650048 bytes
1769536       0x1B0040        PackImg section delimiter tag, little endian size: 11565824 bytes; big endian size: 8105984 bytes
1769568       0x1B0060        Squashfs filesystem, little endian, version 4.0, compression:lzma, size: 8103415 bytes, 2128 inodes, blocksize: 65536 by
10186700      0x9B6FCC        Executable script, shebang: "/bin/sh"
10186830      0x9B704E        Unix path: /proc/sys/vm/drop_caches
11318239      0xACB3DF        HTML document header
11318312      0xACB428        HTML document footer
11318426      0xACB49A        HTML document header
11318515      0xACB4F3        HTML document footer
11318629      0xACB565        HTML document header
11318808      0xACB618        HTML document footer
11318884      0xACB664        HTML document header
11318971      0xACB6BB        HTML document footer
11319327      0xACB81F        XML document, version: "1.0"
11321016      0xACBEB8        Unix path: /htdocs/web/docs/config.bin
11321228      0xACBF8C        Unix path: /htdocs/web/docs/dongle_list.txt
11562488      0xB06DF8        Certificate in DER format (x509 v3), header length: 4, sequence length: 2
11870115      0xB51FA3        Copyright string: "Copyright (C) 1998-2008 Erik Andersen, Rob Landley, Denys Vlasenko"
11885123      0xB55A43        POSIX tar archive (GNU), owner user name: "dtq123456789n"

Contents of DIR859Ax_FW105b03.bin

0             0x0             DLOB firmware header, boot partition: "dev=/dev/mtdblock/1"
116           0x74            LZMA compressed data, properties: 0x5D, dictionary size: 33554432 bytes, uncompressed size: 3650048 bytes
1310836       0x140074        PackImg section delimiter tag, little endian size: 8421120 bytes; big endian size: 8355840 bytes
1310868       0x140094        Squashfs filesystem, little endian, version 4.0, compression:lzma, size: 8352125 bytes, 2151 inodes, blocksize: 65536 by, created: 2016-06-28 03:36:41

Any luck getting your DIR-859 to work.
I think I have the same problem (DIR-859 A3) running latest build of DD-WRT (01-21-2019-r38347).
It has been running, but now Wifi is shut down.
I can connect to the internet if I plug in a LAN cable, but I can't connect to the router. Nothing on or
If I run "ipconfig" I get the standardgateway:, but nothing there aswell.
Reset button doesn't work, so I can't do a hard reset.
Can you (or anybody else) help with some advice?

UPDATE: I managed to reset it. The box of the DIR-859 says the reset button and the WPS button are the same. But this is not the case for A3. The reset button is on the bottom. So I have done the reset (which didn't reset the router, but it solved my problem, which I still don't know what was).
Hope this helps somebody.

1 Like

I have same problem, any idea?