Unbricking a TP-Link C2600

I tried to set up VLANs on my C2600 Access Point. Now I can't connect to the access point anymore. My assumption is that it's address is not accessable from the VLAN I am assigned to when connecting to the access point (either wireless or via LAN).

Anyway, I would like to restore/unbrick it via TFTP but it's not clear how to do it.

First, when I look at the C2600 OpenWrt page, it is not clear to me wether the C2600 is a TFTP client or a TFTP server. I assume it's an server, but I can I determine it?

Second: When I try to follow the instructions: as stated (see below) I don't know what is meant from step 3-4 onwards. I have a Linux Mint laptop and configuered the LAN connection with an IP-address of on forehand and disabled wifi as well. Then I open a terminal window and
start tftp. Note: I have the "ArcherC2600_1.0_tp_recovery.bin" file in the /var/lib/tftpboot folder. The routers address is Which commands do I have to give?

Bootloader contains TFTP server

The basic procedure of using a tftp client to upload a new firmware to your router:

  1. Unplug the power to your router

  2. Plug the Ethernet connection from your computer (acting as tftp client) into a LAN port on your model. See your model's OpenWrt wiki devicepage for details on which port to use

  3. Start your tftp client on your computer

  4. Give it the router's address (specific to model and bootloader, see your model's wiki page)

  5. Set mode to octet/binary

  6. Tell the client to resend the file until it succeeds

  7. “put” the file

  8. Plug-in your router while having the tftp client running and constantly probing for a connection

  9. The tftp client will receive an ack from the bootloader and starts sending the firmware

Instead of reflashing via TFTP, have you tried failsafe already?


1 Like

The failsafe procedures above should get you going again, but the c2600 acts as tftp client when the reset button remains pressed while booting. As a consequence you can't really influence it beyond pushing the button, the bootloader will try to connect to a tftp server under the hardcoded IP and try to fetch the hardcoded file name - if that succeeds and the fetched factory image passes its scrutiny, it's flashed and the router restarts.

1 Like

see https://openwrt.org/toh/tp-link/tp-link_archer_c2600_v1#debricking

I'd add, disable any firewall on the PC used as the tftp server prior to following the procedure.

1 Like

Failsafe worked: thank you for your suggestion.
I am able to access the access point again via ssh, disabled the dhcp server and set the IP address, but it can't access the internet yet. But that might be a local network issue.
Thank you for your help.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.