Unbrick TP-Link Archer C7V2 with modified (stripped) firmware

Hello all,
I managed to brick my TP-Link Archer C7 v2 (EU version) (when reverting to stock from openwrt and clicked upload without unzipping the file first) and now all lights illuminate, flash, repeat.

I've tried multiple times to use the TFTP (setup at tftp server on my machine with IP address of to flash a valid image to it (tried both OpenWRT and stock).
I followed the below instruction

  • Set static IP of
  • Run TFTPD32 server with proper directory/image (renamed to ArcherC7v2_tp_recovery.bin) and network interface selected
  • Hold WPS button while powering on. It does the expected thing and illuminates WPS light/etc.

The TFTPD progress bar indicating the transfer moves to 100% (far too quickly—within 5 seconds), then the router immediately reboots and starts brick-dance-bootlooping again. Furthermore, the log does not show the extended communication that I typically see when flashing devices with TFTP.

I'm confident I'm using the correct images of stock firmware (the same images I've successfully flashed multiple times before.) From what I understand, if the router can enter the "WPS light illuminated" mode, it should be recoverable via this process. It seems unlikely I've caused irreparable damage.

I saw some posts that I require to hex edit (using a hex editor) the stock firmware (containing the word boot) header and cut out the boot.

Thanks a lot in advance!

the TFTP transfer is usually quick, and there's no additional TFTP communication afterwards.

this might be useful Online tool to convert TP-Link stock firmwares to sysupgrade-compatible images

I tried using the tool but the file returned was 0.0 kb

You could try this old "pre-stripped" firmware


I tried it, but no luck. the file is transferred but once it completes the lights keep blinking. Thanks a lot though!

there are some other threads asking for help to unbrick various Archer models: https://forum.openwrt.org/search?q=unbrick%20archer
maybe you can find some helpful hint for your case there.

It's on the old threads, the hardware and model id need to be hex-edited in the firmware flash file.

I opened a the latest stock firmware with a hexeditor, but I honestly do not have any idea where to find the HWID and edit it this is all new to me, is there a thread which could help me with the hex editor?

I tried using FF, and 00 for address from 0x40 to 0x47, and tried both bin files but still the same.


You must be have a USB to TTL and you can see log of u-boot
VCC is NOT [connected]

I did not use tplink stock to flash but a hex edited openwrt factory image.