Unable to use bss_transition

When I add the option to /etc/config/wireless, it just stays disabled forever.
I'm using a TP-Link Archer AX23 v1

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '11'
	option band '2g'
	option htmode 'HE40'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option channel '161'
	option band '5g'
	option cell_density '0'
	option htmode 'HE80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<ssid>'
	option encryption 'sae'
	option key '<password>'
	option ieee80211k '1'
	option ieee80211r '1'
	option ft_over_ds '0'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '<ssid>'
	option encryption 'sae'
	option key '<password>'
	option ieee80211r '1'
	option ieee80211k '1'
	option ft_over_ds '0'
	option network 'lan'

You need wpad-mbedtls in place if wpad-basic-mbedtls .

Helps to set 5ghz country code to get any transmissions out of it.

Still doesn't work.

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '11'
	option band '2g'
	option htmode 'HE40'
	option cell_density '0'
	option country '<redacted>'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option channel '161'
	option band '5g'
	option cell_density '0'
	option htmode 'HE80'
	option country '<redacted>'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '<redacted>'
	option encryption 'sae'
	option key '<redacted>'
	option ieee80211k '1'
	option ieee80211r '1'
	option bss_transition '1'
	option ft_over_ds '0'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid '<redacted>'
	option encryption 'sae'
	option key '<redacted>'
	option ieee80211r '1'
	option ieee80211k '1'
	option bss_transition '1'
	option ft_over_ds '0'
	option network 'lan'

Cant helpyou here. Is 80mhz channel permitted or dfs in your secret place?

What you find in `logread' while restarting 5ghz radio?

Channels aren't the problem, its using the bss_transition option that just disables everything.

It's permitted and works without bss_transition, with bss_transition, both 2.4ghz and 5ghz don't work

Anyways I found two warnings

daemon.notice netifd: radio1 (25874): WARNING: Variable 'data' does not exist or is not an array/object

WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 1340 path (/usr/sbin/wpad (deleted))

and whatever this means

daemon.err hostapd: rmdir[ctrl_interface=/var/run/hostapd]: Permission denied

Happens when you upgrade running packages, just reboot to regain control, 2 other messages are harmless.

Rebooting doesn't fix my issue though

I've figured it out. I was using wpad-mbedtls, swapping it with hostapd-wolfssl solved my issue along with making LuCI actually show the various WLAN Roaming options.

Everything works wonderfully with usteer now.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.