Unable to upgrade to 19.07.0 on Edgerouter X

Today I flashed OpenWRT 18.06.0 on my Edgerouter X by first flashing the 17.06 factory image provided here , and then I attempted to upgrade from that version to OpenWRT 19.07.0, and my router subsequently went into a boot loop. After restoring the router to factory firmware I repeated the process except instead of going straight from the opennet image to 19.07.0, I first upgraded to 18.06.0, which worked without issue. However then when I tried to upgrade to 19.07.0, the router again went into a bootloop and had to be restored to factory firmware with TFTP recovery to get it to work again. I have read a few other posts about this that were made a few months ago and I think it has to do with the 19.07.0 image being a .bin and not a .tar , which all the other images I flashed were. What is the status of being able to flash 19.07.0 without being sent into a boot loop (without plugging a cable directly into the board of the router, as I don't want to open it up and void the warranty) or if there exists a firmware for 19.07.0 which is a .tar? Thanks

The page you have linked is not connected to OpenWrt. So I don't think it is a coincidence that upgrading to OpenWrt failed after that.

They look pretty tar to me.

1 Like

Unfortunately when I tried downloading it, I got a 404 not found error, the link is broken.
Also I don't think this is related to the original image I used as that was a regular OpenWRT 17.06 image, and I was able to upgrade to 18.06 without issue

The link is outdated, if you read the installation instructions a bit below, there is no need for .tar files.

@tmomas how can we fix it?

1 Like

Unfortunately I tried to follow those instructions but it didn't work either, I got an error of
"There was an error upgrading the system.
UPGRADE request failed: Upgrade image does not support the device. Upgrade failed."

On which step did this happen?
Did you boot with the initramfs image?
Is the factory Ubiquiti image v1 or v2?

That happened on the first step, when attempting to flash the 19.07.0 factory image after executing the command "add system image openwrt-19.07.0-ramips-mt7621-ubnt-erx-initramfs-kernel", I wasn't even able to apply the intramfs image and reboot. Also it is factory Ubiquiti image v1.10

Related topic: Edgerouter X wiki points to not working .BIN and other thingies

I have updated the download links now.

Is this a typo or you didn't add the suffix .bin?

Thank you @tmomas !

My mistake, that was a typo. I wrote the suffix bin in the command but forgot to type it here.

And If I try it by flashing an older version of OpenWRT first then upgrading to 19.04, my router goes into a bootloop when attempting to upgrade to 19.07. It seems that all the firmware files other than the 19.07 files are in .tar format instead of .bin, I'm not sure if that has to do with it.

1 Like

So the router can successfully upgrade to some 18.06 version, but it is not able to upgrade from 18.06 to 19.07? (not keeping settings over upgrade)

Yes, I can upgrade up to 18.06.8 without issue, but whenever I try to flash the 19.07.0, sysupgrade or factory image (from 18.06) it sends my router into a bootloop and the only way to get out of it is to use TFTP recovery.

However when I try to flash the 19.07.0 image from EdgeOS, it doesn't even let me, it says some error about the image not being compatible with the device

1 Like

Since I don't have the device I cannot help any more, sorry.
Maybe you can ask users (with @username) who own it, for example from here.

1 Like

Thank you for your help, I will look in that thread and see if any others were able to successfully flash 19.07

1 Like

Oh yikes. I just ran into this issue as well. I was following the wiki instructions and now my device is on a boot loop.

And I just now see I need a serial cable to rescue it. Guess I'll order one.

@User1426 were you ever able to install it?

Unfortunately not, I gave up on installing 19.x and just stayed on 18.06

First install from German site....then install the correct 18.06 version

Copy it to /tmp from your pc...
Next, ssh into your router:
ssh root@

and go to the /tmp folder on your router
cd /tmp

Then execute ...
sysupgrade -n -v openwrt-18.06.7-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.tar

And wait for it to finish (several minutes). After you wait and it reboots, long in to your router.

Then just download https://downloads.openwrt.org/releases/19.07.3/targets/ramips/mt7621/openwrt-19.07.3-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin

And upgrade....
If upgrading from 18.06 to 19.07, it would be a good idea to not keep your settings.

Tell me please if you successfully install it.

1 Like

What's the German site?

Factory tar link: https://downloads.opennet-initiative.de/ubnt/edgeos/openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar

1 Like