Unable to upgrade from 21.02.5 to 22.03.3 and 22.03.2

I have a GL.inet S-1300, that I am unable to upgrade from 21.02.5 to latest versions. I tried a few times with both 23.03.3 and 23.03.2, everytime not being able to access LUCI and ending recovering via uboot. What could it be? I used 23.03.2 in the recent past for a few months and it worked fine.

Did you happen to get a copy of any errors/logs while connected - before unbricking?

no, I am not sure how to do it. I did everything through the web interface.

Uboot, in a web interface?


Did you keep the settings when you upgraded to 22.03? You should not keep the settings, rather take a backup, flash clean, then start restoring the settings manually.

Yes, see number 5 here:

hmm I kept settings, but yesterday I kept settings while upgrading another router from 23.03.2 to 23.03.3 and it went all good. It was a tlpink wdr4300v1. I will try that, the backup always work even when different versions of openWRT like 21.02.5 to 23.03.3?

When doing minor upgrades within the same major version, like 22.03.2 to 22.03.3 then you can keep the settings.
If moving from 21.02.5 to 22.03.3 then flash clean.

Thanks for the info, and also always by RJ45 when via interface? I have had problems upgrading via Wi-Fi a few times it worked.
But the strange thing is that it did no work upgrading via uboot.

There is no significant difference. However if you upgrade over wifi to a clean installation, the wifi will be disabled.

It's no wonder, uboot is the most early stage of boot. Wifi is not working then.

That I was expecting, for a few times after upgrading WiFi was disable and I set it on again via cable. But the upgrade itself went good. I will try again upgrading via LUCI by cable not keeping any settings, but not today otherwise family will kill me. Maybe monday, thanks for the support so far.

1 Like

i tried again today, without any success. First I tried via LUCI without keeping any settings, I could not access the router after neither via LUCI nor SSH. Then I tried via uboot, and nada again. The last thing I could try is upgrading via terminal, but I am not sure how to do it as described here: https://openwrt.org/toh/gl.inet/gl.inet_gl-s1300
I am not sure if it's a normal sysupgrade or mtd.
After all those trying, I was strangly able to install 21.02.5 again without any problems via u-boot

Start with sysupgrade, as it is equivalent to the luci version.

Version error in the title and the text: it's 22.03.x :wink:

My brain tricked me, I just correct it. Thanks

1 Like