Unable to Upgrade and download packages


I'm trying to install Bluetooth libraries (kmod-bluetooth, bluez-libs, bluez-utils, kmod-usb-core, kmod-usb-uhci, kmod-usb2, usbutils) in my APU2 deviece which has the Lede OPEN WRT operative system.

The thing is that I can't upgrade packages doing "opkg update" and the error is:

opkg_download: Failed to download http://downloads.lede-project.org/releases/17.01.4/packages/x86_64/openc2x/Packages.gz, wget returned 8

Then looking in openWRT webpage I've seen that the correct URL for this packages is "https://downloads.openwrt.org/releases/17.01.0/packages/x86_64/packages/Packages.gz", but if I try to install this I have the same error: "opkg_install_cmd: Cannot install package https://downloads.openwrt.org/releases/17.01.0/packages/x86_64/packages/Packages.gz".

I cannot install some packages in my APU (not only the Bluetooth packages) and I think the problem is the one that I've mentioned above.

Any help, please?



LEDE is umaintained, please upgrade to OpenWrt 19.07.4 as soon as possible, which is the current release.

Note that Packages.gz is just the "table of contents" for the package archive, not something you would install.

Installable package files have an .ipk extension, but when opkg is correctly set up, you would not normally have to deal with package files.

1 Like

You don't need to change the url to https, it works with plain http.
The usual reason for this problem is lack of nameserver or default gateway.
As mentioned already, 17.1.4 is old and unsupported, you need to upgrade to the latest 18.06.8 or 19.07.4

1 Like

Thank you for your answer!

Ok, so the first point is that I have to upgrade OpenWRT to the last version. Is it possible to that by the command line without format the mSata (disk) of my device APU2?

I've tried to download packages indicating the URL with http (instead of https) and the system is blocked with the message "Downloading http://downloads.openwrt.org/releases/17.01.0/packages/x86_64/packages/Packages.gz".

Thank you.

Wouldn't that be wget returned 4? (with 4 = Network failure)
Exit code 8 = Server issued an error response.

Wget exit codes: https://www.gnu.org/software/wget/manual/html_node/Exit-Status.html


Good point @tmomas.
It seems that the openc2x part of the url is not existent.

You can upgrade to the new image without keeping settings. Take a backup just in case, but don't use it to restore over the 19.07. Manually restore the settings.

How can I do that, I'm new in this...

You can do both in System- Backup/Flash Firmware.

1 Like
1 Like