Unable to unbrick TL-WR940N v6

Hi everyone :raised_hand:. Yesterday, I tried to restore my TP-Link TL-WR940N (EU) v6 router after installing OpenWRT following the instructions on here. The firmware installation seemed successful, but now the modem isn't working. The LED flashes blue and orange in an infinite loop. I've tried everything before deciding to disassemble it and connect it to the computer via serial.

Picture 1
Picture 2

What didn't work so far:

  1. Modem reset
  2. Booting with the reset button pressed for 5-20 seconds and connecting to the router at 192.168.0.
  3. Connecting via Ethernet cable to computer (
    LAN port 1 > ETH1 port) and firmware flash via TFTP
  4. Methods 2 + 3
  5. Connecting via Serial Port (see photo)

In any case, the router remains entirely undetected by the computer. It does not appear among the listed devices, including unknown ones, and fails to be recognized by the Ethernet port.

which image was flashed ?

tried reversing the Tx and Rx wires ?

did you also try https://openwrt.org/toh/tp-link/tl-wr940n#recovery_information ?

I flashed the official OpenWrt firmware OpenWrt 18.06.9 *Recovery and followed the guide to restore the TP-Link TL-WR940N v6 via the web interface successfully. Despite trying to swap Rx and Tx, and shorting the board's marked pins (as shown on the pictures on the support page), my computer won't recognize it.

Picture 1
Picture 2

In the video, you can see how the router turns on and flashes without anything happening.

Video 1