Unable to ssh to freshly installed snapshot on Asus RT-AC85P


I decided to install OpenWrt on my new RT-AC85P router as I wanted more customization options than what the stock firmware offers.

Unfortunately I am hitting some unexpected issues while trying to install the snapshot provided by the OpenWrt technical page on the router - https://openwrt.org/toh/hwdata/asus/asus_rt-ac85p. I went for the ssh install and all seemed fine. However once I reboot the router, I cannot connect to it with either ssh or telnet.

I have set a static ip to for my local eth0 device and connected to a wire to the router. Tried ssh root@, but it only says the connection is refused. I tried nmap and it says all 1000 ports are closed. I also tried the failsafe boot, but it didn't help. I have no idea what other logs I can take out of the machine.

I will try with tftp install and if that fails I may give up and move back to the stock firmware, but I would really prefer to have openwrt on this router.

Has anyone had experience installing OpenWRT on RT-AC85P and did you hit a similar issue? Can someone help, please.

You should not need to assign a fixed IP address, the router should issue one using DHCP, did you try that?

1 Like

That IP is only required during the installation process.

Since you have already successfully installed OpenWrt,
The ASUS/OpenWrt router is likely attempting to handout an IP address other than

If you're using a Windows system, change your computer system's TCP/IPv4 settings back to Obtain an IP address automatically so that the ASUS/OpenWrt can hand out the IP to your computer. You may need to reboot the computer since some Windows operating systems are stupid and will not apply the change without a reboot.

I use PuTTy software for SSH use so the default host name is already set to on port 22.
I just click Open, which results in the PuTTy window displaying login as:
Just type in
to start the session. e.g. opkg update

I am on armbian, a debian distribution for single board PC. I tried to remove the static IP, waiting for the dhcp to assign, but I don't get assigned an IP. Also if the router IP is it would not matter what the connecting IP would be, would it?

In the router page in openwrt it specifies that the DHCP server is not running on the LAN ports device - https://openwrt.org/toh/asus/asus_rt-ac85p#network_interfaces.

I also tried the tftp install, but it ended up with the same result.

Do you have other ideas?

I am not familiar with those so unable to assist further.

That is not what I read there... That table says (or implies) that there is a DHCP server on LAN, and a DHCP client on WAN.

If there is not a DHCP server active on LAN, I think there was something wrong with the installation. I would try some failsafe method and try to recover the device.

I see None next to LAN ports and DHCP next to WAN port. Is there a way to troubleshoot a DHCP communication or the lack of it?

I tried the failsafe method, but there is no communication on the wire at all.

I am going to give up. I tried everything I have found around documentation and guides. Thank you @eduperez and @Warlock for the help, I appreciate it.

I will be rolling back to the stock firmware and hope for better times.

1 Like


I bought this RT-AC85P and was bummed that the stock OEM FW did not have the android tethering option installed.

I was almost already going to return it but after all I decided to try openwrt.

I used "SSH method" to install the "factory" bin from latest snapshot using a windows laptop which had DHCP client configured at lan.

I did the SSH method.
Laptop got new IP address from router DHCP after all the leds stopped blinking.

And honestly, only problem after that was that I did not realize there was no GUI or luci included in the factory bin, but a little searching this wonderfull openwrt site I got all installed and android tethering is working. :slight_smile:

I could not be more happy :slight_smile:

But the point was for this reply, my laptop where I did the intial install had DHCP enabled and connected to the LAN1 port, I encountered no problems.


The one link in the wiki page points to ac65p binary:

Techdata might have correct binary:

I had to download correct binary from the snapshot folder, is it anyway possible you flashed 65p binary by mistake?

@Roisto I think I tried to connect to the router through windows as well (before flashing it back to the stock firmware), but it was the same as under Linux.

I am sure I flashed the ac85p version, as
I checked it a number of times. I also downloaded from the tech data page.

Thanks for the tips. My plan is to wait for the next release and try it out

I can reply to this topic directly from email, cool!

Here is the version I am using.

I just saw that there is a fresh snapshot. Maybe I give it a try this evening again. Wish me luck.