Unable to run OpenVPN on a TP-LINK Archer C7 v2 Router

kill-switch is measure, preventing traffic leakage lan-wan. Add DNS via interface configuration in LuCI for wan. You can also modify section of wan:

        option proto 'dhcp' 
        option peerdns '0'                     
        list dns '8.8.8.8'                     
        list dns '8.8.4.4'

You can add option to config dhcp 'lan':
list dhcp_option '6,8.8.8.8,8.8.4.4'
You can also modify DNS after establishing connection, but it is too tedious, to my mind.

1 Like

I'm sorry to bother but just to be clear :

I modify the section of wan by modifying what file?

Do I have to disable openvpn to do add this option ?

list dhcp_option '6,8.8.8.8,8.8.4.4'

Just modify wan-section, and add option to config dhcp 'lan' in /etc/config/dhcp, after that reboot router.

2 Likes
root@OpenWrt:/etc/config# vi /etc/config/dhcp
root@OpenWrt:/etc/config# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list dhcp_option '6,8.8.8.8,8.8.4.4'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option proto 'dhcp'
        option peerdns '0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:/etc/config#
root@OpenWrt:/etc/config# reboot
root@OpenWrt:/etc/config#

No, modify wan section in /etc/config/network, and you've correctly added string to config dhcp 'lan'.

2 Likes
root@OpenWrt:~# vi /etc/config/network
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdba:4e33:a2c5::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option peerdns '0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

OK, correct.

1 Like

Thank you very much @ulmwind for your help and your patience !

1 Like

Hi @b.bo,

what is the average speed you are getting from Archer C7 setup with express VPN?

Thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.