Unable to run more than 1 command from "Local Startup" input window in Luci

I am trying to run two similar commands to move processes around to different threads of my router's dual core CPU. I can confirm these commands work when entered manually via SSH and both work when used individually in the "Local Startup" field but when stacked together as shown in the picture above, only the first command works and the second does not. Am I missing something? Is there a special way to format multiple commands? Do I need any characters at the end of one command to separate it from the next?

you could try 2 things:

1 Like

So there is no special punctuation or formatting needed between commands?

I'm not sure why you would need to delay running those commands when each one runs correctly by itself.

I'll look into the WinSCP thing.

Nope, it's just a shell script. You could put logger -t testing "Hello world" messages sprinkled through and then do logread -e testing to see when they are executed...

1 Like

You can enable detailed debugging and logging like this:

sed -i -e "1i set -x -v; exec &> /tmp/rc.local" /etc/rc.local

That was it. I went back into the field and typed out the commands instead of copy pasting them and they work now. Thanks.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.