Unable to receive an upstream IPv6 address anymore

Hey fellows,

As the topic says, I'm not getting an IPv6 address anymore.
Device is a Buffalo WZR-HP-G300NH (ar71xx target) and I had IPv6 already working until it suddenly stopped working.
At that time, I was running OpenWrt 15.05.01 without changing anything when it stopped, so I called my provider. They said, IPv6 is still active on my connection, but precautionary sent me a new cable modem.
So I now have the new modem in use, which is in bridge-mode, and even did a fresh install of OpenWrt 19.07.4 but I'm still not getting an IPv6 address. Everything regarding IPv4 works without any problems.
That's the story so far.

ifstatus wan6 gives me:

{
	"up": false,
	"pending": true,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "dhcpv6",
	"device": "eth1",
	"data": {
		
	}
}

my /etc/config/network (also tried eth1 instead of @wan for wan6 ifname):

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8a:0134:4cc9::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option max_length '3'
	option enable_vlan4k '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

It seems, the device is trying, but doesn't get a response:
tcpdump ip6 -i eth1:

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
10:49:35.709490 IP6 fe80::21d:73ff:feb1:91d2 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
10:49:35.859503 IP6 fe80::21d:73ff:feb1:91d2 > ff02::16: HBH ICMP6, multicast listener report v2, 4 group record(s), length 88
10:49:36.042501 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 16
10:49:36.228353 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:49:37.300156 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:49:39.419743 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:49:40.059739 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 8
10:49:43.619638 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:49:44.060158 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 16
10:49:48.089423 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 8
10:49:52.259634 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:50:09.939762 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:50:46.440002 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:52:00.019655 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:56:09.259502 IP6 fe80::21d:73ff:feb1:91d2 > ff02::16: HBH ICMP6, multicast listener report v2, 4 group record(s), length 88
10:56:09.559534 IP6 fe80::21d:73ff:feb1:91d2 > ff02::16: HBH ICMP6, multicast listener report v2, 4 group record(s), length 88
10:56:10.124935 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 16
10:56:11.009075 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:56:12.099723 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:56:14.126202 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 8
10:56:14.126561 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:56:18.126624 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 16
10:56:18.259697 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:56:22.127044 IP6 fe80::21d:73ff:feb1:91d2 > ip6-allrouters: ICMP6, router solicitation, length 8
10:56:26.579674 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:56:42.899635 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit
10:57:15.539642 IP6 fe80::21d:73ff:feb1:91d2.546 > ff02::1:2.547: dhcp6 solicit

and ps shows odhcp6c is running:

odhcp6c -s /lib/netifd/dhcpv6.script -Ntry -P0 -t120 eth1

Is there anything else I can do to rule out any misconfiguration on my OpenWrt side before contacting my provider again? Do you need any more information, logs or config files?

Thanks in advance for any hint you can give.

Take OpenWrt out of equation and connect your computer directly to the modem then test.

1 Like

Thank you for the quick response.
I just tried your suggestion and don't get an IPv6 address either, so this seems to be a problem on the providers side.