Unable to produce image for Inteno VG50

I'm trying to produce a 17.01.4 image for Inteno VG50. There seems to be a profile for it under brcm63xx, which is good, but a successful build process isn't producing a final image; the bin/targets/brcm63xx/generic/ doesn't contain the image.

I've tried both the full build system and the specific brcm63xx Image Builder. While neither produced the image, both executed to completion successfully without any errors.

I have previously built images for ipq806x and ar71xx, but this is the first time I'm facing this behaviour. Any ideas on how to proceed are much appreciated.

If they're of any help, here are the final bits of the make output:

Creating 4.0 filesystem on /root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64/build_dir/target-mips_mips32_musl-1.1.16/linux-brcm63xx_generic/root.squashfs, block size 262144.
Pseudo file "/dev" exists in source filesystem "/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64/build_dir/target-mips_mips32_musl-1.1.16/root-brcm63xx/dev".
Ignoring, exclude it (-e/-ef) to override.
[=======================================================================================================================================================================-] 483/483 100%
Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
	compressed data, compressed metadata, compressed fragments, no xattrs
	duplicates are removed
Filesystem size 1312.61 Kbytes (1.28 Mbytes)
	32.68% of uncompressed filesystem size (4016.68 Kbytes)
Inode table size 5378 bytes (5.25 Kbytes)
	22.33% of uncompressed inode table size (24087 bytes)
Directory table size 6996 bytes (6.83 Kbytes)
	48.38% of uncompressed directory table size (14462 bytes)
Number of duplicate files found 65
Number of inodes 720
Number of files 483
Number of fragments 14
Number of symbolic links  178
Number of device nodes 1
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 58
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	root (0)
/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64/staging_dir/host/bin/opkg --offline-root /root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64/build_dir/target-mips_mips32_musl-1.1.16/root-brcm63xx --add-arch all:100 --add-arch mips_mips32:200 list-installed > /root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64/bin/targets/brcm63xx/generic/lede-17.01.4-brcm63xx-generic-device-vg50.manifest
make[3]: Leaving directory '/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64/target/linux/brcm63xx/image'
make[2]: Leaving directory '/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64'
make checksum
make[2]: Entering directory '/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64'

Calculating checksums...
make[2]: Leaving directory '/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64'
make[1]: Leaving directory '/root/openbuilder/lede-imagebuilder-17.01.4-brcm63xx-generic.Linux-x86_64'

An old topic, but has anyone built openwrt for Inteno VG50 successfully? The code has been in the source forever but I can't seem to find any builds.

VG50 is natively running IopSys which I believe is running on top of OpenWrt:

To me it seems like IopSys maybe have pushed their VG50 code to OpenWrt git, but maybe intentionally left it in such state that it does not automatically build?

I'd like to make an openvpn client from this VG50. I don't need wifi or ADSL/VDSL, just two gigabit ethernets and OpenVPN client..

Ok, I actually managed to log into the box with ssh.. As I suspected, the box is already running OpenWrt:

"OpenWrt Base: Chaos Breaker (14.07/15.05)"

I noticed that openvpn is already installed and working, so it might be that I don't need to update to "real" OpenWrt at all. What's more, when I once ran openvpn from ssh, it appeared to the GUI also! Very easy to configure through there..

Awesome, Teemu! I'm happy to hear you got it working.

Indeed, IopSys is OpenWRT and it uses a UI that is a modified version of LuCI. On initial OpenVPN use, it should run some installation script that installs the needed packages, including the OpenVPN LuCI package, which enables the option in the UI.

If you need any help with it, please don't hesitate to ask. I worked quite a bit with VG50 as it used to be given out by a local ISP here called DNA.

Ah, same DNA box here too. :slight_smile: They never asked the box back when they removed wiring and cancelled ADSL..

Yeah OpenVPN is now working as expected, perfect. :slight_smile: