Unable to obtain IP address on radio1

Model: ASUS RT-AC88U
Version: 24.10.0
[Edit]
I'm configuring this router as a "dumb" AP.

Issue:

I've configured the settings through the web gui, I'm able to reach the internet through the lan ports as well as 2.4 (radio0) but for whatever reason I can't get radio1 to work. Whenever I connect it to my phone / laptop, it says "Obtaining IP address" which then fails.

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc1:9cd6:75ee::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'extsw'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.72'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.254'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option channel '1'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt24'
        option encryption 'psk2'
        option key 'mypassword'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0'
        option band '5g'
        option channel '36'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt5'
        option encryption 'psk2'
        option key 'mypassword'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Logs

Mon Feb  3 23:30:15 2025 daemon.info hostapd: phy1-ap0: STA 12:04:4a:f1:d5:15 IEEE 802.11: associated
Mon Feb  3 23:30:15 2025 daemon.notice hostapd: phy1-ap0: AP-STA-CONNECTED 12:04:4a:f1:d5:15 auth_alg=open
Mon Feb  3 23:30:15 2025 daemon.info hostapd: phy1-ap0: STA 12:04:4a:f1:d5:15 WPA: pairwise key handshake completed (RSN)
Mon Feb  3 23:30:15 2025 daemon.notice hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED 12:04:4a:f1:d5:15
Mon Feb  3 23:30:33 2025 daemon.info hostapd: phy1-ap0: STA 12:04:4a:f1:d5:15 IEEE 802.11: disassociated
Mon Feb  3 23:30:33 2025 daemon.notice hostapd: phy1-ap0: AP-STA-DISCONNECTED 12:04:4a:f1:d5:15

Dies it work, if you configure an static IP address on the device?

Usually, this is left blank in a LAN config - as a gateway is normally on WAN.

Why is this LAN DHCP set to ignore?

It seems you disabled the DHCP server - hence you don't obtain an IP.

Sorry I did not clarify earlier, I'm setting this router as a "dumb" AP.
This is the guide I referred to.

I tested it on my laptop, I was able to connect to it but it says "No internet". I'm unable to reach other devices on my lan including the router itself.

If you connect to the other radio, it works? Please try this again to ensure that it is true. And, make sure you're actually connected to this AP. If there's another AP in the mix, disable/unplug it to make sure that this is the only one that could be used.

And what about via ethernet (connected via the AC88U)? Does that work?

Only radio1 does not have connection to the internet, radio0 works fine, and as for the lan ports, I'm able to reach the internet through it too.

Turning off WMM Mode seems to work, I can connect to radio1 and reach the internet. The speed is abysmal though, its under 20Mbps whereas the stock fw I was getting ~400.

There is nothing that I see in your config that would cause the 5g radio to behave any differently than the 2.4g one.

Does this problem happen on all client devices?

Did you try setting a static ip on a client device to see if that solves the problem? (Don’t forget to also set the gateway, DNS, and netmask)

1 Like

Yes, both my android phone and my windows laptop has the same issue. I've also set the gateway/dns but the main issue is that even if it somehow connects to it, I'm still unable to reach the gateway or other devices on the lan.

When you setup the AP, did it start from a completely default state? Did you make any changes to the config that were not specified in the guide and/or add/remove any packages?

Nope, I tried to follow exactly and I've reset the router just to be sure.

Everything looks right, unless I am just missing the mistake. Sorry, I wish I could help you solve the problem. Maybe someone else will spot it.

Sorry to say that, but this device is based on a Broadcom WiFi chipset. While it works for some use cases, it doesn't for others. I owned this device for a single day and returned it due to its bad WiFi chipset.

See also this thread with similar issues on this device.

1 Like

In that case, this is not a DHCP issue; the problem is that there is no traffic at all, between the AP and the clients.