Unable to make pppoe connection

I tried to connect the adsl cable directly on my tp-link router and I got no success.
My network looks like this:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option broadcast '192.168.1.255'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '...'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth0.835'
        option username 'my_username'
        option password 'my_pass'
        option ipv6 'auto'
        option vid '835'
        option pppd_options 'debug'

config device 'wan_dev'
        option name 'eth0.835'
        option macaddr '--:--:--:--:--:--'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5t'
        option vid '835'

config interface 'wwan'
        option proto 'dhcp'

Of course not, your WR1043ND does not have a DSL modem. Its WAN port is an ethernet port, not a modem port.

If your ISP's modem-router itself now cannot make a connection anymore either, I would reckon something's wrong on the ISP's side.

Oh! My bad.
My isp also suggested that when setting their router in bridge mode they disable the modem for internet and let it only for telephony (voip). So my device should also be a modem/router.
I thought i would be capable to use the tplink.

edit: finally I managed to speak with someone from my isp and they suggested a few bugs on their device so I asked for a replacement. I'll update when I test with the new hardware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.