Unable to login LuCI with snapshot/Upgraded Luci install


I have a D-Link DAP-2695 which was sluggish with the release factory.img FW which included LuCI, so after some advice upgraded (snapshot sysupgrade.bin) to the available snapshot version on the OpenWRT page for this particular model.

Webpage DAP2695 :- https://openwrt.org/toh/hwdata/d-link/d-link_dap-2695_a1

Snapshot link :- http://downloads.openwrt.org/snapshots/targets/ar71xx/generic/lede-ar71xx-generic-dap-2695-a1-squashfs-sysupgrade.bin

I updated from the original release factory.img (first used to install OpenWRT), then factory defaulted, cleared the keep config check box and upgraded to the snapshot.bin.

Ran opkg upgrade and opkg install luci to install Luci but now when I try to login it takes quite a while for the login page to appear and when logging in but I get invalid User/pass, if I ignore this and just enter the password again and retry login. I get this error in the browser....

/usr/lib/lua/luci/dispatcher.lua:247: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:247: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:144: in function </usr/lib/lua/luci/dispatcher.lua:143>

Which I think maybe a result of uhttpd or rpcd crash on first login?

I can login via cli fine, although connecting this way is also slower than usual for the login request to appear in console.

Tried installing ssl and also redirecting to http instead but no change.

Don't know if reverting back to D-link FW and then flashing the snapshot .img and then installing Luci will be of any benefit over going from release.img to snapshot.bin as I have done?

Can anyone help with resolving this?

Thanks for any help and guidance to get this working.

uhttpd or rpcd config files look ok?...


# Server configuration
config uhttpd main

	# HTTP listen addresses, multiple allowed
	list listen_http
	list listen_http	[::]:80

	# HTTPS listen addresses, multiple allowed
	list listen_https
	list listen_https	[::]:443

	# Redirect HTTP requests to HTTPS if possible
	option redirect_https	0

	# Server document root
	option home		/www

	# Reject requests from RFC1918 IP addresses
	# directed to the servers public IP(s).
	# This is a DNS rebinding countermeasure.
	option rfc1918_filter 1

	# Maximum number of concurrent requests.
	# If this number is exceeded, further requests are
	# queued until the number of running requests drops
	# below the limit again.
	option max_requests 1

	# Maximum number of concurrent connections.
	# If this number is exceeded, further TCP connection
	# attempts are queued until the number of active
	# connections drops below the limit again.
	option max_connections 100

	# Certificate and private key for HTTPS.
	# If no listen_https addresses are given,
	# the key options are ignored.
	option cert		/etc/uhttpd.crt
	option key		/etc/uhttpd.key

	# CGI url prefix, will be searched in docroot.
	# Default is /cgi-bin
	option cgi_prefix	/cgi-bin

	# List of extension->interpreter mappings.
	# Files with an associated interpreter can
	# be called outside of the CGI prefix and do
	# not need to be executable.
#	list interpreter	".php=/usr/bin/php-cgi"
#	list interpreter	".cgi=/usr/bin/perl"

	# List of prefix->Lua handler mappings.
	# Any request to an URL beneath the prefix
	# will be dispatched to the associated Lua
	# handler script. Lua support is disabled when
	# no handler mappings are specified. Lua prefix
	# matches have precedence over the CGI prefix.
	list lua_prefix		"/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua"

	# Specify the ubus-rpc prefix and socket path.
#	option ubus_prefix	/ubus
#	option ubus_socket	/var/run/ubus.sock

	# CGI/Lua timeout, if the called script does not
	# write data within the given amount of seconds,
	# the server will terminate the request with
	# 504 Gateway Timeout response.
	option script_timeout	60

	# Network timeout, if the current connection is
	# blocked for the specified amount of seconds,
	# the server will terminate the associated
	# request process.
	option network_timeout	30

	# HTTP Keep-Alive, specifies the timeout for persistent
	# HTTP/1.1 connections. Setting this to 0 will disable
	# persistent HTTP connections.
	option http_keepalive	20

	# TCP Keep-Alive, send periodic keep-alive probes
	# over established connections to detect dead peers.
	# The value is given in seconds to specify the
	# interval between subsequent probes.
	# Setting this to 0 will disable TCP keep-alive.
	option tcp_keepalive	1

	# Basic auth realm, defaults to local hostname
#	option realm	OpenWrt

	# Configuration file in busybox httpd format
#	option config	/etc/httpd.conf

	# Do not follow symlinks that point outside of the
	# home directory.
#	option no_symlinks	0

	# Do not produce directory listings but send 403
	# instead if a client requests an url pointing to
	# a directory without any index file.
#	option no_dirlists	0

	# Do not authenticate any ubus-rpc requests against
	# the ubus session/access procedure.
	# This is dangerous and should be always left off
	# except for development and debug purposes!
#	option no_ubusauth	0

	# For this instance of uhttpd use the listed httpauth
	# sections to require Basic auth to the specified
	# resources.
#	list httpauth prefix_user

# Defaults for automatic certificate and key generation
config cert defaults

	# Validity time
	option days		730

	# RSA key size
	option bits		2048

	# Location
	option country		ZZ
	option state		Somewhere
	option location		Unknown

	# Common name
	option commonname	'OpenWrt'

# config httpauth prefix_user
#	option prefix /protected/url/path
#	option username user
#	option password 'plaintext_or_md5_or_$p$user_for_system_user'


config rpcd
	option socket /var/run/ubus.sock
	option timeout 30

config login
	option username 'root'
	option password '$p$root'
	list read '*'
	list write '*'

It seems you have installed a bad snapshot - while there was a build issue. This has been resolved in the last 24 hours or so.

Install a new snapshot and try again.

1 Like

Re-downloaded snapshot again, flashed, installed luci, ssl - still get invalid username/pass :confused:

With a fresh install - and not saving defaults?

There is no password on an initial install of OpenWrt.

No access to LuCI gui, defaulted using 30sec reset button on AP, then copied newly downloaded snapshot to /tmp/ and ran 'sysupgrade -v -n /tmp/*.bin' (variable -n added to not preserve config).

Tried to login with no password (default state) - invalid user pass

Created password, cli - passwd

Tried to login with new password - invalid user pass

Browsers cache cleared beforehand.

Login via CLI - ok

  • Do a firstboot && reboot after it boots up from a fresh flash
  • Install LuCI first - then set the password


Just realised I have a different snapshot version compared to the thread you linked to - which states...

When I log in via CLI I get...

OpenWrt SNAPSHOT, r10250-016d1eb

Edit: Trying your suggestion now, Thanks.

Your snapshot was made on Thursday, 13 Jun 2019. You're definitely flashing an older version. Make sure you've downloaded the current snapshot, as an old download will not work to fix your issue.


Edit: Latest snapshot for my hardware looks to have not been updated yet, latest release shows - Mon Jun 17 14:17:55 2019 :frowning:


ar71xx is abandoned.

Those routers have been converted for ath79 instead.
See https://downloads.openwrt.org/snapshots/targets/ath79/generic/

But looks like nobody has yet imported your router to ath79...

For the the old ar71xx, the newest and final snapshot is from June 17th: https://downloads.openwrt.org/snapshots/targets/ar71xx/generic/openwrt-ar71xx-generic-dap-2695-a1-squashfs-sysupgrade.bin

1 Like

Anyway to get login working with the 17th June snapshot available for my AP or am I stuck?

What did you have before the snapshot? Did you have issues with 18.06.02?

same issue TP-Link WBS510 v1.20 6/27/2019


Only used release and then snapshot provided in the first link I posted in post #1.

Release FW with Luci pre-installed works and I can login fine.

Snapshot FW with updated Luci - cannot login ( can restore config and have a working system but with no web access to settings Luci/gui)

Other way to resolve this I suppose would be to try an older version of Luci but I don’t know what to download eg. Luci and the required dependency packages, if someone could possibly help with the required list of files to install?


OK if the latest snapshot available for your device has issues, any reason you don't want to install release 18.06.02? Did you have any problems with it?

No, you shouldn't do that.

1 Like

only problem i have its the dbm power it refuses to go above 13 dbm and the decive is rated for 27 dbm and i can tell you the data rate is very bad at 13bdm no matter which country cannt go above it only works with 17.06.1. Openwrt and Lede merger was a waste of time

I found it was really sluggish in the GUI and the 5ghz led had not been addressed - eg didn't work, that's what I found so far, didn't use the release for very long, a week tops.

The available and last snapshot FW seems to work ok on it's own (no LuCI) after I uploaded a save config file I made with the release FW, my custom wireless ssid's and Vlan passthrough all work, can connect fine etc.. inc 5ghz led works, just that Luci does not, which is installed with the latest version of luci, eg. opkg update, opkg install luci.

Why, the latest snapshot version for my device is a few builds behind the main snapshot for other devices that have been already ported, logically if I install an older version of luci - maybe likely to have/find a prior luci version that works/worked with my last snapshot version - SNAPSHOT, r10250-016d1eb?


Thanks for the info, not done any tests regards data transfer.

Looks like I maybe going back to official D-Link FW, shame as I like the way Luci works.

EDIT: The missus (on the 5ghz wifi connection) says the internet has been rubbish, video's buffering, so looks like I have issues with the snapshot, doesn't help I can't get in via the gui and see the settings :confused:

is there any way THEY cold fix this power issue on the update to Its working very well on 17.06.1 please fix dbm issue on WBS 510 Tp Link. i also have TP-Link WBS210 v1.20 but i see no build for it on ath79/

You should have the packages installed of the same build as the firmware. I don't know what changed between the builds.

Edit: this is typically required for kernel modules, so shouldn't be an issue for LuCI, but given the issues that were with the builds recently, I wouldn't like to play with it.

Or you could wait and see if 19.07 will solve your problems.

You can check whatever you want from SSH.

1 Like