Unable to Install rtl8152 dependencies

Hi all,

I am trying to manually install rtl8152 related packages in order for networking to work on the TP-Link TL-UE300 USB 3.0 to Gigabit Ethernet Network Adapter attached to my Raspberry Pi 2 flashed with 21.02.3 unfortunately opkg failed with the following errors:

# opkg install kmod-usb-net_5.4.188-1_arm_cortex-a7_neon-vfpv4.ipk
Unknown package 'kmod-usb-net'.
Collected errors:
* pkg_hash_check_unresolved: cannot find dependency kmod-mii for kmod-usb-net
* pkg_hash_fetch_best_installation_candidate: Packages for kmod-usb-net found, but incompatible with the architectures configured
* opkg_install_cmd: Cannot install package kmod-usb-net.

Tried the same on 22.03.0-rc1 using the kmod packages for the said release/architecture but to no avail. Is there a way to customize the build to include the kmod-usb-net-rtl8152 package for either 21.02.3 or 22.03.0-rc1 so that internet works out of the box? Either release are not available on both https://asu.aparcar.org and https://chef.libremesh.org.


Did you first install https://downloads.openwrt.org/releases/21.02.3/targets/bcm27xx/bcm2709/kmods/5.4.188-1-3073283f5202f81e41af122de236d697/kmod-mii_5.4.188-1_arm_cortex-a7_neon-vfpv4.ipk ?

And is it a 32-bit or 64-bit image? Firmware Selector might suggest bcm2709 or bcm2710 targets depending on your bit choice.

Thanks for the prompt response @dave14305, yes I did download and tried to install the bcm2709 kmods but it failed as mentioned. The below are the packages I am trying to install and as you can see they are all for bcm2709 architecture.


What’s the output of these 2 commands?

ubus call system board
opkg print-architecture

# ubus call system board
"kernel": "5.4.188",
"hostname": "OpenWrt",
"system": "ARMv7 Processor rev 5 (v7l)",
"model": "Raspberry Pi 2 Model B Rev 1.1",
"board_name": "raspberrypi,2-model-b",
"release": {
"distribution": "OpenWrt",
"version": "21.02.3",
"revision": "r16554-1d4dea6d4f",
"target": "bcm27xx/bcm2709",
"description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"

# opkg print-architecture

arch all 1
arch noarch 1
arch arm_cortex-a7_neon-vfpv4 10

This is now resolved, I failed to look at the package dependency error message thoroughly, it was right there in front of me all this time, the correct order of installation should be as follows:

  1. opkg install kmod-mii_5.4.188-1_arm_cortex-a7_neon-vfpv4.ipk
    Installing kmod-mii (5.4.188-1) to root...
    Configuring kmod-mii.

  2. opkg install kmod-usb-net_5.4.188-1_arm_cortex-a7_neon-vfpv4.ipk
    Installing kmod-usb-net (5.4.188-1) to root...
    Configuring kmod-usb-net.

  3. opkg install kmod-usb-net-rtl8152_5.4.188-1_arm_cortex-a7_neon-vfpv4.ipk
    Installing kmod-usb-net-rtl8152 (5.4.188-1) to root...
    Configuring kmod-usb-net-rtl8152.

The TP-Link TL-UE300 USB 3.0 Gigabit Ethernet Network Adapter is now detected as eth1.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.