Unable to install packages with persistant kmods

I am new to openwrt, and am using snapshot builds for my dynalink WRX36. I am trying to install some kmods, for example kmod-fs-nfs, and get the kernel dependency error, so I found out about persistant kmods, and set this up, and now have 'src/gz openwrt_kmods https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec' in /etc/opkg/distfeeds.conf, but when I do something like 'opkg install kmod-dax' I still get same error. What am I missing?

root@OpenWrt:~# uname -a
Linux OpenWrt 6.1.42 #0 SMP Sat Aug  5 16:42:45 2023 aarch64 GNU/Linux

root@OpenWrt:~# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/packages
src/gz openwrt_base https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base
src/gz openwrt_luci https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci
src/gz openwrt_packages https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages
src/gz openwrt_routing https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing
src/gz openwrt_telephony https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony
src/gz openwrt_kmods https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec

root@OpenWrt:~# opkg install kmod-fs-nfs
Installing kmod-fs-nfs (6.1.42-1) to root...
Downloading https://downloads.openwrt.org/snapshots/targets/qualcommax/ipq807x/kmods/6.1.42-1-41909366fefc9edca8d69d06051b4aec/kmod-fs-nfs_6.1.42-1_aarch64_cortex-a53.ipk
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 6.1.45-1-41909366fefc9edca8d69d06051b4aec) for kmod-fs-nfs
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-nfs:
 *      kernel (= 6.1.45-1-41909366fefc9edca8d69d06051b4aec)
 * opkg_install_cmd: Cannot install package kmod-fs-nfs.

You're running a snapshot - it changes daily:

  • Use a release version (or the current release candidate) instead
  • Simply install all packages needed immediately upon installation of the firmware
  • Use the Firmware Selector to include the packages you desire into the image
1 Like

But isn't that what the persistent kmods were supposed to work around? Having to install the same day? Persistent kmods for snapshots

Perhaps so, but I don't think it solves installing on a different Kernel.

Having the 6.1.45 there is curious, as your uname say 6.1.42 and the kmods download points to 6.1.42.

Pure guess, but having "core" first may lead to finding the kmod there first.
(kmod-fs-nfs_6.1.45-1_aarch64_cortex-a53.ipk 83.3 KB Sun Aug 13 12:59:56 2023)

You might try placing the kmods line first, so that the persistent file would hopefully be found first.

Alternative, more sure, approach is to manually download the correct kmod .ipk file with wget to /tmp and then use opkg to install it.
opkg install /tmp/kmod-fs-nfs_6.1.42-1_aarch64_cortex-a53.ipk

1 Like

opkg isn't very smart in doing dependency resolution for you (even less when it comes to multiple versions of the same package, multiple ABI versions, etc.), but it's small - and that's what counts on hardware like this.

Beyond that, snapshot kernel modules are only retained for a limited amount of time anyways, so just make sure to get everything in on day one - or sysupgrade when you need more (imagebuilder, asu and friends can also help).

1 Like

Yes, they were supposed to solve that. Opkg however turned out to be unable to use them and lack of time and resources prevented a fix for this since then.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.