Unable to install OpenWrt on D-Link DIR-2660 A2

I am out of ideas of how to install any version of openwrt on my DIR-2660 A2 router
I've downloaded factory sysupgrade images and checked header and CRC details. (Should header have A1 in it?)
I've tried windows / private session firefox recovery interface on and session times out.
I've tried ubuntu cURL and get ' Done waiting for 100-continue' message.
My D-link box states it's A2 but I have downloaded it to version A1 1.04 and A1 1.01.
Does anyone have a sysupgrade.bin solution to this?
I've noticed that the headers of D-Link's firmware files have no obvious model details and are bigger than 9F bytes in size.
Someone please help!

There is only A1 page on OpenWRT site. It looks like your device is not supported.


first install on most D-Link devices works with

  • only factory image works
  • only via D-Link emergency room boot sequence

there were reports about several dir-2660 variants, I once tried to summarize them in a post: D-Link DIR-2660 rev A1 Not Working After Successful Upgrade - #8 by Pico

My impression was that all 3 of the 2660 variants are supported with recent 22 releases?

Edit: Oh, but wait, there is more ;-), almost forgot, on top of it, you may have hit an unrelated issue: many D-Link devices with emergency room boot option have an incorrect http-100 implementation in the emergency room. Several http clients fail on that, as the client sends rfc-conform http-100, but the emergency room mini server does not respond properly, I think it might stall the client then.
I think trying different browsers, not on Linux, but on Windows (Chrome? Firefox?) or disabling 100 in the client was a viable workaround.

1 Like

If I assume that the latest A1 version of openwrt factory bin file is correct then it is a 'simple' matter of how to upload it to the D-Link box.
My latest curl command is...

curl --http1.1 -H Expect: -v -i -F "firmware=@curl.bin"

(curl.bin is just a renamed "openwrt-22.03.2-ramips-mt7621-dlink_dir-2660-a1-squashfs-factory.bin")
I have tried without the http1.1 and Expect switches.

Recovery screen install in firefox (in private window), Microsoft Edge and Midori browser. All lose connection after about 30 seconds and I have to restart the d-link box.
The d-link box has a P/N ending in A2E. - The E could be for Europe?

Below is the response when I try to use cURL to D-Link DIR 2660 A2

$ curl --http1.1 -H Expect: -v -i -F "firmware=@curl.bin"
*   Trying
* Connected to ( port 80 (#0)
> POST / HTTP/1.1
> Host:
> User-Agent: curl/7.81.0
> Accept: */*
> Content-Length: 9175244
> Content-Type: multipart/form-data; boundary=------------------------88e4eb4aa624c720
* We are completely uploaded and fine
* Mark bundle as not supporting multiuse
* HTTP 1.0, assume close after body
< HTTP/1.0 200 OK
HTTP/1.0 200 OK
< Content-type: text/html
Content-type: text/html

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><style type='text/css'>.warning{margin:50px 0;color:red;font-size:22px}</style></head><script type="text/javascript">var percent=1;var Timer;function uiOnload(){Timer=setTimeout("upStatus()",2200);}window.onload = uiOnload;function upStatus(){percent++;if(percent > 100){clearTimeout(Timer);document.getElementById('wait').style.display = 'none';document.getElementById('result').style.display = '';return;	}document.getElementById('time').innerHTML = 'Device is upgrading the firmware...' + percent + '%';	Timer = setTimeout('upStatus()',2200);}window.onload = uiOnload;</script><body><center><div><center style='margin:50px 0;color:blue;font-size:24px'>D-Link Router Recovery Mode</center></div><div id=wait><center style='margin:50px 0;font-size:15px'><span id=time>Device is upgrading the firmware... 1%</span></center></div><div id=result style=disp* Closing connection 0
lay:none><center class=warning><span>Upgrade successfully!</span></center></div><hr/><div><center class=warning>WARNING!!</center></div></center><ul><li style='margin:50px 0 10px;font-size:14px'>Do not interrupt the update process,as it may demage the device</li></ul><hr/></body></html>timius@timius-X570:~$

find a windows computer i recommend firefox & no firefox on linux won't work
not even virtually

Best advice I have ever seen.

Hi, I have multiple DIR-2660 ending with A2E. Recently updated them to stable 22.03.2. Had no problems uploading full recovery firmware with the dlink emergency interface, using private firefox window or chrome on windows.

Can do a test/ troubleshooting with a browser/curl/wget from linux if needed.

Hurrah! Success!
Windows 10 on an old laptop with all AV and monitoring SW disabled
Laptop set to with only a direct connection to the D-link box.
Firefox, in private window, to get to recovery screen of D-link.
No other cables plugged in D-link
22.3.2 factory install

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.