Unable to install on TPLink Archer C1200 v1

I have been trying to install OpenWRT on Malaysian Unifi Archer C1200 v1 using OpenWRT. It did not work when I use Firmware Upgrade feature of the stock firmware, it gives me "Unable to Upgrade" error. However I managed to upgrade it to EU and US version but even installing from the EU and US version won't work. I also tried to install old LEDE version but nothing seems to work.

I managed to install 1.1.0 Build 20170413 rel.56876 (US) and 1.1.3 Build 20180502 rel.46288_2018-05-02_13.47.59 (EU).

The one still fails is openwrt-18.06.4-ar71xx-generic-archer-c5-v1-squashfs-factory.bin

Please help.

1 Like

Have you tried this?

Note: The Archer C7 V2.0's web interface does not accept the image .bin file unless you rename it to something with less dots; like openwrt.bin

I know it is for v2, but maybe it started affecting v1 too.

Are we talking about this device?

Yes I have shortened the firmware name but the same error. I even tried using the V2 firmware with name shortened also the same error

@tmomas yes I believe that is the device. It matches the specs and has 3 external antennas.

Model Archer C1200

Like I mentioned above, I tried both firmwares for V1 and V2 but none worked so far. I do not know how else to do it.

Your suggestion is appreciated. Thanks.

This does not fit.

Archer C1200 v1 = Broadcom = unsupported
Archer C5 v1 = Qualcomm Atheros = supported

Please mind that Archer C1200 != C5 AC1200, those are completely different devices.

Based on further research, I think you are right. Is there any effort currently to support this model?

@zorrox, welcome to the community!

Not likely unless you begin yourself. This link will provide you more information: https://openwrt.org/meta/infobox/broadcom_wifi

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.