Unable to install latest firmware on WE1326-BKC

I've got a recently delivered WE1326-BKC device that refuses to work with either the latest release (openwrt-19.07.3-ramips-mt7621-zbt-we1326-squashfs-sysupgrade) or the nightly (?) build - none of the GO versions I've tried (2019-03 and 2020-03) work either. I've tried flashing the firmware from the chinese bootloader thing and upgrading the firmware from ZBT supplied 14.04 (Barrier Breaker) version that is currently the only firmware I've gotten the modem to boot up with.

The device came originally with the ZBT's own Z-OS or whatnot instead of the OpenWRT they were using before.

My router does have 512M of RAM despite being BKC model (says BKC on the modem sticker) and I have tried both the WE1326 and WE1326v5 (for 256M) firmware versions.

After flashing any of the abovementioned firmwares the system seems to get into a boot loop based on the indicator lights - it never boots up as much as to answer to a ping.

The modem is equipped with the Quectel EC25 LTE chip.

Any suggestions are welcome!

I did manage to upgrade into the WifiX version of GoldenOrb ( https://ltehacks.com/viewtopic.php?t=92 ).

@Kanimies were you eventually able to figure out the issue with the latest openwrt stable release?

No, I'm still running GoldenOrb_2020-05-16 as I haven't found the time nor the adventurism to have another go on upgrading. It would be sorely needed though as the current version I'm running fails miserably on recovering from failover to LTE - there's something wrong with the way it manages the routes and renews IP for the WAN port as I get driven into situations where WAN goes offline and LTE failover sometimes works but some routes still direct to the now dead WAN and become unusable - and recovering needs manual restart of the wan interface.

Would be great if OpenWRT continued to support this device. Do you know when I can get the original Z-OS firmware from ZBT?

You could try emailing them at zbt04@zbt-china.com - they've been quite responsive and did send me a firmware update of theirs once for an earlier unit, but that was of the Barrier Breaker era and not Z-OS.