Unable to get Wireguard attempted connection

I've been scratching my head at this trying to figure it out for a while but can't see what I'm doing wrong.

I"m trying to setup a wireguard connection on VLAN30 of my network but I'm unable to get a connection from my client.

Here is what I have for my configs:

root@homelab-network:~# uci show network; uci show wireless; \ uci show firewall; uci show dhcp; \ ip -
4 addr ; ip -4 ro ; ip -4 ru; \ iptables-save; head -n -0 /etc/config/firewall;
network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd54:d324:dfaa::/48'
network.vlan10=interface
network.vlan10.proto='static'
network.vlan10.ipaddr='192.168.10.1'
network.vlan10.netmask='255.255.255.0'
network.vlan10.device='eth0.10'
network.wan=interface
network.wan.proto='dhcp'
network.wan.device='eth1'
network.vlan20=interface
network.vlan20.proto='static'
network.vlan20.ipaddr='192.168.20.1'
network.vlan20.netmask='255.255.255.0'
network.vlan20.device='eth0.20'
network.vlan30=interface
network.vlan30.proto='static'
network.vlan30.ipaddr='192.168.30.1'
network.vlan30.netmask='255.255.255.0'
network.vlan30.device='eth0.30'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@rule[0]=rule
network.@rule[0].in='vlan10'
network.@rule[0].lookup='100'
network.@rule[1]=rule
network.@rule[1].in='vlan30'
network.@rule[1].lookup='100'
network.@route[0]=route
network.@route[0].interface='wan'
network.@route[0].target='0.0.0.0'
network.@route[0].netmask='0.0.0.0'
network.@route[0].metric='200'
network.@route[0].table='100'
network.@route[0].gateway='192.168.12.1'
network.@route[1]=route
network.@route[1].interface='vlan10'
network.@route[1].target='192.168.10.0'
network.@route[1].netmask='255.255.255.0'
network.@route[1].table='100'
network.@route[2]=route
network.@route[2].interface='vlan30'
network.@route[2].target='192.168.30.0'
network.@route[2].netmask='255.255.255.0'
network.@route[2].table='100'
network.@route[3]=route
network.@route[3].interface='vlan20'
network.@route[3].target='192.168.20.0'
network.@route[3].netmask='255.255.255.0'
network.@route[3].table='100'
network.@wireguard_wgclient[0]=wireguard_wgclient
network.@wireguard_wgclient[0].public_key='o5aQZ6yjw5CeyLsn94LQ8DTn9nIn3TaFxIgEcAP0w1k='
network.@wireguard_wgclient[0].endpoint_host='removed'
network.@wireguard_wgclient[0].endpoint_port='51820'
network.@wireguard_wgclient[0].persistent_keepalive='25'
network.@wireguard_wgclient[0].route_allowed_ips='1'
network.@wireguard_wgclient[0].allowed_ips='0.0.0.0/0'
network.vpn=interface
network.vpn.proto='wireguard'
network.vpn.private_key='yJN/yG5ZHojFgFoO8AEOzSMgFYzvxvuNhpeZLcYl9Fs='
network.vpn.listen_port='51820'
network.vpn.addresses='192.168.40.1/24'
network.@wireguard_vpn[0]=wireguard_vpn
network.@wireguard_vpn[0].description='macbook-pro'
network.@wireguard_vpn[0].public_key='key'
network.@wireguard_vpn[0].private_key='key'
network.@wireguard_vpn[0].preshared_key=‘key’
network.@wireguard_vpn[0].allowed_ips='0.0.0.0/0'
network.@wireguard_vpn[0].route_allowed_ips='1'
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.path='platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
wireless.radio0.channel='36'
wireless.radio0.band='5g'
wireless.radio0.htmode='VHT80'
wireless.radio0.disabled='1'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='OpenWrt'
wireless.default_radio0.encryption='none'
-ash:  uci: not found
dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_protection='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].cachesize='1000'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].resolvfile='/tmp/resolv.conf.d/resolv.conf.auto'
dhcp.@dnsmasq[0].localservice='1'
dhcp.@dnsmasq[0].ednspacket_max='1232'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.start='2'
dhcp.lan.limit='50'
dhcp.lan.leasetime='48h'
dhcp.lan.dhcpv4='server'
dhcp.lan.dhcpv6='server'
dhcp.lan.ra='server'
dhcp.lan.ra_flags='managed-config' 'other-config'
dhcp.lan.force='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'
dhcp.vlan20=dhcp
dhcp.vlan20.interface='vlan20'
dhcp.vlan20.start='100'
dhcp.vlan20.limit='50'
dhcp.vlan20.leasetime='72h'
dhcp.vlan20.force='1'
dhcp.vlan30=dhcp
dhcp.vlan30.interface='vlan30'
dhcp.vlan30.start='100'
dhcp.vlan30.limit='50'
dhcp.vlan30.leasetime='72h'
dhcp.vlan30.force='1'
dhcp.vlan10=dhcp
dhcp.vlan10.interface='vlan10'
dhcp.vlan10.start='100'
dhcp.vlan10.limit='50'
dhcp.vlan10.leasetime='72h'
dhcp.vlan10.force='1'
dhcp.@host[0]=host
dhcp.@host[0].name='HoopNAS-VLAN10'
dhcp.@host[0].ip='192.168.10.121'
dhcp.@host[0].mac='30:E1:71:6F:1A:9C'
dhcp.@host[1]=host
dhcp.@host[1].name='HoopNAS-VLAN20'
dhcp.@host[1].ip='192.168.20.122'
dhcp.@host[1].mac='30:E1:71:6F:1A:9D'
dhcp.@host[2]=host
dhcp.@host[2].name='HoopNAS-iLO'
dhcp.@host[2].ip='192.168.30.124'
dhcp.@host[2].mac='30:E1:71:6A:54:8E'
dhcp.@host[3]=host
dhcp.@host[3].name='win10-vm'
dhcp.@host[3].ip='192.168.20.126'
dhcp.@host[3].mac='52:54:00:B1:4D:B8'
dhcp.@host[4]=host
dhcp.@host[4].name='octoprint'
dhcp.@host[4].ip='192.168.30.129'
dhcp.@host[4].mac='D8:3A:DD:58:60:34'
dhcp.@boot[0]=boot
dhcp.@boot[0].filename='ipxe.efi'
dhcp.@boot[0].servername='pxeboot-fog'
dhcp.@boot[0].serveraddress='192.168.30.10'
dhcp.@boot[0].force='1'
-ash:  ip: not found
default via removed dev eth1  src removed
removed/22 dev eth1 scope link  src removed
192.168.10.0/24 dev eth0.10 scope link  src 192.168.10.1 
192.168.20.0/24 dev eth0.20 scope link  src 192.168.20.1 
192.168.30.0/24 dev eth0.30 scope link  src 192.168.30.1 
192.168.40.0/24 dev vpn scope link  src 192.168.40.1 
0:      from all lookup local 
1:      from all iif eth0.10 lookup 100 
2:      from all iif eth0.30 lookup 100 
32766:  from all lookup main 
32767:  from all lookup default 
-ash:  iptables-save: not found

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'vlan10'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        list network 'vlan10'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'vlan10'
        option dest 'wan'

config forwarding
        option src 'vlan30'
        option dest 'vlan10'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'vlan10'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'vlan10'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Block_VLAN_10_to_CG-NAT'
        option src 'vlan10'
        option dest 'wan'
        option dest_ip '192.168.12.0/24'
        option target 'REJECT'

config zone
        option name 'vlan20'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        list network 'vlan20'

config rule
        option name 'Block-192.168.20.15'
        option src 'vlan20'
        option src_ip '192.168.20.15'
        option target 'REJECT'

config forwarding
        option src 'vlan30'
        option dest 'vlan20'

config zone
        option name 'vlan30'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'vlan30'
        list network 'vpn'

config forwarding
        option src 'vlan30'
        option dest 'wan'

config zone
        option name 'extfirewall'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'

config forwarding
        option src 'vlan20'
        option dest 'extfirewall'

config redirect
        option target 'DNAT'
        option name 'plex'
        option src 'extfirewall'
        option src_dport '32400'
        option dest_ip '192.168.20.2'
        option dest_port '32400'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'dev-vm-01-ssh'
        option src 'extfirewall'
        option src_dport '22010'
        option dest_ip '192.168.20.10'
        option dest_port '22010'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'nginx-proxy-ssh'
        option src 'extfirewall'
        option src_dport '22015'
        option dest_ip '192.168.20.15'
        option dest_port '22015'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-panel-ssh'
        option src 'extfirewall'
        option src_dport '22020'
        option dest_ip '192.168.20.20'
        option dest_port '22020'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'nginx-proxy-https'
        option src 'extfirewall'
        option src_dport '443'
        option dest_ip '192.168.20.3'
        option dest_port '443'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-ssh'
        option src 'extfirewall'
        option src_dport '22021'
        option dest_ip '192.168.20.21'
        option dest_port '22021'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-mc-java'
        option src 'extfirewall'
        option src_dport '25565-25575'
        option dest_ip '192.168.20.21'
        option dest_port '25565-25575'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-mc-bedrock'
        option src 'extfirewall'
        option src_dport '19132'
        option dest_ip '192.168.20.21'
        option dest_port '19132'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-mc-map'
        option src 'extfirewall'
        option src_dport '8123'
        option dest_ip '192.168.20.21'
        option dest_port '8123'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-beammp'
        option src 'extfirewall'
        option src_dport '30814'
        option dest_ip '192.168.20.21'
        option dest_port '30814'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-daemon'
        option src 'extfirewall'
        option src_dport '8443'
        option dest_ip '192.168.20.21'
        option dest_port '8443'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'pterodactyl-wings-sftp'
        option src 'extfirewall'
        option src_dport '2022'
        option dest_ip '192.168.20.21'
        option dest_port '2022'
        option dest 'vlan20'

config redirect
        option target 'DNAT'
        option name 'nginx-proxy-http'
        option src 'extfirewall'
        option src_dport '80'
        option dest_ip '192.168.20.3'
        option dest_port '80'
        option dest 'vlan20'

config forwarding
        option src 'vlan20'
        option dest 'wan'

config redirect
        option dest 'vlan30'
        option target 'DNAT'
        option name 'wireguard'
        option src 'extfirewall'
        option src_dport '51820'
        option dest_ip '192.168.30.3'
        option dest_port '51820'

config redirect
        option dest 'vlan20'
        option target 'DNAT'
        option name 'guac-ssh'
        option src 'extfirewall'
        option src_dport '22030'
        option dest_ip '192.168.20.30'
        option dest_port '22030'

When I try to connect on the client it says activated but no data is being sent, wg show has no activity and no handshake request

Looking for any advice in my config that would be causing an issue. I've tried multiple reboots after changing settings, still getting nothing. Thanks in advance!