Unable to get opkg list update after sysupgrade (ipv6 connectivity)

I did a sysupgrade to latest stable generic from a community version with a few extra packages installed and keeping settings.

It is all working as it should, I think, excepty that I get an error when trying to update software list.

Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

This applies for all it seems , I just copied a few lines to show. And it applies from luci interface and from the cli vconfigurationia ssh.

Following advice found on this site, I tried to ping the download site from the CLI without issue.

The distribution feeds are:

src/gz openwrt_core http://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/packages
src/gz openwrt_base http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/18.06.1/packages/arm_cortex-a9_vfpv3/telephony

The config is

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
option check_signature 1

There are no custom feeds

What should I do next and/or what is the issue here?

Is the problem related to using sysupgrade and shoukld I do a factory.img flash instead, or simply re-upgrade without keeping settings?

Thanks for any help

Can you ping downloads.openwrt.org from the router?

Yes, I can connect through the router from my workstations without issues.

Yes, I can ping downloads.openwrt.org from the router, without issues.

The problem is about connectivity from your router to internet. If you look at the erros, the core error is that wget returns 4 as it can not do the download.

You could test wget manually from router cli.

Typical reason might be e.g. your router being a secondary router inside LAN with fixed ip witout DHCP, but no gateway or DNS has been set.

Or you have had some dnscrypt setting that is now failing due to the missing package.

Note that connectivity from your PC is a separate matter. This is purely about the router itself, so all test should be done from the router cli.

Hello hnyman,

Thanks for your reply. BTW, I am using your image on the wndr3800 and have for years. :slight_smile: Thanks for that.

On the wndr3800 which has a fiber connection to the internet I see:

Active DHCP Lease: for the WRT32X
Active DHCPv6 Leases: fdc6:bf8e:dc1c::735/128  and  fdc6:bf8e:dc1c:4::/62 both for the WRT32X.lan

On the WRX32X whose WAN interface is connected to the LAN side of the WNDR3800 I see:

Protocol: DHCP client
Uptime: 6h 3m 39s
MAC: 60:38:E0:C5:D1:70
RX: 157.63 MB (235915 Pkts.)
TX: 46.01 MB (234820 Pkts.)


Protocol: DHCPv6 client
Uptime: 6h 4m 30s
MAC: 60:38:E0:C5:D1:70
RX: 157.65 MB (236038 Pkts.)
TX: 46.02 MB (234944 Pkts.)
IPv6: fdc6:bf8e:dc1c::735/128
IPv6-PD: fdc6:bf8e:dc1c:4::/62

Trying a wget from the cli on the WRT32X fails with:

# wget http://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/packages/Packages.gz
Downloading 'http://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/packages/Packages.gz'
Connecting to 2a01:4f8:202:43ea::2:80
Connection error: Connection failed

To save some time, would doing a firmware factory install solve the problem or is the issue soemthing else you think, that would not be resolved that way?

I am feeling a bit out of my depth here. :frowning:

Thanks again for any help.

Well, those logs and error message provide a clear clue:

Sounds like a ipv6 configuration problem. Your new router does not get a public ipv6 address, only a link-local fdc6:... address, which the leads into problems as wget fails to connect. ipv6 is preferred, so the router thinks that it has ipv6 connectivity, but it does not actually have it.

Likely you have not properly configured the ipv6 downstream in WNDR3800, so the WRT32X gets an ipv6 address, which doesn't actually work for connecting internet.

OK, I am glad we are making some progress.

Being out of my depth here, I am not sure how I should configure the ipv6 downstream on the wndr3800.

Is it in the DHCP Server ipv6 settings? The Router Advertisement-Service? NDP-Proxy? Announced DNS servers? And what should be the values there to allow for my setup as in the first post here?

By the way, if it is a consideration, my isp does not provide me with ipv6 only ipv4.

Or is it elsewhere?

Thanks for any help or pointer to the documentation that may help me resolve this with some understanding.

Disable the WAN6 interface, then run a opkg update.
Also do a nslookup to make sure DNS is working.
#nslookup http://downloads.openwrt.org

Thanks stumper.

That is what I decided to do. I run part of my network (where the WRT32X is located) as a ip4 network and, presto, all problems gone.

At the end of the day I am unlikely to run out of ip4 addresses internally and I don't think there is any performance penalties for doing this.

I will re-visit ipv6 from time to time, but until such time as there is a good and comprehensive set of documentation rather than the RFC's, I will, regretfully leave it alone.

Thanks again, for all the help on this forum. OpenWRT rocks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.