Unable to get local DNS recognized on TP-Link RE650 v1

For context, I have a set-up where the Wi-Fi extender is being used as a wireless client, NOT a wireless access point, connected to a Netgear RAX70 as it would be only used for its ethernet port connected to an unmanaged network switch where all my other nearby devices would also be connected to, greatly limiting the amount of devices using Wi-Fi.

Only issue with my setup so far, after installing openwrt, is that no matter what I'm going with, be it relayd or WDS, followed by modifying my config via ssh, the server (and only server) I want to have the DNS set to (192.168.1.101) would not be advertised to the devices. Instead, it would be setting the gateway (192.168.1.1) as the DNS instead of what I would like to have it as. I have tried modifying /etc/config/network, /etc/config/wireless and /etc/config/dhcp to no avail, searching the forums for similar problems related to DNS, and also looking through the wiki. This issue only has been occuring with relayd, as WDS wouldn't work no matter what I did as what's been told on the wiki, by chance is there an issue with my install or there's something else going on that I'm missing?

How are you doing this, AFAIK relayd config (never tried WDS) disables the DHCP ?

I've tried getting the DNS to work by modifying the Interface settings, be it under Advanced Settings or DHCP Server:


2024-05-18_00-47-47
Or DNS Forwarding:
2024-05-18_00-48-21
These three methods I've seen used from other threads when attempting to resolve the issue I've been having

That's fine and dandy, but if you disable the DHCP, none of this gets used anywhere.

Pretty sure it applies to WAN and firewall too.

AFAIK, with your current setup, the only device capable of announcing the DNS IP, is the RAX70, if that's the device using the 192.168.1.1 IP.

First, on the wiki for relay configuration, wouldn't that mean this section of the guide is completely useless then?

For WDS, it wouldn't want to get an internet connection from the router despite everything I followed, by chance does the broadcom chipset that the router has prevents it from working properly? even though the stock TP-Link firmware was able to work just fine with this type of setup

Second, The atheroswds wiki page also says that DHCP should be also disabled for WLAN as well, does it mean WWAN? or that's something else entirely?

Third, when I set the mode for the wireless network to Client (WDS), there's no such thing as option wds '1' appearing in /etc/config/network unless I edit the line in myself. Is this an error on the software?

Fourth, I'm getting this issue in openwrt where LuCI is complaining about the wireless network not being associated, but when I change Network back to wwan or have it set to both lan and wwan, is this intentional?

image

image