Unable to get internet working reliably on multiple routers

I've been trying to use one of my old routers as a Wireguard VPN b/g WiFi access point for older devices. I've not been able to get any of them working reliably using any firmware, and I have no idea why. I've had the best luck with my WNDR3400 (v1) with OpenWrt so far, so that's what I'll be referring to.

I can't seem to get internet access working reliably no matter what I do. It was working fine a bit ago, but now it seems to constantly work, then not work. Here's me trying to ping Google.

My old setup was modem -> WRT1900ACv2 (with OpenWRT), and modem -> Linksys E3000 (Tomato with OpenVPN). I got symmetrical fiber, and had to reorganize my setup, so it's now modem -> WRT1900ACv2 (Now DD-WRT) -> anything. I replaced the E3000 because the network speed was terrible, it would start off ok, then just get slower and slower until it didn't work anymore. However I can't seem to get anything working reliably anymore, even the old E3000. I've tried the WR841ND (v8.2), E3000, and WRND3400 with OpenWRT, Tomato (if applicable), and DD-WRT, and just can't get anything working reliably with this setup VPN or not. I also swapped the WRT1900ACv2 from OpenWRT to DD-WRT just in case it was that, and that changed nothing. I have no idea why nothing works, and I'm about to just give up because I've spent days trying to make this work to no avail. Does anyone know how I can fix this or even seen this before?

If I have read this correctly, you have tried to change everything but the modem and the fiber connection, right? Are you sure this is a router issue, and not a modem/fiber issue?

1 Like

Well if it is, literally everything else just works connected to the router (WRT1900AC v2). What would cause specifically other routers to break?

I'm a bit confused...

This suggests that the WRT1900ACv2 works... is the correct?

So does this router work regardless if you have DD-WRT or OpenWrt, or is one working well and the other not?

Yeah it did work on both, and I get the same result with both. I'm just going to stick with DD-WRT for now because I can't be bothered to reconfigure it yet again.

ok... so problem solved??

1 Like

No, same result with both meaning I get this bs where nothing works. I literally want to smash my routers, and I already broke a bunch of plastic in one of the WR841ND's when it decided to brick itself and I threw it across the room. Maybe I should just get a switch and have the WRT1900ACv2 be the VPN shit but that costs money and I can't be bothered to spend money on something I haven't needed to use in months.

It might make sense to step away from the situation and cool down...

Ok... it's really unclear what, if any, configurations actually work. A simple table/list could be really useful (for example):

- WRT1900V2 w/ DD-WRT: Not working
- WRT1900V2 w/ OpenWrt: Not working
- < some other router > w/ < whatever firmware >: Working
- etc.

Or are you saying that not a single router on any firmware will work properly? If so, it doesn't sound like a problem with your routers, but rather your upstream connection (one or more of the following: modem/ont issue, the cable connecting to your router, and/or issues with the ISPs network).

What have you done to rule out issues with the connections upstream of your router that would prove that the problem is the router itself?

I guess I could temporarily test it from the modem, and if it's broken there then I'll know. It's just not feasible for me to actually run it from the modem itself since all ports are filled, so I never tried.

First rule of troubleshooting- break the problem down into smaller blocks and test each. Go back to first principles. In this case, does the connection from your modem/ont work reliably.

If it just one router which works then maybe it is your isp modem which is "tuned" to the MAC address of that router.

Sometimes powering down the ISP modem will set it again in learning mode, sometimes the ISP need to set it in learning mode.

Alternatively clone the MAC address

So it seems to be working for now connected directly to the modem. Not sure if it will break or not again, will have to see.

So I did more thorough testing. I went back to the E3000, and saw the same results, intermittent connectivity through WRT1900AC v2, completely fine though modem. What could cause this? It's not firmware unless both DD-WRT and OpenWrt have the issue. Why does this happen?

There are a bunch of questions that we'll need answered:

  • Is your modem a modem-only, or is it a modem+router combo device? If you're not entirely certain, what are the first 2 octets of the address you get when you plug your computer directly into the modem (in bold: aaa,bbb.ccc.ddd)
  • How are you connecting your computer and running the tests (for each the modem and the router) -- by ethernet or wifi?
  • If ethernet, are you using the same cable to connect the router to the mdeom as you did connecting your comptuer directly to the modem? What about the cable (if applicable) between the router and the computer? Have you tried other cables?
  • Are the routers in their default configuration? If not, what did you change?
  • Are there any other physical connections aside from:
    • 1 cable between the modem and the router
    • 1 cable between the router and your computer (or none if you're using wifi).

Let's start with these and see where that gets us.

2 Likes

1: It's a modem + router. I have the WiFi disabled on it because it's sandwiched between a thick concrete wall and a big metal box so... Not sure what you mean by octets, but is it 192.168.0.x?
2: I'm using wired, RJ45.
3: I haven't directly connected my laptop to the modem, only to the WRT1900ACv2 and the routers I've tried to test. I've used various cables and swapped them thinking maybe they were the issue.
4: For the modem, I disabled WiFi, I don't think I changed much else, not really sure. For the WRT1900AC v2, 2.4GHz is disabled, 5GHz is configured as 20/40 n/ac. I don't think I configured that much else, probably a few minor options, not really sure. I don't feel like resetting and seeing what all I change. The E3000 has 5GHz disabled, 2.4 is b/g, I configured Wireguard and it works connected to the modem, nothing else really major. Both are also running DD-WRT so idk if the changes or this post is even applicable here anymore.
5: The modem is connected to my main PC, my NAS, another PC (powered off), WRT1900AC v2. WRT1900AC v2 has WiFi which I have a couple phones connected to, but other than that, it's just the router for now.

Irrespective of any config, note that your devices are not the brightest lights in the room.

32 MB RAM device. Too low amount of RAM.
Very likely that you have out of memory issues on this.

64 MB RAM Broadcom device, sadly Broadcom means: Wifi from hell
(The wiki has some further clues that sound not very promising either on other parts)

64MB RAM Broadcom device, sadly Broadcom means: Wifi from hell as well

sadly another winner in the category „Wifi driver from hell“, but at least its wired LAN is decent and it has decent amount of RAM.

So be aware that you have 1 device with borderline low amount of RAM and 3 known Wifi special-needs devices.
It could be that 64MB RAM is a potential RAM issue as well, depends on what else runs on the devices.

I think, you may need to consider obtaining some better supported devices. The WRT is kind of ok as a router (as long as Wifi and HW offloading is not of high importance for you)

1 Like

For the WNDR3400/E3000 I'm going to be using 2.4GHz b/g, so it doesn't exactly need to be good. It just needs to work. I have a working config on the E3000 directly from modem, so if I get it working through router I should be good.

WRT1900AC v2 I've had no WiFi issues aside from that one time I tried a weird "security" OpenWRT build and shit just didn't work on it.

All of these devices I've either gotten for super cheap or free. I'm not about to spend a bunch of money on a router unless I can get one with 10G ports that works with a custom firmware, and even then I'm probably not going to get it anytime soon since that will be expensive.

Using what hardware you have I'd suggest a two piece system: the WRT1900 running OpenWrt as a wired router and VPN terminus, and the WR841ND with stock firmware as a dumb AP.

The open Marvell and Broadcom wifi drivers may not connect well with IoT devices, which often aren't quite standard in their wifi implementation. Test the Broadcom boxes with OpenWrt as dumb APs to evaluate wifi compatibility. If that is suitable, the VPN can then be built out.

2 Likes

I have nothing IoT, it's more for like iPhone 4s and earlier, older phones or devices I have that can't do 5GHz. If it's too old for 5GHz it likely can't run my VPN so that's my thinking for it. I guess I could have the WRT1900AC with the VPN, but I'd rather have a WiFi access point that I can use without VPN if I needed to. The E3000 in its old config with Tomato and OpenVPN was fine until the speeds died, so I think the current DD-WRT and Wireguard config should work if I can get it working connected through the WRT1900AC.

I think that every iPhone after the 3G supported 5 GHz wifi, Apple was an early adopter of it.