Unable to flash 21.02.1 in Linksys EA7500 V2 router

Hi,
I purchased 3 linksys ea7500 v2 routers trying to make use of 802.11r to establish a better roaming experience.

And I also have checked openwrt has support for ea7500 v2 from this link, so I brought 3 pecs at a time, this is the little background.

I managed to flash wrt to the first two routers without any problem, it was so smooth, however, to the third router, after flashed wrt, it always boots the OEM firmware after a reboot, I've spent a day without successful, I followed the exact instructions as follows from the tutorial link mentioned earlier,

If the flashing was unsuccessfull

1. the router will try to boot 3 times and then will automatically boot the OEM firmware.
Don’t turn off the router. Simply wait and try to reach the router through the web interface every now and then, it will take few minutes. After this, you should be back in the OEM firmware.

2. Now you have to flash the OEM Firmware over itself using the OEM web interface (I tested it using the `FW_EA7500v2_2.0.8.194281_prod.img` downloaded from the Linksys website).

3. When the router reboots flash the `factory.bin` OpenWrt image and this time it should work.

4. After the OpenWrt installation you have to use the sysupgrade image for future updates.

The wrt image I flashed is downloaded from here, the factory bin file.

But it still boots and restores to OEM firmware after a reboot, I have tried to perform reset few times without luck. I don't very understand why the third router which has the exact same specs with the other two can't get wrt flashed in, I have tested that with the OEM firmware everything works fine, WIFI and LANs work very well, it does't seem to be any hardware issue with this router, it's frustrated after a whole day without an outcome...

The problem might be with the dual boot system, it seems the router is unable to boot from wrt and then restore to OEM after 3 attempts, but I don't have any idea to force it boot from wrt.

Any help would be appreciated! thank you.

I would first suggest to flash two different OEM firmware versions to the two flash partitions and then check that both of them are working, ruling out flash errors on one of them.

Hi thank you for the suggestion, I have done the test and verified both of them are working, after flashed two different OEM firmware versions, I'm able to switch one version to the other and vice-versa by following below steps,

  1. power on the router

  2. wait 15 seconds

  3. power off the router

  4. repeat steps 1-2-3 twice more.

  5. power on the router and you should be in the “other” firmware

This is really weird.

I tried to reflash wrt via web page and capture all logs that occur in the router, I think I have found some related information, but I'm not sure what to do with them.

x=pass dqs delay value (min~max)center
y=0-7bit DQ of every group
input delay:DQS0 =29 DQS1 = 28
==================================================================
bit     DQS0     bit      DQS1
0  (1~58)29  8  (1~52)26
1  (1~50)25  9  (2~54)28
2  (1~55)28  10  (1~50)25
3  (2~55)28  11  (1~53)27
4  (1~57)29  12  (1~56)28
5  (1~50)25  13  (1~54)27
6  (1~56)28  14  (2~55)28
7  (2~56)29  15  (1~55)28
==================================================================
3.dq delay value last
==================================================================
bit|    0  1  2  3  4  5  6  7  8   9
--------------------------------------
0 |    13 7 12 8 11 7 14 3 2 9
10 |    6 12 6 10 4 9
==================================================================
==================================================================
     TX  perbyte calibration
==================================================================
DQS loop = 15, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqsdly_pass[0]=15,  finish count=1
dqs_perbyte_dly.last_dqsdly_pass[1]=15,  finish count=2
DQ loop=15, cmp_err_1 = ffff05aa
DQ loop=14, cmp_err_1 = ffff01aa
DQ loop=13, cmp_err_1 = ffff01aa
DQ loop=12, cmp_err_1 = ffff00a0
dqs_perbyte_dly.last_dqdly_pass[1]=12,  finish count=1
DQ loop=11, cmp_err_1 = ffff0080
DQ loop=10, cmp_err_1 = ffff0000
dqs_perbyte_dly.last_dqdly_pass[0]=10,  finish count=2
byte:0, (DQS,DQ)=(a,8)
byte:1, (DQS,DQ)=(9,8)
20,data:9a
[EMI] DRAMC calibration passed

===================================================================
                MT7621   stage1 code done
                CPU=50000000 HZ BUS=16666666 HZ
===================================================================


U-Boot 1.1.3 (Aug  5 2016 - 15:06:22)

SERCOMM v1.03.0, Release date: 2016/08/05

Board: Ralink APSoC DRAM:  256 MB
relocate_code Pointer at: 8ffa8000

Config XHCI 40M PLL
******************************
Software System Reset Occurred
******************************
Allocate 16 byte aligned buffer: 8ffdf070
Enable NFI Clock
# MTK NAND # : Use HW ECC
NAND ID [C2 F1 80 95 02]
Device found in MTK table, ID: c2f1, EXT_ID: 809502
Support this Device in MTK table! c2f1
select_chip
[NAND]select ecc bit:4, sparesize :64 spare_per_sector=16
Signature matched and data read!
load_fact_bbt success 1023
load fact bbt success
[mtk_nand] probe successfully!
mtd->writesize=2048 mtd->oobsize=64,    mtd->erasesize=131072  devinfo.iowidth=8
..============================================
Ralink UBoot Version: 5.0.0.0
--------------------------------------------
ASIC MT7621A DualCore (MAC to MT7530 Mode)
DRAM_CONF_FROM: Auto-Detection
DRAM_TYPE: DDR3
DRAM bus: 16 bit
Xtal Mode=3 OCP Ratio=1/3
Flash component: NAND Flash
Date:Aug  5 2016  Time:15:06:22
============================================
icache: sets:256, ways:4, linesz:32 ,total:32768
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 880 MHZ ####
 estimate memory size =256 Mbytes
#Reset_MT7530
set LAN/WAN WLLLL

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.                                                                           0

#### auto_recovery ####

check env def auto_recovery no
check env def auto_recovery yes
check env def boot_part 1
check env def boot_part_ready 3
enabled:1, boot_part:1, boot_part_ready:3
..nand read ret = 0x20000
boot_count:0, next_record:62
boot_count:0, next_record:62

3: System Boot system code via Flash.
## Booting image at bc180000 ...
   Image Name:   MIPS OpenWrt Linux-5.4.154
   Image Type:   MIPS Linux Kernel Image (uncompressed)
   Data Size:    2367183 Bytes =  2.3 MB
   Load Address: 80001000
   Entry Point:  80001000
................................ranand_read: skip reading a fact bad block 380000 -> 3a0000
.....   Verifying Checksum ... OK
OK
No initrd
## Transferring control to Linux (at address 80001000) ...
## Giving linux memsize in MB, 256

Starting kernel ...



OpenWrt kernel loader for MIPS based SoC
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Decompressing kernel... done!
Starting kernel at 80001000...

[    0.000000] Linux version 5.4.154 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16325-88151b8303)) #0 SMP Sun Oct 24 09:01:35 2021
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is Linksys EA7500 v2
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000]   HighMem  empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] percpu: Embedded 14 pages/cpu s26768 r8192 d22384 u57344
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 64960
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes, linear)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Writing ErrCtl register=00014121
[    0.000000] Readback ErrCtl register=00014121
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 250788K/262144K available (6089K kernel code, 210K rwdata, 748K rodata, 1260K init, 238K bss, 11356K reserved, 0K cma-reserved, 0K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 25 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] random: get_random_bytes called from 0x806e5a3c with crng_init=0
[    0.000000] CPU Clock: 880MHz
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4343773742 ns
[    0.000008] sched_clock: 32 bits at 440MHz, resolution 2ns, wraps every 4880645118ns
[    0.007812] Calibrating delay loop... 583.68 BogoMIPS (lpj=1167360)
[    0.042012] pid_max: default: 32768 minimum: 301
[    0.046787] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.054014] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.064453] rcu: Hierarchical SRCU implementation.
[    0.069894] smp: Bringing up secondary CPUs ...
[    9.066967] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    9.066978] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    9.066990] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    9.067090] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.102652] Synchronize counters for CPU 1: done.
[    9.128282] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    9.128292] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    9.128300] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    9.128357] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.167367] Synchronize counters for CPU 2: done.
[    9.189674] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    9.189684] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    9.189693] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    9.189755] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.225227] Synchronize counters for CPU 3: done.
[    0.255106] smp: Brought up 1 node, 4 CPUs
[    0.263634] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.273322] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.280396] pinctrl core: initialized pinctrl subsystem
[    0.287223] NET: Registered protocol family 16
[    0.315137] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.326437] clocksource: Switched to clocksource GIC
[    0.332916] thermal_sys: Registered thermal governor 'step_wise'
[    0.333403] NET: Registered protocol family 2
[    0.343972] IP idents hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.352053] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.360444] TCP established hash table entries: 2048 (order: 1, 8192 bytes, linear)
[    0.368043] TCP bind hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.375131] TCP: Hash tables configured (established 2048 bind 2048)
[    0.381557] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.388046] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.395252] NET: Registered protocol family 1
[    0.399578] PCI: CLS 0 bytes, default 32
[    0.494410] 4 CPUs re-calibrate udelay(lpj = 1163264)
[    0.501114] workingset: timestamp_bits=14 max_order=16 bucket_order=2
[    0.508374] random: fast init done
[    0.520575] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.526363] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.537871] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.547163] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.553019] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.558869] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.565276] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.575418] printk: console [ttyS0] disabled
[    0.579720] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 19, base_baud = 3125000) is a 16550A
[    0.588705] printk: console [ttyS0] enabled
[    0.588705] printk: console [ttyS0] enabled
[    0.596962] printk: bootconsole [early0] disabled
[    0.596962] printk: bootconsole [early0] disabled
[    0.608871] mt7621-nand 1e003000.nand: Using programmed access timing: 31c07388
[    0.616461] nand: device found, Manufacturer ID: 0xc2, Chip ID: 0xf1
[    0.622811] nand: Macronix MX30LF1G18AC
[    0.626648] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    0.634201] mt7621-nand 1e003000.nand: ECC strength adjusted to 4 bits
[    0.640751] mt7621-nand 1e003000.nand: Using programmed access timing: 21005134
[    0.648050] mt7621-nand 1e003000.nand: Using programmed access timing: 21005134
[    0.655344] Scanning device for bad blocks
[    0.695528] Bad eraseblock 28 at 0x000000380000
[    1.883333] Bad eraseblock 963 at 0x000007860000
[    1.964014] 11 fixed-partitions partitions found on MTD device mt7621-nand
[    1.970876] Creating 11 MTD partitions on "mt7621-nand":
[    1.976187] 0x000000000000-0x000000080000 : "boot"
[    1.982320] 0x000000080000-0x0000000c0000 : "u_env"
[    1.988662] 0x0000000c0000-0x000000100000 : "factory"
[    1.995129] 0x000000100000-0x000000140000 : "s_env"
[    2.001459] 0x000000140000-0x000000180000 : "devinfo"
[    2.007818] 0x000000180000-0x000000580000 : "kernel"
[    2.014235] 0x000000580000-0x000002980000 : "ubi"
[    2.020460] 0x000002980000-0x000002d80000 : "alt_kernel"
[    2.027321] 0x000002d80000-0x000005180000 : "alt_rootfs"
[    2.034156] 0x000005180000-0x000005280000 : "sysdiag"
[    2.040718] 0x000005280000-0x000007f80000 : "syscfg"
[    2.048603] libphy: Fixed MDIO Bus: probed
[    2.076811] libphy: mdio: probed
[    2.080300] mt7530 mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.088697] mtk_soc_eth 1e100000.ethernet: generated random MAC address 9a:87:16:a4:17:d2
[    2.097745] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 21
[    2.108285] mt7621-pci 1e140000.pcie: Parsing DT failed
[    2.116330] NET: Registered protocol family 10
[    2.122261] Segment Routing with IPv6
[    2.126077] NET: Registered protocol family 17
[    2.130631] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    2.143815] 8021q: 802.1Q VLAN Support v1.8
[    2.149963] mt7530 mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.166367] libphy: dsa slave smi: probed
[    2.170846] mt7530 mdio-bus:1f wan (uninitialized): PHY [dsa-0.0:00] driver [Generic PHY]
[    2.180499] mt7530 mdio-bus:1f lan1 (uninitialized): PHY [dsa-0.0:01] driver [Generic PHY]
[    2.190238] mt7530 mdio-bus:1f lan2 (uninitialized): PHY [dsa-0.0:02] driver [Generic PHY]
[    2.199936] mt7530 mdio-bus:1f lan3 (uninitialized): PHY [dsa-0.0:03] driver [Generic PHY]
[    2.209675] mt7530 mdio-bus:1f lan4 (uninitialized): PHY [dsa-0.0:04] driver [Generic PHY]
[    2.219498] mt7530 mdio-bus:1f: configuring for fixed/rgmii link mode
[    2.230737] DSA: tree 0 setup
[    2.234051] rt2880-pinmux pinctrl: pcie is already enabled
[    2.239686] mt7621-pci-phy 1e149000.pcie-phy: PHY for 0xbe149000 (dual port = 1)
[    2.247277] mt7621-pci-phy 1e14a000.pcie-phy: PHY for 0xbe14a000 (dual port = 0)
[    2.354362] mt7621-pci-phy 1e149000.pcie-phy: Xtal is 40MHz
[    2.359946] mt7621-pci-phy 1e14a000.pcie-phy: Xtal is 40MHz
[    2.465153] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    2.472106] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    2.476977] mt7621-pci 1e140000.pcie: PCIE1 enabled
[    2.481855] mt7621-pci 1e140000.pcie: PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    2.491318] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    2.497685] pci_bus 0000:00: root bus resource [io  0x1e160000-0x1e16ffff]
[    2.504554] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    2.511421] pci_bus 0000:00: root bus resource [bus 00-ff]
[    2.516940] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    2.522975] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    2.529238] pci 0000:00:00.0: reg 0x14: [mem 0x60200000-0x6020ffff]
[    2.535584] pci 0000:00:00.0: supports D1
[    2.539594] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    2.545737] pci 0000:00:01.0: [0e8d:0801] type 01 class 0x060400
[    2.551779] pci 0000:00:01.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    2.558043] pci 0000:00:01.0: reg 0x14: [mem 0x60210000-0x6021ffff]
[    2.564363] pci 0000:00:01.0: supports D1
[    2.568373] pci 0000:00:01.0: PME# supported from D0 D1 D3hot
[    2.575777] pci 0000:01:00.0: [14c3:7615] type 00 class 0x000280
[    2.581844] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    2.588791] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5 GT/s x1 link)
[    2.603987] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    2.609228] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    2.615318] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    2.622101] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    2.628949] pci 0000:02:00.0: [14c3:7615] type 00 class 0x000280
[    2.635012] pci 0000:02:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    2.641954] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s x1 link at 0000:00:01.0 (capable of 4.000 Gb/s with 5 GT/s x1 link)
[    2.657162] pci 0000:00:01.0: PCI bridge to [bus 02-ff]
[    2.662422] pci 0000:00:01.0:   bridge window [io  0x0000-0x0fff]
[    2.668506] pci 0000:00:01.0:   bridge window [mem 0x60100000-0x601fffff]
[    2.675291] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    2.681941] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    2.688548] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.695502] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    2.702105] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.709060] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    2.715843] pci 0000:00:01.0: BAR 8: assigned [mem 0x60100000-0x601fffff]
[    2.722626] pci 0000:00:00.0: BAR 1: assigned [mem 0x60200000-0x6020ffff]
[    2.729409] pci 0000:00:01.0: BAR 1: assigned [mem 0x60210000-0x6021ffff]
[    2.736194] pci 0000:00:00.0: BAR 7: assigned [io  0x1e160000-0x1e160fff]
[    2.742977] pci 0000:00:01.0: BAR 7: assigned [io  0x1e161000-0x1e161fff]
[    2.749763] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff 64bit]
[    2.757073] pci 0000:00:00.0: PCI bridge to [bus 01]
[    2.762036] pci 0000:00:00.0:   bridge window [io  0x1e160000-0x1e160fff]
[    2.768817] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    2.775606] pci 0000:02:00.0: BAR 0: assigned [mem 0x60100000-0x601fffff 64bit]
[    2.782914] pci 0000:00:01.0: PCI bridge to [bus 02]
[    2.787876] pci 0000:00:01.0:   bridge window [io  0x1e161000-0x1e161fff]
[    2.794661] pci 0000:00:01.0:   bridge window [mem 0x60100000-0x601fffff]
[    2.801986] mt7530 mdio-bus:1f: Link is Up - 1Gbps/Full - flow control off
[    2.809957] UBI error: no valid UBI magic found inside mtd6
[    2.815593] hctosys: unable to open rtc device (rtc0)
[    2.821429] /dev/root: Can't open blockdev
[    2.825540] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    2.832999] Please append a correct "root=" boot option; here are the available partitions:
[    2.841336] 1f00             512 mtdblock0
[    2.841340]  (driver?)
[    2.847869] 1f01             256 mtdblock1
[    2.847872]  (driver?)
[    2.854407] 1f02             256 mtdblock2
[    2.854410]  (driver?)
[    2.860927] 1f03             256 mtdblock3
[    2.860930]  (driver?)
[    2.867465] 1f04             256 mtdblock4
[    2.867468]  (driver?)
[    2.873983] 1f05            4096 mtdblock5
[    2.873986]  (driver?)
[    2.880532] 1f06           36864 mtdblock6
[    2.880535]  (driver?)
[    2.887069] 1f07            4096 mtdblock7
[    2.887072]  (driver?)
[    2.893590] 1f08           36864 mtdblock8
[    2.893593]  (driver?)
[    2.900124] 1f09            1024 mtdblock9
[    2.900127]  (driver?)
[    2.906665] 1f0a           46080 mtdblock10
[    2.906668]  (driver?)
[    2.913273] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    2.921531] Rebooting in 1 seconds..

See there is a '................................ranand_read: skip reading a fact bad block 380000 -> 3a0000' and

 mt7530 mdio-bus:1f: Link is Up - 1Gbps/Full - flow control off
[    2.809957] UBI error: no valid UBI magic found inside mtd6
[    2.815593] hctosys: unable to open rtc device (rtc0)
[    2.821429] /dev/root: Can't open blockdev
[    2.825540] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    2.832999] Please append a correct "root=" boot option; here are the available partitions:
[    2.841336] 1f00             512 mtdblock0
.....
[    2.906668]  (driver?)
[    2.913273] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    2.921531] Rebooting in 1 seconds..

exceptions which made the router reboots 3 time to back to OEM version.

Making one more update here,

I finally managed to flash the image via serial port (with TFTP), I firstly have tested flashing to partition 1 and it just boots to the OEM firmware, then flashed to partition 2, 3 time reboots back to OEM again, the exceptions are exactly the same as above, then I flashed to both partitions and it falls into infinite loop.

The critical error is this,

[    2.810815] UBI error: no valid UBI magic found inside mtd6
[    2.822104] hctosys: unable to open rtc device (rtc0)
[    2.827963] /dev/root: Can't open blockdev
[    2.832075] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    2.839533] Please append a correct "root=" boot option; here are the available partitions:

But if there is a hardware issue, why the OEM firmware works without any problem?

Make a last update here,

I ended up with flashed the KERNAL bin to this router via serial port and turns out no wireless is available, also tried to make an upgrade after the KERNAL bin with no change, flashing factory bin in either way is not possible.

So for the router EA7500 V2 you got chance to flash unsuccessful.