Unable to establish internet connection for an OpenWrt based Bridged-AP/Repeater config


#1

Greetings forum members. Kindly bear with my noviceness as I am a newbie for this kind of a setup/config.

Setup -
A TL-WR841NDV11 in AP mode with an OpenWRT 18.06 is my home's primary router (to which cellphones, laptops connect). And willingness to add a range extender for my desktop computer.

Home router is on 192.168.1.2
The desired AP is on 192.168.1.1
[If either or both need to have an IP change, please tell me what it should be and how? /etc/config/network?]

Aim - To include a TP-Link WR940NV6 Multi-mode router with O-WRT enabled firmware to the primary home router as a range extender for a desktop to which the PC can have internet connectivity via the range extender through a RJ-45 port.
[The same setup works fine with the TP Link's factory firmware (snapshots inlcuded). But not with O-WRT].

WR940N%20working

The reason why I want to do this is coz I feel using O-WRT on all my routers would prove beneficial to me now and also in the future. And I also believe I can get this running, but with some help of course!

Steps tried -
O-WRT firmware -
O-WRT 18.06.1 r7258-5eb055306f / LuCI O-WRT-18.06 branch (git-18.228.31946-f64b152)
Kernel Version 4.9.120

I've been working on this for the past four days and found out on multiple occassions that how NOT to configure this!

[I also checked a few other related topics prior posting this. But I couldn't latch on to anything!

Below are the different instructionals that I have followed so far;

https://O-WRT.org/docs/guide-user/network/wan/internet.connection
https://O-WRT.org/docs/guide-user/network/wifi/bridgedap

http://javier.io/blog/en/2014/06/10/installing-O-WRT-as-wireless-repeater.html


(Mute the background music)

I also changed the primary router's default O-WRT IP from, 192.168.1.1 to 192.168.1.2 -- This was done very later in the troubleshooting attempts, thinking that if the primary router is on a separate IP, configuring the second router on 192.168.1.1 would be a bit convenient (avoiding the IP conflicts and configuration related to the same default IP/setting).

I'm certain that I am missing something here. Could be due to my limited knowledge of O-WRT or networks in general.

I'm in dire need of your gracious assistance

Situation - After all the setups built from the above mentioned links, I still can't get the WR940 router to connect to the internet with the O-WRT firmware. A blue LED on the device glows as soon as the router is online (internet). But this is NOT happening at all.

The ping requests dont go through either -

However, the pings from the opernwrt shell goes through

The same setup works fine (snapshots inlcuded above) with the TP Link's factory firmware.

After immense retries, reboots and eventually listening to a heavenly voice, it prompted me to post my ongoing issue on this forum.
:slight_smile:

I'm willing to troubleshoot this further with proper guidance.

Do let me know if you all require screenshots as I have taken a few (but restricted by this site to upload).

Thanks again for your time!!


#2

Could you copy here the contents of /etc/config/network /etc/config/wireless /etc/config/firewall?
Connect to the router by ssh and run the command cat followed by the file above.


#3

Key point: Use WDS. Set the main router's wifi AP to AP(WDS) mode instead of regular AP.

The setup of the repeater router is called a "dumb AP". This entails these major points:

  • LAN IP address in the same range but different from the main router's LAN IP
  • DHCP server turned off (both IPv4 and IPv6)
  • WAN network not used. All interfaces are bridged into one network, the lan.
  • A regular AP interface bridged into the lan to serve nearby WiFi users. This AP can have the same SSID as your main router, but for initial testing make it different to clarify the operation.
  • (as is the default) Ethernet ports bridged into the lan to serve wired users
  • Since everything is in one network, the router does no routing or firewalling. Thus the name "dumb AP".

The link from your dumb AP to the main router can be wired or wireless (WDS). Start by connecting them in the same room with an Ethernet cable (LAN port to LAN port). After that works you can set up a wireless client on the repeater router, and disconnect the cable. This would be an additional wifi interface having:

  • mode Client(WDS)
  • SSID and encryption match the main router's AP. "BSSID" can be left blank. I suggest configuring this manually rather than using the "Join Network" button on the scan page.
  • attached to the LAN network.

#4

Thank you Trendy & mk!

I'll have these things done and update the thread accordingly.

I may need some additional time though.


#5

@trendy, thanks for trying to help me out. But the issue is fixed!

@mk24 - A BIG thank you to you. Guys, a HUGE round of applause to 'mk' for providing me with an on-point solution. Those days of struggle earlier, now seem to ease away!

I followed your instructions step-by-step and it worked like magic! Good job my friend... and thanks once again!

Also, I have two things to clarify:-

  1. How is it that I only get internet access via the LAN port and not the WAN port of the dummy AP?
    Is it because all of the bridged config is now pointing to the LAN interface on O-WRT?

  2. At the moment, I'm running both the primary and the secondary routers on channel 13@20Mhz, is that fine? Or should it be something else?

This is how my current setup looks like:

ScreenShot095


#6

For 1, you can make all 5 ports on the router usable as LAN ports by moving the WAN port (I think it is eth0 on that model) into the LAN bridge. The wan network can be entirely deleted, or you can leave it in place with no interfaces in the physical settings.

Channel selection depends on what channels your neighbors are using. A smartphone with an app like Wifi Analyzer is useful to find out which channels are in use and where they are strongest. Only try using 40 MHz if there are no neighboring wifi signals at all.

Both routers must operate on the same channel since they are sending data to each other. If you change the AP (main router) channel, the client will search and follow it to the new channel even if you tried to explicitly set a channel in the client. Note that while the client is searching for its AP, any AP interfaces on the same radio will go off the air. This can be a problem if you move out of range, change the settings of the main router or take it off the air, you will need to use Ethernet to log in to the client.


#7

Thanks Mike! Good pointers here. I'll make a note of it.