Unable to enable WDS repeater on DFS channels

I'm using a wrt1900acs if that matters.

I have it configured as a WDS repeater, but this only works when the channel is set on the main router (a bt home hub 5 also running openwrt) and repeater to 36 (a non DFS channel). When I set the channel on my main router and repeater to "auto", and it selects a DFS frequency, the second interface on the repeater doesn't enable, and I have a lot of errors in my system log that say:
daemon.warn hostapd: Failed to check if DFS is required; ret=-1

Is there any way to fix this? The only non DFS channel my router works on is 36 and it's congested where I am.

a better option would be to set a different channel manualy.
like set a specific fixded channel on the two machine, no autochannel.

Second what @bricco1981 said, i have a wrt1200 and from everything i've read the dfs implementation is pretty poor on the new wrt series, i've never had a dfs channel work on mine, wds or otherwise.

strange, my wrt3200 run on channel 100, never go down.

hello, how made you this?

i just made a nice pizza.

thx, nice :slight_smile:

are you disable DFS?

That does seem to have worked, I set both to channel 100 and they seem to be working, thanks.

I do wonder though, if DFS forces the main router to change channel, will the repeater follow?

sometime yes sometime no. if you have stable ap, the client will be ok.

AP and client at the same time on a DFS channel isn't possible on all drivers. I think ath10k also has this limitation.

1 Like