Unable to consistently reach 1.2gbps (or disable WMM)

Hi all,

First-time OpenWRT user here. I flashed my WAX202 Netgear modem today, rooted in with SSH, and installed the Luci GUI. After some setup, I enabled the 5ghz band in AX mode and selected my channel (112).

I have a gigabit internet plan. With stock firmware, I could hit gigabit speeds (or close to them). I am now maxing out around 400mbps after installing OpenWRT, about half of my prior speeds.

In the connection, I see that it oscillates between 600mbps and 1.2 Gbps fairly often. I can understand maxing out at 400mbps if the connection is limited to 600mbps rate, but even when at 1.2 gbps I am still limited to that rate.

I think the problem is that WMM is enabled, which is a form of QoS (right?). I have tried to disable WMM, but the router never accepts the change and reverts back to the old settings after it is unable to connect.

Any tips on how to disable WMM? Is that the problem, or is there some other setting I can tweak?

Thanks!

WMM is a hard requirement of 802.11n and newer - if you disable it, you're down to 54 MBit/s.

1 Like

Yes, I see that now! Thank you!

I am curious though about why it seems limited to 600mbps. Is there QoS enabled by default?

Edit: Hmm, after rebooting things, it seems I am connected at 1.2 gbps according to my adapter in Windows. Getting slow speeds but it is network wide. Will update later.